Skip to content

Commit ace8593

Browse files
Poncewillysr
authored andcommitted
system/virt-manager: Updated for version 5.0.0, switch to meson.
...and, unfortunately, the stock one in 15.0 is a bit old Signed-off-by: Matteo Bernardini <[email protected]> Signed-off-by: Willy Sudiarto Raharjo <[email protected]>
1 parent 6b39d08 commit ace8593

File tree

2 files changed

+26
-11
lines changed

2 files changed

+26
-11
lines changed

system/virt-manager/virt-manager.SlackBuild

+22-7
Original file line numberDiff line numberDiff line change
@@ -9,7 +9,7 @@
99
cd $(dirname $0) ; CWD=$(pwd)
1010

1111
PRGNAM=virt-manager
12-
VERSION=${VERSION:-4.1.0}
12+
VERSION=${VERSION:-5.0.0}
1313
BUILD=${BUILD:-1}
1414
TAG=${TAG:-_SBo}
1515
PKGTYPE=${PKGTYPE:-tgz}
@@ -22,9 +22,6 @@ if [ -z "$ARCH" ]; then
2222
esac
2323
fi
2424

25-
# If the variable PRINT_PACKAGE_NAME is set, then this script will report what
26-
# the name of the created package would be, and then exit. This information
27-
# could be useful to other scripts.
2825
if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
2926
echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
3027
exit 0
@@ -54,7 +51,7 @@ rm -rf $PKG
5451
mkdir -p $TMP $PKG $OUTPUT
5552
cd $TMP
5653
rm -rf $PRGNAM-$VERSION
57-
tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
54+
tar xvf $CWD/$PRGNAM-$VERSION.tar.?z
5855
cd $PRGNAM-$VERSION
5956
chown -R root:root .
6057
find -L . \
@@ -63,8 +60,26 @@ find -L . \
6360
\( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
6461
-exec chmod 644 {} \;
6562

66-
python3 setup.py configure
67-
python3 setup.py install --root=$PKG
63+
PYVER=$(python3 -c 'import sys; print("%d.%d" % sys.version_info[:2])')
64+
export PYTHONPATH=/opt/python$PYVER/site-packages
65+
66+
mkdir build
67+
cd build
68+
CFLAGS="$SLKCFLAGS" \
69+
CXXFLAGS="$SLKCFLAGS" \
70+
meson .. \
71+
--buildtype=release \
72+
--infodir=/usr/info \
73+
--libdir=/usr/lib${LIBDIRSUFFIX} \
74+
--localstatedir=/var \
75+
--mandir=/usr/man \
76+
--prefix=/usr \
77+
--sysconfdir=/etc \
78+
-Dstrip=true \
79+
-D default-hvs=qemu,lxc
80+
"${NINJA:=ninja}"
81+
DESTDIR=$PKG $NINJA install
82+
cd ..
6883

6984
find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
7085
| cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true

system/virt-manager/virt-manager.info

+4-4
Original file line numberDiff line numberDiff line change
@@ -1,10 +1,10 @@
11
PRGNAM="virt-manager"
2-
VERSION="4.1.0"
2+
VERSION="5.0.0"
33
HOMEPAGE="http://virt-manager.org/"
4-
DOWNLOAD="https://releases.pagure.org/virt-manager/virt-manager-4.1.0.tar.gz"
5-
MD5SUM="8bf86bcc7e43a956ff94ebdaf4d7d399"
4+
DOWNLOAD="https://releases.pagure.org/virt-manager/virt-manager-5.0.0.tar.xz"
5+
MD5SUM="83b4c8dec30d445fc7117f6dc7418315"
66
DOWNLOAD_x86_64=""
77
MD5SUM_x86_64=""
8-
REQUIRES="libosinfo libvirt-glib libvirt-python gtk-vnc spice-gtk"
8+
REQUIRES="libosinfo libvirt-glib libvirt-python gtk-vnc spice-gtk python3-meson-opt"
99
MAINTAINER="Robby Workman"
1010

0 commit comments

Comments
 (0)