Skip to content

Commit 21cb752

Browse files
committed
bump version to 1.3.2
1 parent 4f2692e commit 21cb752

File tree

3 files changed

+5
-12
lines changed

3 files changed

+5
-12
lines changed

Makefile

+4-6
Original file line numberDiff line numberDiff line change
@@ -1,19 +1,19 @@
11
#
22
# Copyright (C) 2015 OpenWrt-dist
33
#
4-
# This is free software, licensed under the MIT.
5-
# See /LICENSE for more information.
4+
# This is free software, licensed under the GPLv3.
5+
# See /COPYING for more information.
66
#
77

88
include $(TOPDIR)/rules.mk
99

1010
PKG_NAME:=ChinaDNS
11-
PKG_VERSION:=1.3.1
11+
PKG_VERSION:=1.3.2
1212
PKG_RELEASE:=1
1313

1414
PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
1515
PKG_SOURCE_URL:=https://github.com/aa65535/openwrt-chinadns/releases/download/v$(PKG_VERSION)
16-
PKG_MD5SUM:=a68bd997f3d69291605f69e93c1514c2
16+
PKG_MD5SUM:=c529ac231aed4e5874251639f77e92de
1717

1818
PKG_LICENSE:=GPLv3
1919
PKG_LICENSE_FILES:=COPYING
@@ -41,14 +41,12 @@ endef
4141

4242
define Package/ChinaDNS/conffiles
4343
/etc/config/chinadns
44-
/etc/chinadns_iplist.txt
4544
/etc/chinadns_chnroute.txt
4645
endef
4746

4847
define Package/ChinaDNS/install
4948
$(INSTALL_DIR) $(1)/etc/init.d
5049
$(INSTALL_BIN) ./files/chinadns.init $(1)/etc/init.d/chinadns
51-
$(INSTALL_CONF) $(PKG_BUILD_DIR)/iplist.txt $(1)/etc/chinadns_iplist.txt
5250
$(INSTALL_CONF) $(PKG_BUILD_DIR)/chnroute.txt $(1)/etc/chinadns_chnroute.txt
5351
$(INSTALL_DIR) $(1)/etc/config
5452
$(INSTALL_DATA) ./files/chinadns.config $(1)/etc/config/chinadns

files/chinadns.config

-2
Original file line numberDiff line numberDiff line change
@@ -1,9 +1,7 @@
11

22
config chinadns
33
option enable '1'
4-
option compression '1'
54
option bidirectional '0'
65
option chnroute '/etc/chinadns_chnroute.txt'
76
option port '5353'
87
option server '114.114.114.114,8.8.4.4'
9-

files/chinadns.init

+1-4
Original file line numberDiff line numberDiff line change
@@ -36,13 +36,10 @@ start_chinadns() {
3636
[ "$enable" = 1 ] || return 0
3737
append_parm $1 port "-p"
3838
append_parm $1 server "-s"
39-
append_parm $1 iplist "-l"
4039
append_parm $1 chnroute "-c"
41-
append_bool $1 compression "-m"
42-
append_parm $1 result_delay "-y"
4340
append_bool $1 bidirectional "-d"
4441
service_start /usr/bin/chinadns \
45-
$parms
42+
$parms -m
4643
return $?
4744
}
4845

0 commit comments

Comments
 (0)