Commit 21cb752 1 parent 4f2692e commit 21cb752 Copy full SHA for 21cb752
File tree 3 files changed +5
-12
lines changed
3 files changed +5
-12
lines changed Original file line number Diff line number Diff line change 1
1
#
2
2
# Copyright (C) 2015 OpenWrt-dist
3
3
#
4
- # This is free software, licensed under the MIT .
5
- # See /LICENSE for more information.
4
+ # This is free software, licensed under the GPLv3 .
5
+ # See /COPYING for more information.
6
6
#
7
7
8
8
include $(TOPDIR ) /rules.mk
9
9
10
10
PKG_NAME: =ChinaDNS
11
- PKG_VERSION: =1.3.1
11
+ PKG_VERSION: =1.3.2
12
12
PKG_RELEASE: =1
13
13
14
14
PKG_SOURCE: =$(PKG_NAME ) -$(PKG_VERSION ) .tar.gz
15
15
PKG_SOURCE_URL: =https://github.com/aa65535/openwrt-chinadns/releases/download/v$(PKG_VERSION )
16
- PKG_MD5SUM: =a68bd997f3d69291605f69e93c1514c2
16
+ PKG_MD5SUM: =c529ac231aed4e5874251639f77e92de
17
17
18
18
PKG_LICENSE: =GPLv3
19
19
PKG_LICENSE_FILES: =COPYING
@@ -41,14 +41,12 @@ endef
41
41
42
42
define Package/ChinaDNS/conffiles
43
43
/etc/config/chinadns
44
- /etc/chinadns_iplist.txt
45
44
/etc/chinadns_chnroute.txt
46
45
endef
47
46
48
47
define Package/ChinaDNS/install
49
48
$(INSTALL_DIR ) $(1 ) /etc/init.d
50
49
$(INSTALL_BIN ) ./files/chinadns.init $(1 ) /etc/init.d/chinadns
51
- $(INSTALL_CONF ) $(PKG_BUILD_DIR ) /iplist.txt $(1 ) /etc/chinadns_iplist.txt
52
50
$(INSTALL_CONF ) $(PKG_BUILD_DIR ) /chnroute.txt $(1 ) /etc/chinadns_chnroute.txt
53
51
$(INSTALL_DIR ) $(1 ) /etc/config
54
52
$(INSTALL_DATA ) ./files/chinadns.config $(1 ) /etc/config/chinadns
Original file line number Diff line number Diff line change 1
1
2
2
config chinadns
3
3
option enable '1'
4
- option compression '1'
5
4
option bidirectional '0'
6
5
option chnroute '/etc/chinadns_chnroute.txt'
7
6
option port '5353'
8
7
option server '114.114.114.114,8.8.4.4'
9
-
Original file line number Diff line number Diff line change @@ -36,13 +36,10 @@ start_chinadns() {
36
36
[ " $enable " = 1 ] || return 0
37
37
append_parm $1 port " -p"
38
38
append_parm $1 server " -s"
39
- append_parm $1 iplist " -l"
40
39
append_parm $1 chnroute " -c"
41
- append_bool $1 compression " -m"
42
- append_parm $1 result_delay " -y"
43
40
append_bool $1 bidirectional " -d"
44
41
service_start /usr/bin/chinadns \
45
- $parms
42
+ $parms -m
46
43
return $?
47
44
}
48
45
You can’t perform that action at this time.
0 commit comments