diff --git a/dev-lang/tcl/Manifest b/dev-lang/tcl/Manifest
index f7132426671a7..bfb32e9cdaaea 100644
--- a/dev-lang/tcl/Manifest
+++ b/dev-lang/tcl/Manifest
@@ -1,3 +1,4 @@
+DIST tcl-core8.6.10-src.tar.gz 6008840 BLAKE2B 592f708492e56da3577f190adc3da4f2979f32a570dfc29cb53fde58a83d804223dfe9527b76d094de3005a6e12dda73674573bab3af2e591b4573163b81b9c0 SHA512 de31ac8fc5226c831198af88befa05ccb1842dcfd209690e25b907f062033b3ae7a77bc12e85c4210ce85cfd7c598060e03fc81b0e624d422bfe4df655cc9068
 DIST tcl-core8.6.8-src.tar.gz 5887483 BLAKE2B 2b8428652e451b817fe63a811f910001929cdcbc8a8361cdf4f7df8e13cbf9b18c94a91c22c0f09cc46dc0174a66c44774b485539a8f24c14faee6658547b6b8 SHA512 36e6079b582c205e8c89435b361ef96550541357f473aea2ca4e6f01bd84e50ebd1474a75a1ae90640b9a5b392fb01ddfa71f0fa28e409b3569d88c32b4ddb69
 DIST tcl-core8.6.9-src.tar.gz 5932010 BLAKE2B ddc0cff12aeeebbf8d1c799db9e154a9ecbe2a2e2afce97c6f15c408301b7a40119bd1c861aa724c178bd9abfe0616c7bcafd9cf6714ed49cf882c9085222cf3 SHA512 306a38a27729b764bae2eae6c4cdd8cd6aee5de6bd924d6a487c8691ee874e4459abc1fa785183c2f6ff4d2d57be98093dd7460c5a668cf994e8f1c31516ae67
 DIST tcl8.5.17-src.tar.gz 4546317 BLAKE2B 27031dd3bd5790d03692e77edf91eb7fae8a40d8d193d8c8ce4e79b21f90e683bfc9d5b71764760223987fb163be844e6096d0aea1058b8ce255731d97e2a0ea SHA512 ad5ddb4cd6378fd6bbea8cd85ceb1cf90392b2e8c49fbfb3e4b35c81d3ae3e3f087697c41fcba8c8e06de1d9e7539397e26d58b864dc01ba65abe4ba4efa9568
diff --git a/dev-lang/tcl/files/tcl-8.6.10-multilib.patch b/dev-lang/tcl/files/tcl-8.6.10-multilib.patch
new file mode 100644
index 0000000000000..329d5614e7828
--- /dev/null
+++ b/dev-lang/tcl/files/tcl-8.6.10-multilib.patch
@@ -0,0 +1,11 @@
+--- a/unix/configure.in	2020-12-26 10:39:12.107965844 +0100
++++ b/unix/configure.in	2020-12-26 10:39:44.821378776 +0100
+@@ -773,7 +773,7 @@
+ 
+ eval "TCL_LIB_FILE=${TCL_LIB_FILE}"
+ 
+-test -z "$TCL_LIBRARY" && TCL_LIBRARY='$(prefix)/lib/tcl$(VERSION)'
++test -z "$TCL_LIBRARY" && TCL_LIBRARY='$(libdir)/tcl$(VERSION)'
+ PRIVATE_INCLUDE_DIR='$(includedir)'
+ HTML_DIR='$(DISTDIR)/html'
+ 
diff --git a/dev-lang/tcl/tcl-8.6.10.ebuild b/dev-lang/tcl/tcl-8.6.10.ebuild
new file mode 100644
index 0000000000000..be6d50c628280
--- /dev/null
+++ b/dev-lang/tcl/tcl-8.6.10.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib-minimal toolchain-funcs
+
+MY_P="${PN}${PV}"
+
+DESCRIPTION="Tool Command Language"
+HOMEPAGE="http://www.tcl.tk/"
+SRC_URI="mirror://sourceforge/tcl/${PN}-core${PV}-src.tar.gz"
+
+LICENSE="tcltk"
+SLOT="0/8.6"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="debug +threads"
+
+RDEPEND=">=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+SPARENT="${WORKDIR}/${MY_P}"
+S="${SPARENT}"/unix
+
+PATCHES=(
+	"${FILESDIR}"/${P}-multilib.patch
+	"${FILESDIR}"/${PN}-8.6.8-conf.patch # Bug 125971
+	"${FILESDIR}"/${PN}-8.6.9-include-spec.patch # Bug 731120
+)
+
+src_prepare() {
+	find \
+		"${SPARENT}"/compat/* \
+		"${SPARENT}"/doc/try.n \
+		-delete || die
+
+	pushd "${SPARENT}" &>/dev/null || die
+	default
+	popd &>/dev/null || die
+
+	# httpold tests require netowk
+	rm ../tests/httpold.test \
+		../tests/env.test \
+		../tests/http.test \
+		|| die
+
+	# workaround stack check issues, bug #280934
+	use hppa && append-cflags "-DTCL_NO_STACK_CHECK=1"
+
+	tc-export CC
+
+	sed \
+		-e '/chmod/s:555:755:g' \
+		-i Makefile.in || die
+
+	sed \
+		-e 's:-O[2s]\?::g' \
+		-i tcl.m4 || die
+
+	mv configure.{in,ac} || die
+
+	eautoconf
+
+	multilib_copy_sources
+}
+
+multilib_src_configure() {
+	# We went ahead and deleted the whole compat/ subdir which means
+	# the configure tests to detect broken versions need to pass (else
+	# we'll fail to build).  This comes up when cross-compiling, but
+	# might as well get a minor configure speed up normally.
+	export ac_cv_func_memcmp_working="yes"
+	export tcl_cv_str{str,toul,tod}_unbroken="ok"
+	export tcl_cv_strtod_buggy="no"
+
+	econf \
+		$(use_enable threads) \
+		$(use_enable debug symbols)
+}
+
+multilib_src_install() {
+	#short version number
+	local v1=$(ver_cut 1-2)
+	local mylibdir=$(get_libdir)
+
+	S= default
+	# fix the tclConfig.sh to eliminate refs to the build directory
+	# and drop unnecessary -L inclusion to default system libdir
+
+	sed \
+		-e "/^TCL_BUILD_LIB_SPEC=/s:-L$(pwd) *::g" \
+		-e "/^TCL_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
+		-e "/^TCL_SRC_DIR=/s:${SPARENT}:${EPREFIX}/usr/${mylibdir}/tcl${v1}/include:g" \
+		-e "/^TCL_BUILD_STUB_LIB_SPEC=/s:-L$(pwd) *::g" \
+		-e "/^TCL_STUB_LIB_SPEC=/s:-L${EPREFIX}/usr/${mylibdir} *::g" \
+		-e "/^TCL_BUILD_STUB_LIB_PATH=/s:$(pwd):${EPREFIX}/usr/${mylibdir}:g" \
+		-e "/^TCL_LIBW_FILE=/s:'libtcl${v1}..TCL_DBGX..so':\"libtcl${v1}\$\{TCL_DBGX\}.so\":g" \
+		-i "${ED}"/usr/${mylibdir}/tclConfig.sh || die
+	if use prefix && [[ ${CHOST} != *-darwin* && ${CHOST} != *-mint* ]] ; then
+		sed \
+			-e "/^TCL_CC_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|g" \
+			-e "/^TCL_LD_SEARCH_FLAGS=/s|'$|:${EPREFIX}/usr/${mylibdir}'|" \
+			-i "${ED}"/usr/${mylibdir}/tclConfig.sh || die
+	fi
+
+	# install private headers
+	insinto /usr/${mylibdir}/tcl${v1}/include/unix
+	doins *.h
+	insinto /usr/${mylibdir}/tcl${v1}/include/generic
+	doins "${SPARENT}"/generic/*.h
+	rm -f "${ED}"/usr/${mylibdir}/tcl${v1}/include/generic/{tcl,tclDecls,tclPlatDecls}.h || die
+
+	# install symlink for libraries
+	dosym libtcl${v1}$(get_libname) /usr/${mylibdir}/libtcl$(get_libname)
+	dosym libtclstub${v1}.a /usr/${mylibdir}/libtclstub.a
+
+	if multilib_is_native_abi; then
+		dosym tclsh${v1} /usr/bin/tclsh
+		dodoc "${SPARENT}"/{ChangeLog*,README,changes}
+	fi
+}
+
+pkg_postinst() {
+	for version in ${REPLACING_VERSIONS}; do
+		if ver_test 8.6 -lt ${version}; then
+			echo
+			ewarn "You're upgrading from <${P}, you must recompile the other"
+			ewarn "packages on your system that link with tcl after the upgrade"
+			ewarn "completes. To perform this action, please run revdep-rebuild"
+			ewarn "in package app-portage/gentoolkit."
+			ewarn "If you have dev-lang/tk and dev-tcltk/tclx installed you should"
+			ewarn "upgrade them before this recompilation, too,"
+			echo
+		fi
+	done
+}