Skip to content

Commit

Permalink
dev-haskell/binary: drop USE=test, bug #666810
Browse files Browse the repository at this point in the history
Test suite is not compatible with modern QuickCheck instances:

```
tests/Arbitrary.hs:17:10: error:
    Duplicate instance declarations:
      instance (Arbitrary a, Arbitrary b, Arbitrary c, Arbitrary d,
                Arbitrary e, Arbitrary f) =>
               Arbitrary (a, b, c, d, e, f)
        -- Defined at tests/Arbitrary.hs:17:10
        -- Defined in ‘Test.QuickCheck.Arbitrary’
```

Binary is not really an upgradeable package. Let's drop
test suite completely.

Reported-by: Pacho Ramos
Closes: https://bugs.gentoo.org/666810
Package-Manager: Portage-2.3.49, Repoman-2.3.11
  • Loading branch information
Sergei Trofimovich committed Sep 23, 2018
1 parent d9a884a commit 50c1a9f
Showing 1 changed file with 2 additions and 7 deletions.
9 changes: 2 additions & 7 deletions dev-haskell/binary/binary-0.7.6.1.ebuild
Original file line number Diff line number Diff line change
@@ -1,11 +1,11 @@
# Copyright 1999-2015 Gentoo Foundation
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=5

# ebuild generated by hackport 0.4.6.9999

CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
CABAL_FEATURES="lib profile haddock hoogle hscolour" # Avoid test-suite circular depend
inherit haskell-cabal

DESCRIPTION="Binary serialisation for Haskell values using lazy ByteStrings"
Expand All @@ -23,11 +23,6 @@ RDEPEND=">=dev-lang/ghc-7.4.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.8
test? ( dev-haskell/hunit
>=dev-haskell/quickcheck-2.8
>=dev-haskell/random-1.0.1.0
dev-haskell/test-framework
>=dev-haskell/test-framework-quickcheck2-0.3 )
"

CABAL_CORE_LIB_GHC_PV="PM:7.10.3_rc1 PM:7.10.3"

0 comments on commit 50c1a9f

Please sign in to comment.