diff --git a/sys-fs/ntfs3g/metadata.xml b/sys-fs/ntfs3g/metadata.xml
index 51450c0c76e4b..1b94ddb68933d 100644
--- a/sys-fs/ntfs3g/metadata.xml
+++ b/sys-fs/ntfs3g/metadata.xml
@@ -27,6 +27,8 @@ file ownership, access right.
Include internal version of ntfsprogs.
+ http://tuxera.com/forum/
cpe:/a:ntfs-3g:ntfs-3g
+ ntfs-3g
diff --git a/sys-fs/ntfs3g/ntfs3g-2016.2.22.ebuild b/sys-fs/ntfs3g/ntfs3g-2016.2.22-r1.ebuild
similarity index 88%
rename from sys-fs/ntfs3g/ntfs3g-2016.2.22.ebuild
rename to sys-fs/ntfs3g/ntfs3g-2016.2.22-r1.ebuild
index 4222ccd6c90e0..9a0aca841bd16 100644
--- a/sys-fs/ntfs3g/ntfs3g-2016.2.22.ebuild
+++ b/sys-fs/ntfs3g/ntfs3g-2016.2.22-r1.ebuild
@@ -1,6 +1,5 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Id$
EAPI=5
inherit eutils linux-info udev toolchain-funcs libtool
@@ -13,7 +12,8 @@ HOMEPAGE="http://www.tuxera.com/community/ntfs-3g-download/"
SRC_URI="http://tuxera.com/opensource/${MY_P}.tgz"
LICENSE="GPL-2"
-SLOT="0/86"
+# The subslot matches the SONAME major #.
+SLOT="0/87"
KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~arm-linux ~x86-linux"
IUSE="acl debug +external-fuse ntfsdecrypt +ntfsprogs static-libs suid xattr"
@@ -50,6 +50,11 @@ pkg_setup() {
src_prepare() {
epatch "${PATCHES[@]}"
+ # Keep the symlinks in the same place we put the main binaries.
+ # Having them in / when all the progs are in /usr is pointless.
+ sed -i \
+ -e 's:/sbin:$(sbindir):g' \
+ {ntfsprogs,src}/Makefile.in || die #578336
# Note: patches apply to Makefile.in, so don't run autotools here.
elibtoolize
}
@@ -60,7 +65,6 @@ src_configure() {
--prefix="${EPREFIX}"/usr \
--exec-prefix="${EPREFIX}"/usr \
--docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --exec-prefix="${EPREFIX}"/usr \
$(use_enable debug) \
--enable-ldscript \
--disable-ldconfig \