diff --git a/kde-frameworks/purpose/metadata.xml b/kde-frameworks/purpose/metadata.xml
index 6b0d501b777f2..70fcb363554b9 100644
--- a/kde-frameworks/purpose/metadata.xml
+++ b/kde-frameworks/purpose/metadata.xml
@@ -11,6 +11,7 @@
diff --git a/kde-frameworks/purpose/purpose-5.116.0.ebuild b/kde-frameworks/purpose/purpose-5.116.0-r1.ebuild
similarity index 96%
rename from kde-frameworks/purpose/purpose-5.116.0.ebuild
rename to kde-frameworks/purpose/purpose-5.116.0-r1.ebuild
index 608b515dc68ec..9f3b9e96d6dd0 100644
--- a/kde-frameworks/purpose/purpose-5.116.0.ebuild
+++ b/kde-frameworks/purpose/purpose-5.116.0-r1.ebuild
@@ -40,7 +40,7 @@ DEPEND="
)
"
RDEPEND="${DEPEND}
- kf6compat? ( kde-frameworks/purpose:6[kaccounts?] )
+ kf6compat? ( kaccounts? ( >=kde-frameworks/purpose-6.3.0-r1:6[webengine] ) )
>=dev-qt/qtquickcontrols-${QTMIN}:5
>=dev-qt/qtquickcontrols2-${QTMIN}:5
>=kde-frameworks/kdeclarative-${PVCUT}:5
diff --git a/kde-frameworks/purpose/purpose-6.3.0.ebuild b/kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
similarity index 88%
rename from kde-frameworks/purpose/purpose-6.3.0.ebuild
rename to kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
index 5fc42a4bd8967..5a87ee551fe4a 100644
--- a/kde-frameworks/purpose/purpose-6.3.0.ebuild
+++ b/kde-frameworks/purpose/purpose-6.3.0-r1.ebuild
@@ -13,7 +13,7 @@ DESCRIPTION="Library for providing abstractions to get the developer's purposes
LICENSE="LGPL-2.1+"
KEYWORDS="~amd64 ~arm64"
-IUSE="bluetooth kaccounts"
+IUSE="bluetooth webengine"
# requires running environment
RESTRICT="test"
@@ -29,7 +29,7 @@ DEPEND="
=kde-frameworks/knotifications-${PVCUT}*:6
=kde-frameworks/kservice-${PVCUT}*:6
=kde-frameworks/prison-${PVCUT}*:6
- kaccounts? (
+ webengine? (
kde-apps/kaccounts-integration:6
>=net-libs/accounts-qt-1.16_p20220803[qt6]
)
@@ -38,9 +38,9 @@ RDEPEND="${DEPEND}
!${CATEGORY}/${PN}:5[-kf6compat(-)]
>=kde-frameworks/kdeclarative-${PVCUT}:6
bluetooth? ( =kde-frameworks/bluez-qt-${PVCUT}*:6 )
- kaccounts? ( >=net-libs/accounts-qml-0.7_p20231028[qt6] )
+ webengine? ( >=net-libs/accounts-qml-0.7_p20231028[qt6] )
"
-BDEPEND="kaccounts? ( dev-util/intltool )"
+BDEPEND="webengine? ( dev-util/intltool )"
src_prepare() {
ecm_src_prepare
@@ -51,7 +51,7 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
- $(cmake_use_find_package kaccounts KAccounts6)
+ $(cmake_use_find_package webengine KAccounts6)
)
ecm_src_configure