diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0-r1.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0-r2.ebuild
similarity index 97%
rename from dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0-r1.ebuild
rename to dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0-r2.ebuild
index ee6b40d335d97..9b44e6f970586 100644
--- a/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0-r1.ebuild
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-1.7.0-r2.ebuild
@@ -15,7 +15,7 @@ SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ISC"
SLOT="0/${PV}"
KEYWORDS="~amd64"
-IUSE="async camlp4 lwt"
+IUSE="async +camlp4 lwt"
RDEPEND="
async? ( dev-ml/async:= )
diff --git a/dev-ml/ocaml-pcap/Manifest b/dev-ml/ocaml-pcap/Manifest
new file mode 100644
index 0000000000000..b066fa9184a9e
--- /dev/null
+++ b/dev-ml/ocaml-pcap/Manifest
@@ -0,0 +1 @@
+DIST ocaml-pcap-0.3.3.tar.gz 45752 SHA256 9419a1701310b2d9130be3d305a6e2cb0cb2c8da0348a6c9fc49bbe2a5d6ae76 SHA512 732f895c08b114aef34ea3b776c69d67696e290f2a2952405b75097ce0253fcc8a754dd223ac4ce98b134786f46c328cc2510f7313c4c8c4042d242a1a4de8a1 WHIRLPOOL 0a39017e791e1031b0f1500e3f9eb055db66dda3c35c0ba027f579f4a3066c824bb066733cce9ab07e37e679694bc909ef0b3c812b71570a1563e5a28121b00d
diff --git a/dev-ml/ocaml-pcap/metadata.xml b/dev-ml/ocaml-pcap/metadata.xml
new file mode 100644
index 0000000000000..a33970c685ba0
--- /dev/null
+++ b/dev-ml/ocaml-pcap/metadata.xml
@@ -0,0 +1,9 @@
+
+
+
+ ml
+ proxy-maintainers
+
+ tomboy64@sina.cn
+
+
diff --git a/dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild b/dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild
new file mode 100644
index 0000000000000..8d7f9d774937a
--- /dev/null
+++ b/dev-ml/ocaml-pcap/ocaml-pcap-0.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Read and write pcap-formatted network packet traces."
+HOMEPAGE="https://github.com/mirage/ocaml-pcap https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+# Blockers taken from opam file and only relevant
+# if MirageOS should enter portage.
+RDEPEND="
+ dev-ml/ocaml-ipaddr:=
+ !dev-ml/mirage-net-socket
+ !=dev-ml/ocaml-cstruct-0.6.0:=[camlp4(-)]
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ >=dev-ml/lwt-2.4.0 )
+ ${RDEPEND}
+"
+
+DOCS=( CHANGES MAINTAINERS README.md )