diff --git a/dev-build/bazelisk/bazelisk-1.19.0.ebuild b/dev-build/bazelisk/bazelisk-1.19.0-r1.ebuild
similarity index 88%
rename from dev-build/bazelisk/bazelisk-1.19.0.ebuild
rename to dev-build/bazelisk/bazelisk-1.19.0-r1.ebuild
index 4cea472f3598e..9b18306d7e1b3 100644
--- a/dev-build/bazelisk/bazelisk-1.19.0.ebuild
+++ b/dev-build/bazelisk/bazelisk-1.19.0-r1.ebuild
@@ -16,6 +16,7 @@ SRC_URI="
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="+bazel-symlink"
DOCS=( CONTRIBUTING.md README.md )
@@ -34,5 +35,9 @@ src_install() {
exeinto /usr/bin
doexe "bin/${PN}"
+ if use bazel-symlink ; then
+ dosym -r /usr/bin/bazelisk /usr/bin/bazel
+ fi
+
einstalldocs
}
diff --git a/dev-build/bazelisk/metadata.xml b/dev-build/bazelisk/metadata.xml
index 032d00abaf95d..de81e5f355e37 100644
--- a/dev-build/bazelisk/metadata.xml
+++ b/dev-build/bazelisk/metadata.xml
@@ -7,12 +7,15 @@
Maciej Barć
- Bazelisk is a wrapper for Bazel written in Go. It automatically picks
- a good version of Bazel given your current working directory, downloads it
+ Bazelisk is a wrapper for Bazel written in Go. It automatically picks a
+ good version of Bazel given your current working directory, downloads it
from the official server (if required) and then transparently passes
through all command-line arguments to the real Bazel binary. You can call
it just like you would call Bazel.
+
https://github.com/bazelbuild/bazelisk/issues/
bazelbuild/bazelisk