diff --git a/app-text/tidy-html5/tidy-html5-5.2.0.ebuild b/app-text/tidy-html5/tidy-html5-5.2.0.ebuild
index f6a270245edde..2e92cdf94629f 100644
--- a/app-text/tidy-html5/tidy-html5-5.2.0.ebuild
+++ b/app-text/tidy-html5/tidy-html5-5.2.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -17,27 +17,5 @@ IUSE=""
DEPEND=""
RDEPEND="!app-text/htmltidy"
-S="${WORKDIR}/${P}"
-
DOCS=( README/{CODESTYLE,README,CONTRIBUTING,LICENSE,VERSION}.md )
HTML_DOCS=( README/README.html )
-
-BUILD_DIR="${S}/build/cmake"
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_BUILD_TYPE=Release
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cd build/cmake || die
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-}
diff --git a/app-text/tidy-html5/tidy-html5-5.4.0.ebuild b/app-text/tidy-html5/tidy-html5-5.4.0.ebuild
index 4632b3e1a371c..fffb62956b10e 100644
--- a/app-text/tidy-html5/tidy-html5-5.4.0.ebuild
+++ b/app-text/tidy-html5/tidy-html5-5.4.0.ebuild
@@ -16,23 +16,3 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
RDEPEND="!app-text/htmltidy"
DOCS=( README/{CODESTYLE,CONTRIBUTING,LICENSE,VERSION}.md )
-
-BUILD_DIR="${S}/build/cmake"
-
-src_configure() {
- local mycmakeargs=(
- -DCMAKE_INSTALL_PREFIX=/usr
- -DCMAKE_BUILD_TYPE=Release
- )
-
- cmake-utils_src_configure
-}
-
-src_compile() {
- cd build/cmake || die
- cmake-utils_src_compile
-}
-
-src_install() {
- cmake-utils_src_install
-}