diff --git a/media-libs/mesa/mesa-9999.ebuild b/media-libs/mesa/mesa-9999.ebuild
index 6c2c4ebe96af0..00213165a443b 100644
--- a/media-libs/mesa/mesa-9999.ebuild
+++ b/media-libs/mesa/mesa-9999.ebuild
@@ -44,8 +44,8 @@ done
IUSE="${IUSE_VIDEO_CARDS}
bindist +classic d3d9 debug +dri3 +egl +gallium +gbm gles1 gles2 +llvm
- +nptl opencl osmesa pax_kernel openmax pic selinux +udev vaapi vdpau
- wayland xvmc xa kernel_FreeBSD"
+ +nptl opencl osmesa pax_kernel openmax pic selinux +udev vaapi valgrind
+ vdpau wayland xvmc xa kernel_FreeBSD"
REQUIRED_USE="
d3d9? ( dri3 gallium )
@@ -148,6 +148,7 @@ DEPEND="${RDEPEND}
)
sys-devel/gettext
virtual/pkgconfig
+ valgrind? ( dev-util/valgrind )
>=x11-proto/dri2proto-2.8-r1:=[${MULTILIB_USEDEP}]
dri3? (
>=x11-proto/dri3proto-1.0:=[${MULTILIB_USEDEP}]
@@ -299,6 +300,7 @@ multilib_src_configure() {
$(use_enable gles2) \
$(use_enable nptl glx-tls) \
$(use_enable !udev sysfs) \
+ --enable-valgrind=$(usex valgrind auto no) \
--enable-llvm-shared-libs \
--with-dri-drivers=${DRI_DRIVERS} \
--with-gallium-drivers=${GALLIUM_DRIVERS} \
diff --git a/media-libs/mesa/metadata.xml b/media-libs/mesa/metadata.xml
index 88120e51f659d..cd38cd9042c50 100644
--- a/media-libs/mesa/metadata.xml
+++ b/media-libs/mesa/metadata.xml
@@ -23,6 +23,7 @@
Build the Mesa library for off-screen rendering.
Enable if the user plans to run the package under a pax enabled hardened kernel
disable optimized assembly code that is not PIC friendly
+ Compile in valgrind memory hints
Enable the VDPAU acceleration interface for the Gallium3D Video Layer.
Enable support for dev-libs/wayland
Enable the XA (X Acceleration) API for Gallium3D.