forked from openwrt/openwrt
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Merge pull request openwrt#347 from kdarbyshirebryant/addcake
Add CAKE qdisc
- Loading branch information
Showing
3 changed files
with
805 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,42 @@ | ||
# | ||
# Copyright (C) 2016 LEDE | ||
# | ||
# This is free software, licensed under the GNU General Public License v2. | ||
# See /LICENSE for more information. | ||
# | ||
|
||
include $(TOPDIR)/rules.mk | ||
include $(INCLUDE_DIR)/kernel.mk | ||
|
||
PKG_NAME:=sched-cake | ||
PKG_RELEASE:=1 | ||
|
||
PKG_SOURCE_PROTO:=git | ||
PKG_SOURCE_URL:=https://github.com/kdarbyshirebryant/sch_cake.git | ||
PKG_SOURCE_DATE:=2017-01-21 | ||
PKG_SOURCE_VERSION:=e928a82a83401ae70163f73e14490aa54749924d | ||
PKG_MIRROR_HASH:=29c0a29e110a8fb0a513cc3ead848f497eef9fceb04dc64e22aab41165abda53 | ||
PKG_MAINTAINER:=Kevin Darbyshire-Bryant <[email protected]> | ||
|
||
include $(INCLUDE_DIR)/package.mk | ||
|
||
define KernelPackage/sched-cake | ||
SUBMENU:=Network Support | ||
TITLE:=Cake fq_codel/blue derived shaper | ||
URL:=https://github.com/dtaht/sch_cake | ||
FILES:=$(PKG_BUILD_DIR)/sch_cake.ko | ||
AUTOLOAD:=$(call AutoLoad,75,sch_cake) | ||
DEPENDS:=+kmod-ipt-conntrack @!LINUX_3_18 | ||
endef | ||
|
||
include $(INCLUDE_DIR)/kernel-defaults.mk | ||
|
||
define KernelPackage/sched-cake/description | ||
Common Applications Kept Enhanced fq_codel/blue derived shaper | ||
endef | ||
|
||
define Build/Compile | ||
$(MAKE) $(KERNEL_MAKEOPTS) SUBDIRS="$(PKG_BUILD_DIR)" modules | ||
endef | ||
|
||
$(eval $(call KernelPackage,sched-cake)) |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.