-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Mechanical changes to add DESTDIR support to packages that install
their files via a custom do-install target.
- Loading branch information
1 parent
9bd3464
commit 0bb78c6
Showing
55 changed files
with
480 additions
and
305 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.21 2007/07/30 18:55:23 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.22 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= datlib221 | ||
|
@@ -11,6 +11,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.logiqx.com/Tools/DatLib/DatLib.php | ||
COMMENT= Data file library for some emulation tools | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake | ||
WRKSRC= ${WRKDIR} | ||
MAKE_FILE= makefile | ||
|
@@ -21,17 +23,17 @@ MAKE_ENV+= RANLIB=${RANLIB:Q} | |
INSTALLATION_DIRS= lib | ||
|
||
do-install: | ||
${INSTALL_DATA_DIR} ${PREFIX}/include/DatLib | ||
${INSTALL_DATA_DIR} ${PREFIX}/include/DatLib/hash | ||
${INSTALL_DATA_DIR} ${PREFIX}/include/DatLib/mame | ||
${INSTALL_DATA_DIR} ${PREFIX}/include/DatLib/misc | ||
${INSTALL_DATA} ${WRKSRC}/src/*.h ${PREFIX}/include/DatLib | ||
${INSTALL_DATA} ${WRKSRC}/src/hash/*.h ${PREFIX}/include/DatLib/hash | ||
${INSTALL_DATA} ${WRKSRC}/src/mame/*.h ${PREFIX}/include/DatLib/mame | ||
${INSTALL_DATA} ${WRKSRC}/src/misc/*.h ${PREFIX}/include/DatLib/misc | ||
${INSTALL_LIB} ${WRKSRC}/obj/libdatlib.a ${PREFIX}/lib/libdatlib.a | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/DatLib | ||
${INSTALL_DATA} ${WRKSRC}/*.txt ${PREFIX}/share/doc/DatLib | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/include/DatLib | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/include/DatLib/hash | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/include/DatLib/mame | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/include/DatLib/misc | ||
${INSTALL_DATA} ${WRKSRC}/src/*.h ${DESTDIR}${PREFIX}/include/DatLib | ||
${INSTALL_DATA} ${WRKSRC}/src/hash/*.h ${DESTDIR}${PREFIX}/include/DatLib/hash | ||
${INSTALL_DATA} ${WRKSRC}/src/mame/*.h ${DESTDIR}${PREFIX}/include/DatLib/mame | ||
${INSTALL_DATA} ${WRKSRC}/src/misc/*.h ${DESTDIR}${PREFIX}/include/DatLib/misc | ||
${INSTALL_LIB} ${WRKSRC}/obj/libdatlib.a ${DESTDIR}${PREFIX}/lib/libdatlib.a | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/DatLib | ||
${INSTALL_DATA} ${WRKSRC}/*.txt ${DESTDIR}${PREFIX}/share/doc/DatLib | ||
|
||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.23 2007/07/30 18:55:51 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.24 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= dutil232 | ||
|
@@ -11,6 +11,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.logiqx.com/Tools/DatUtil/DatUtil.php | ||
COMMENT= Create and convert emulator rom checksum files | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake | ||
WRKSRC= ${WRKDIR} | ||
MAKE_FILE= makefile | ||
|
@@ -23,9 +25,9 @@ post-extract: | |
${MKDIR} ${WRKSRC}/obj | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/datutil ${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/DatUtil | ||
${INSTALL_DATA} ${WRKSRC}/*.txt ${PREFIX}/share/doc/DatUtil | ||
${INSTALL_PROGRAM} ${WRKSRC}/datutil ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/DatUtil | ||
${INSTALL_DATA} ${WRKSRC}/*.txt ${DESTDIR}${PREFIX}/share/doc/DatUtil | ||
|
||
.include "../../devel/zlib/buildlink3.mk" | ||
BUILDLINK_API_DEPENDS.DatLib+= DatLib>=2.21 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.18 2007/07/08 09:42:33 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.19 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= mdiff226 | ||
|
@@ -11,6 +11,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.logiqx.com/Tools/MAMEDiff/MAMEDiff.php | ||
COMMENT= Compare MAME rom sets of different releases | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake | ||
WRKSRC= ${WRKDIR} | ||
MAKE_FILE= makefile | ||
|
@@ -22,9 +24,10 @@ post-extract: | |
${MKDIR} ${WRKSRC}/obj | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/mamediff ${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/MAMEDiff | ||
${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/MAMEDiff | ||
${INSTALL_PROGRAM} ${WRKSRC}/mamediff ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/MAMEDiff | ||
${INSTALL_DATA} ${WRKSRC}/readme.txt \ | ||
${DESTDIR}${PREFIX}/share/doc/MAMEDiff | ||
|
||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../emulators/DatLib/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.16 2007/09/10 09:06:36 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.17 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= rbuild29 | ||
|
@@ -11,6 +11,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.logiqx.com/Tools/ROMBuild/ROMBuild.php | ||
COMMENT= Arcade ROM manipulation tool | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake | ||
WRKSRC= ${WRKDIR} | ||
MAKE_FILE= makefile | ||
|
@@ -22,9 +24,10 @@ post-extract: | |
${MKDIR} ${WRKSRC}/obj | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/rombuild ${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/ROMBuild | ||
${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/ROMBuild | ||
${INSTALL_PROGRAM} ${WRKSRC}/rombuild ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/ROMBuild | ||
${INSTALL_DATA} ${WRKSRC}/readme.txt \ | ||
${DESTDIR}${PREFIX}/share/doc/ROMBuild | ||
|
||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../emulators/DatLib/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.15 2007/07/08 09:42:33 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.16 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= zident28 | ||
|
@@ -11,6 +11,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.logiqx.com/Tools/ZIPIdent/ZIPIdent.php | ||
COMMENT= Identify arcade ROM sets | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_TOOLS+= gmake | ||
WRKSRC= ${WRKDIR} | ||
MAKE_FILE= makefile | ||
|
@@ -22,9 +24,10 @@ post-extract: | |
${MKDIR} ${WRKSRC}/obj | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/zipident ${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${PREFIX}/share/doc/ZIPIdent | ||
${INSTALL_DATA} ${WRKSRC}/readme.txt ${PREFIX}/share/doc/ZIPIdent | ||
${INSTALL_PROGRAM} ${WRKSRC}/zipident ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/share/doc/ZIPIdent | ||
${INSTALL_DATA} ${WRKSRC}/readme.txt \ | ||
${DESTDIR}${PREFIX}/share/doc/ZIPIdent | ||
|
||
.include "../../devel/zlib/buildlink3.mk" | ||
.include "../../emulators/DatLib/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.2 2007/03/24 19:08:51 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.3 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= applyppf3_src | ||
|
@@ -11,14 +11,17 @@ MAINTAINER= [email protected] | |
#HOMEPAGE= http://www.paradogs.com/pdx_ppf3.htm | ||
COMMENT= PPF (Playstation Patch File) v3.0 apply tool | ||
|
||
WRKSRC= ${WRKDIR} | ||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
WRKSRC= ${WRKDIR} | ||
INSTALLATION_DIRS= bin | ||
|
||
do-build: | ||
cd ${BUILD_DIRS} && ${CC} ${CPPFLAGS} ${CFLAGS} \ | ||
-D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64 \ | ||
-D_LARGEFILE64_SOURCE -o applyppf applyppf3_linux.c | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/applyppf ${PREFIX}/bin | ||
${INSTALL_PROGRAM} ${WRKSRC}/applyppf ${DESTDIR}${PREFIX}/bin | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.17 2008/02/27 12:52:41 rillig Exp $ | ||
# $NetBSD: Makefile,v 1.18 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
|
||
DISTNAME= arnsrc27012002 | ||
|
@@ -12,6 +12,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://arnold.emuunlim.com/ | ||
COMMENT= Amstrad CPC, Amstrad CPC+ and KC Compact emulator | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
# we want case sensitive file names. | ||
EXTRACT_OPTS_ZIP= -aqo | ||
|
||
|
@@ -27,9 +29,10 @@ MAKE_ENV+= SHAREDIR=${SHAREDIR} | |
AUTO_MKDIRS= yes | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/arnold ${PREFIX}/bin | ||
cd ${WRKSRC}/roms && pax -wr * ${SHAREDIR}/roms/ | ||
cd ${WRKSRC} && ${INSTALL_DATA} readme.* ${PREFIX}/share/doc/arnold | ||
${INSTALL_PROGRAM} ${WRKSRC}/arnold ${DESTDIR}${PREFIX}/bin | ||
cd ${WRKSRC}/roms && pax -wr * ${DESTDIR}${SHAREDIR}/roms/ | ||
cd ${WRKSRC} && ${INSTALL_DATA} readme.* \ | ||
${DESTDIR}${PREFIX}/share/doc/arnold | ||
|
||
.include "../../mk/oss.buildlink3.mk" | ||
.include "../../devel/SDL/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile.common,v 1.9 2008/01/15 15:43:49 jlam Exp $ | ||
# $NetBSD: Makefile.common,v 1.10 2008/03/03 19:21:37 jlam Exp $ | ||
# | ||
# Common infrastructure for NetBSD compat* packages. | ||
# | ||
|
@@ -12,6 +12,8 @@ EXTRACT_SUFX= .tar.bz2 | |
|
||
MAINTAINER= [email protected] | ||
|
||
PKG_DESTDIR_SUPPORT= destdir | ||
|
||
NO_SRC_ON_FTP= Already in MASTER_SITE_LOCAL | ||
|
||
NETBSD_PKG= yes | ||
|
@@ -127,9 +129,10 @@ ${ELF_SYMLINKS_DATA}: plist | |
.PHONY: compat-install | ||
do-install: compat-install | ||
compat-install: | ||
${INSTALL_DATA_DIR} ${PREFIX}/${EMULSUBDIR} | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/${EMULSUBDIR} | ||
cd ${WRKSRC} && for dir in lib libexec usr; do \ | ||
if ${TEST} -d "$$dir"; then \ | ||
${PAX} -rw "$$dir" ${PREFIX}/${EMULSUBDIR}; \ | ||
${PAX} -rw "$$dir" \ | ||
${DESTDIR}${PREFIX}/${EMULSUBDIR}; \ | ||
fi; \ | ||
done |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.