Skip to content

Commit

Permalink
Be smarter when parsing the argument for the bitrate.
Browse files Browse the repository at this point in the history
Allows mounting directories with commas in them.
Bump PKGREVISION.
  • Loading branch information
0-wiz-0 committed Jul 17, 2009
1 parent dcbcfb9 commit 46ccd55
Show file tree
Hide file tree
Showing 3 changed files with 15 additions and 5 deletions.
3 changes: 2 additions & 1 deletion filesystems/fuse-mp3fs/Makefile
Original file line number Diff line number Diff line change
@@ -1,8 +1,9 @@
# $NetBSD: Makefile,v 1.1.1.1 2009/07/16 14:54:02 wiz Exp $
# $NetBSD: Makefile,v 1.2 2009/07/17 10:43:21 wiz Exp $
#

DISTNAME= mp3fs-0.13
PKGNAME= fuse-${DISTNAME}
PKGREVISION= 1
CATEGORIES= filesystems
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:=mp3fs/}

Expand Down
4 changes: 2 additions & 2 deletions filesystems/fuse-mp3fs/distinfo
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
$NetBSD: distinfo,v 1.1.1.1 2009/07/16 14:54:02 wiz Exp $
$NetBSD: distinfo,v 1.2 2009/07/17 10:43:21 wiz Exp $

SHA1 (mp3fs-0.13.tar.gz) = b246bd747a32256cb8364b7ac0cc8b7a4e1d3f74
RMD160 (mp3fs-0.13.tar.gz) = 6ad1126ee22b35fe4987dd6addbc41a25c74a508
Size (mp3fs-0.13.tar.gz) = 301642 bytes
SHA1 (patch-aa) = 7fb2cfc0fa9d3afcd42a98cd73f5834f94245141
SHA1 (patch-aa) = b4554994bb9949c645ba07f43615c78004fc9895
SHA1 (patch-ab) = 9b259b045decb4556dd72eeb65e0275554a93b6f
13 changes: 11 additions & 2 deletions filesystems/fuse-mp3fs/patches/patch-aa
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
$NetBSD: patch-aa,v 1.1.1.1 2009/07/16 14:54:02 wiz Exp $
$NetBSD: patch-aa,v 1.2 2009/07/17 10:43:21 wiz Exp $

--- src/mp3fs.c.orig 2008-12-14 05:17:35.000000000 +0000
--- src/mp3fs.c.orig 2008-12-14 06:17:35.000000000 +0100
+++ src/mp3fs.c
@@ -30,7 +30,11 @@
#include <fcntl.h>
Expand Down Expand Up @@ -40,3 +40,12 @@ $NetBSD: patch-aa,v 1.1.1.1 2009/07/16 14:54:02 wiz Exp $
if(res == -1)
return -errno;

@@ -252,7 +265,7 @@ int main(int argc, char *argv[]) {
basepath = argv[1];
bitrate = 0;

- rate = strchr(basepath, ',');
+ rate = strrchr(basepath, ',');
if(rate) {
rate[0] = '\0';
bitrate = atoi(rate + 1);

0 comments on commit 46ccd55

Please sign in to comment.