-
Notifications
You must be signed in to change notification settings - Fork 160
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Mechanical changes to add full DESTDIR support to packages that install
their files via a custom do-install target.
- Loading branch information
1 parent
5c458b5
commit 76ed4a5
Showing
83 changed files
with
557 additions
and
339 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.7 2007/03/04 11:29:57 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.8 2008/03/02 06:10:31 jlam Exp $ | ||
# | ||
|
||
DISTNAME= applerecords-0.5 | ||
|
@@ -11,6 +11,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://web.archive.org/web/20060501054520/http://www.cdavies.org/applerecords.html | ||
COMMENT= Java DAAP client | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
NO_BUILD= yes | ||
WRKSRC= ${WRKDIR} | ||
USE_JAVA= run | ||
|
@@ -24,8 +26,9 @@ do-extract: | |
${SED} -e 's|@SH@|${SH}|g' -e 's|@PREFIX@|${PREFIX}|g' ${FILESDIR}/applerecords > ${WRKSRC}/applerecords | ||
|
||
do-install: | ||
${INSTALL_DATA_DIR} ${PREFIX}/lib/applerecords | ||
${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar ${PREFIX}/lib/applerecords/applerecords.jar | ||
${INSTALL_SCRIPT} ${WRKSRC}/applerecords ${PREFIX}/bin | ||
${INSTALL_DATA_DIR} ${DESTDIR}${PREFIX}/lib/applerecords | ||
${INSTALL_DATA} ${WRKSRC}/${DISTNAME}.jar \ | ||
${DESTDIR}${PREFIX}/lib/applerecords/applerecords.jar | ||
${INSTALL_SCRIPT} ${WRKSRC}/applerecords ${DESTDIR}${PREFIX}/bin | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.12 2006/10/14 13:11:23 rillig Exp $ | ||
# $NetBSD: Makefile,v 1.13 2008/03/02 06:10:31 jlam Exp $ | ||
|
||
DISTNAME= cd-discid_0.9.orig | ||
PKGNAME= cd-discid-0.9 | ||
|
@@ -8,17 +8,20 @@ MASTER_SITES= http://lly.org/~rcw/cd-discid/ | |
MAINTAINER= [email protected] | ||
COMMENT= Read CD to obtain CDDB discid information | ||
|
||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV} | ||
|
||
NOT_FOR_PLATFORM= Interix-*-* | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
WRKSRC= ${WRKDIR}/${PKGNAME_NOREV} | ||
|
||
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 | ||
|
||
do-build: | ||
cd ${WRKSRC} && ${CC} -O -o cd-discid cd-discid.c | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/cd-discid ${PREFIX}/bin | ||
${INSTALL_MAN} ${WRKSRC}/cd-discid.1 ${PREFIX}/${PKGMANDIR}/man1 | ||
${INSTALL_PROGRAM} ${WRKSRC}/cd-discid ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_MAN} ${WRKSRC}/cd-discid.1 \ | ||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.14 2006/05/11 10:07:58 rillig Exp $ | ||
# $NetBSD: Makefile,v 1.15 2008/03/02 06:10:31 jlam Exp $ | ||
|
||
DISTNAME= cdd-1.0nb3 | ||
CATEGORIES= audio | ||
|
@@ -7,6 +7,8 @@ MASTER_SITES= ${MASTER_SITE_LOCAL} | |
MAINTAINER= [email protected] | ||
COMMENT= Program for reading CD audio from SCSI/ATAPI CD-ROM drives | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
.include "../../mk/bsd.prefs.mk" | ||
|
||
.if defined(CDDCPPFLAGS) | ||
|
@@ -16,8 +18,8 @@ MAKE_ENV+= CDDCPPFLAGS=${CDDCPPFLAGS:Q} | |
INSTALLATION_DIRS= bin | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/cdd ${PREFIX}/bin | ||
${INSTALL_PROGRAM} ${WRKSRC}/stripzeros ${PREFIX}/bin | ||
${INSTALL_PROGRAM} ${WRKSRC}/cdd ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_PROGRAM} ${WRKSRC}/stripzeros ${DESTDIR}${PREFIX}/bin | ||
|
||
.include "../../devel/libscsi/buildlink3.mk" | ||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.4 2007/06/03 22:04:42 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.5 2008/03/02 06:10:31 jlam Exp $ | ||
# | ||
|
||
DISTNAME= manual-html-4.23 | ||
|
@@ -10,18 +10,21 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.csounds.com/ | ||
COMMENT= Csound4 Reference Manual | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
NO_BUILD= yes | ||
WRKSRC= ${WRKDIR} | ||
DIST_SUBDIR= ${PKGNAME_NOREV} | ||
|
||
INSTALLATION_DIRS= share/doc/csound4 share/examples | ||
|
||
do-install: | ||
cd ${WRKSRC}/csound-4.23/manual \ | ||
&& ${PAX} -rw -s '|.*/CVS/.*||' -s ',.*/CVS$$,,' * ${PREFIX}/share/doc/csound4 | ||
cd ${WRKSRC}/csound-4.23/manual && \ | ||
${PAX} -rw -s '|.*/CVS/.*||' -s ',.*/CVS$$,,' * \ | ||
${DESTDIR}${PREFIX}/share/doc/csound4 | ||
cd ${FILESDIR} && ${INSTALL_DATA} rt-midi-input.* \ | ||
${PREFIX}/share/doc/csound4/examples | ||
${DESTDIR}${PREFIX}/share/doc/csound4/examples | ||
${LN} -s ../../share/doc/csound4/examples \ | ||
${PREFIX}/share/examples/csound4 | ||
${DESTDIR}${PREFIX}/share/examples/csound4 | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.4 2006/12/15 14:34:19 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.5 2008/03/02 06:10:31 jlam Exp $ | ||
# | ||
|
||
DISTNAME= Csound${CSOUND_VERSION}_manual_html | ||
|
@@ -12,6 +12,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.csounds.com/ | ||
COMMENT= Csound5 Reference Manual | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
CSOUND_VERSION= 5.01 | ||
NO_BUILD= yes | ||
WRKSRC= ${WRKDIR}/html | ||
|
@@ -21,6 +23,6 @@ EXTRACT_OPTS_ZIP= -aqo | |
INSTALLATION_DIRS+= share/doc/csound5 | ||
|
||
do-install: | ||
cd ${WRKSRC} && ${PAX} -rw * ${PREFIX}/share/doc/csound5 | ||
cd ${WRKSRC} && ${PAX} -rw * ${DESTDIR}${PREFIX}/share/doc/csound5 | ||
|
||
.include "../../mk/bsd.pkg.mk" |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.33 2007/03/24 21:02:18 adam Exp $ | ||
# $NetBSD: Makefile,v 1.34 2008/03/02 06:10:31 jlam Exp $ | ||
|
||
DISTNAME= dap-2.1.5 | ||
CATEGORIES= audio | ||
|
@@ -9,15 +9,17 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://www.cee.hw.ac.uk/~richardk/ | ||
COMMENT= Digital audio recording and processing package | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
USE_LANGUAGES= c c++ | ||
INSTALLATION_DIRS+= share/doc/dap | ||
MAKE_FILE= Makefile.netbsd | ||
MAKE_ENV+= X11PREFIX=${X11PREFIX:Q} | ||
|
||
do-install: | ||
${INSTALL_PROGRAM} ${WRKSRC}/main/DAP ${PREFIX}/bin/dap | ||
${INSTALL_PROGRAM} ${WRKSRC}/main/DAP ${DESTDIR}${PREFIX}/bin/dap | ||
${INSTALL_DATA} ${WRKSRC}/README ${WRKSRC}/TODO ${WRKSRC}/COPYING \ | ||
${WRKSRC}/FEATURES ${PREFIX}/share/doc/dap | ||
${WRKSRC}/FEATURES ${DESTDIR}${PREFIX}/share/doc/dap | ||
|
||
.include "../../graphics/jpeg/buildlink3.mk" | ||
.include "../../x11/libXpm/buildlink3.mk" | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,4 +1,4 @@ | ||
# $NetBSD: Makefile,v 1.19 2007/12/02 13:04:06 wiz Exp $ | ||
# $NetBSD: Makefile,v 1.20 2008/03/02 06:10:31 jlam Exp $ | ||
# | ||
|
||
DISTNAME= darkice-0.17.1 | ||
|
@@ -10,6 +10,8 @@ MAINTAINER= [email protected] | |
HOMEPAGE= http://darkice.tyrell.hu/ | ||
COMMENT= IceCast, IceCast2 and ShoutCast live audio streamer | ||
|
||
PKG_DESTDIR_SUPPORT= user-destdir | ||
|
||
GNU_CONFIGURE= yes | ||
USE_LANGUAGES= c c++ | ||
USE_TOOLS+= gmake | ||
|
@@ -29,14 +31,17 @@ CONF_FILES= ${EGDIR}/darkice.conf ${PKG_SYSCONFDIR}/darkice.conf | |
INSTALLATION_DIRS= bin ${PKGMANDIR}/man1 ${PKGMANDIR}/man5 | ||
|
||
do-install: | ||
${INSTALL_DATA_DIR} ${EGDIR} | ||
${INSTALL_DATA_DIR} ${HTMLDIR} | ||
${INSTALL_DATA} ${WRKSRC}/darkice.cfg ${EGDIR}/darkice.conf | ||
${INSTALL_PROGRAM} ${WRKSRC}/src/darkice ${PREFIX}/bin | ||
${INSTALL_MAN} ${WRKSRC}/man/darkice.1 ${PREFIX}/${PKGMANDIR}/man1 | ||
${INSTALL_DATA_DIR} ${DESTDIR}${EGDIR} | ||
${INSTALL_DATA_DIR} ${DESTDIR}${HTMLDIR} | ||
${INSTALL_DATA} ${WRKSRC}/darkice.cfg \ | ||
${DESTDIR}${EGDIR}/darkice.conf | ||
${INSTALL_PROGRAM} ${WRKSRC}/src/darkice ${DESTDIR}${PREFIX}/bin | ||
${INSTALL_MAN} ${WRKSRC}/man/darkice.1 \ | ||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 | ||
${INSTALL_MAN} ${WRKSRC}/man/darkice.cfg.5 \ | ||
${PREFIX}/${PKGMANDIR}/man5/darkice.conf.5 | ||
cd ${WRKSRC}/doc/doxygen/html && ${INSTALL_DATA} *.html ${HTMLDIR} | ||
${DESTDIR}${PREFIX}/${PKGMANDIR}/man5/darkice.conf.5 | ||
cd ${WRKSRC}/doc/doxygen/html && ${INSTALL_DATA} *.html \ | ||
${DESTDIR}${HTMLDIR} | ||
|
||
.include "../../audio/faac/buildlink3.mk" | ||
.include "../../audio/lame/buildlink3.mk" | ||
|
Oops, something went wrong.