-
Notifications
You must be signed in to change notification settings - Fork 164
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Try to make it compilable on NetBSD.
- Loading branch information
Showing
2 changed files
with
21 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,5 +1,6 @@ | ||
$NetBSD: distinfo,v 1.1.1.1 2007/02/20 23:44:06 xtraeme Exp $ | ||
$NetBSD: distinfo,v 1.2 2009/08/03 13:50:39 joerg Exp $ | ||
|
||
SHA1 (httpfs_with_static_binaries_2.06.08.26.tar.gz) = 857dfe72b817b01c8a445eb486a047b8c4f8ec02 | ||
RMD160 (httpfs_with_static_binaries_2.06.08.26.tar.gz) = 0172c155d38b0ee2e862fdcf8815886ed7d28e48 | ||
Size (httpfs_with_static_binaries_2.06.08.26.tar.gz) = 115384 bytes | ||
SHA1 (patch-aa) = 6dc82d997847f2bb5e6618f59736d5bee5d97eb1 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,19 @@ | ||
$NetBSD: patch-aa,v 1.1 2009/08/03 13:50:39 joerg Exp $ | ||
|
||
--- httpfs.c.orig 2009-08-03 15:46:22.000000000 +0200 | ||
+++ httpfs.c | ||
@@ -1,3 +1,5 @@ | ||
+#define FUSE_USE_VERSION 25 | ||
+ | ||
/* | ||
* HTTPFS: import a file from a web server to local file system | ||
* the main use is, to mount an iso on a web server with loop device | ||
@@ -802,7 +804,7 @@ static int httpfs_fsync(const char *path | ||
return 0; | ||
} | ||
|
||
-static void *httpfs_init(void) { | ||
+static void *httpfs_init(struct fuse_conn_info *arg) { | ||
fchdir(targetFd); /* that's the catch */ | ||
return NULL; | ||
} |