Skip to content

NorfairKing/typst.nix

Folders and files

NameName
Last commit message
Last commit date

Latest commit

author
Tom Sydney Kerckhove
Jan 4, 2024
cb48073 · Jan 4, 2024

History

3 Commits
Jan 4, 2024
Jan 4, 2024
Jan 4, 2024
Jan 4, 2024
Jan 4, 2024
Jan 4, 2024

Repository files navigation

Building Typst documents with Nix

Using this repository

let typstNixRepo = builtins.fetchGit {
        url = "https://github.com/NorfairKing/typst.nix";
        rev = "0000000000000000000000000000000000000000"; # Use a recent typst.nix commit
    };
    makeTypstDocument = pkgs.callPackage (typstNixRepo + "/makeTypstDocument.nix") {};
in makeTypstDocument {
    name = "presentation.pdf";
    main = "presentation.typ";
    src = ./presentation;
    packagesRepo = builtins.fetchGit {
      url = "https://github.com/typst/packages";
      rev = "0000000000000000000000000000000000000000"; # Use a recent typst packages commit
    };
    # Fill in all typst dependencies that you import in your .typ files
    typstDependencies = [
      {
        name = "polylux";
        version = "0.3.1";
      }
    ];
}

makeTypstDocument

See ./makeTypstDocument.nix

About

Making typst documents with Nix

Resources

Stars

Watchers

Forks

Releases

No releases published

Packages

No packages published