let typstNixRepo = builtins.fetchGit {
url = "https://github.com/NorfairKing/typst.nix";
rev = "0000000000000000000000000000000000000000"; # Use a recent typst.nix commit
};
makeTypstDocument = pkgs.callPackage (typstNixRepo + "/makeTypstDocument.nix") {};
in makeTypstDocument {
name = "presentation.pdf";
main = "presentation.typ";
src = ./presentation;
packagesRepo = builtins.fetchGit {
url = "https://github.com/typst/packages";
rev = "0000000000000000000000000000000000000000"; # Use a recent typst packages commit
};
# Fill in all typst dependencies that you import in your .typ files
typstDependencies = [
{
name = "polylux";
version = "0.3.1";
}
];
}
-
Notifications
You must be signed in to change notification settings - Fork 0
NorfairKing/typst.nix
Folders and files
Name | Name | Last commit message | Last commit date | |
---|---|---|---|---|
Latest commit | ||||
Repository files navigation
About
Making typst documents with Nix
Resources
Stars
Watchers
Forks
Releases
No releases published
Packages 0
No packages published