forked from buildroot/buildroot
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
Add openssl and openssh. Fix up UML kernel build.
- Loading branch information
1 parent
f2f69f7
commit 365aac2
Showing
9 changed files
with
404 additions
and
130 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
|
@@ -26,3 +26,20 @@ Have fun! | |
|
||
Please feed suggestions, bug reports, insults, and bribes back to: | ||
Erik Andersen <[email protected]> | ||
|
||
|
||
|
||
NOTE: | ||
|
||
For './configure' to behave itself with certain applications, you may need | ||
to create a symlink under "/lib" on your system that points to the uClibc | ||
shared library loader in the staging directory. For example, on my system | ||
|
||
$ cd /lib | ||
$ sudo ln -s /home/andersen/buildroot/build/staging_dir/lib/ld-uClibc.so.0 ld-uClibc.so.0 | ||
|
||
If you don't use sudo, run 'su -' to become root when making the link. If | ||
you aren't root it won't work. The reason for this symlink, is it allows | ||
'./configure' to actually execute the test applications it compiles against | ||
uClibc during the configuration process.... | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,46 @@ | ||
############################################################# | ||
# | ||
# openssh | ||
# | ||
############################################################# | ||
|
||
OPENSSH_SITE:=ftp://mirror.cs.wisc.edu/pub/mirrors/OpenBSD/OpenSSH/portable/ | ||
OPENSSH_DIR:=$(BUILD_DIR)/openssh-3.4p1 | ||
OPENSSH_SOURCE:=openssh-3.4p1.tar.gz | ||
OPENSSH_PATCH:=$(SOURCE_DIR)/openssh_3.4p1-4.diff.gz | ||
|
||
$(DL_DIR)/$(OPENSSH_SOURCE): | ||
wget -P $(DL_DIR) --passive-ftp $(OPENSSH_SITE)/$(OPENSSH_SOURCE) | ||
|
||
$(OPENSSH_DIR)/.unpacked: $(DL_DIR)/$(OPENSSH_SOURCE) | ||
zcat $(DL_DIR)/$(OPENSSH_SOURCE) | tar -C $(BUILD_DIR) -xvf - | ||
touch $(OPENSSH_DIR)/.unpacked | ||
|
||
$(OPENSSH_DIR)/.patched: $(OPENSSH_DIR)/.unpacked | ||
zcat $(OPENSSH_PATCH) | patch -d $(OPENSSH_DIR) -p1 | ||
touch $(OPENSSH_DIR)/.patched | ||
|
||
$(OPENSSH_DIR)/.configured: $(OPENSSH_DIR)/.patched | ||
(cd $(OPENSSH_DIR); rm -rf config.cache; CC=$(TARGET_CC1) \ | ||
./configure --prefix=/usr \ | ||
--includedir=$(STAGING_DIR)/include \ | ||
--disable-lastlog --disable-utmp --disable-utmpx --disable-wtmp --disable-wtmpx \ | ||
--disable-nls --without-x); | ||
touch $(OPENSSH_DIR)/.configured | ||
|
||
$(OPENSSH_DIR)/openssh: $(OPENSSH_DIR)/.configured | ||
make CC=$(TARGET_CC1) -C $(OPENSSH_DIR) | ||
-$(STRIP) --strip-unneeded $(OPENSSH_DIR)/*.so* | ||
|
||
$(TARGET_DIR)/usr/bin/openssh: $(OPENSSH_DIR)/openssh | ||
make CC=$(TARGET_CC1) DESTDIR=$(TARGET_DIR) -C $(OPENSSH_DIR) install | ||
rm -rf $(TARGET_DIR)/usr/share/doc/openssh | ||
|
||
openssh: $(TARGET_DIR)/usr/bin/openssh | ||
|
||
openssh-clean: | ||
make -C $(OPENSSH_DIR) clean | ||
|
||
openssh-dirclean: | ||
rm -rf $(OPENSSH_DIR) | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,49 @@ | ||
############################################################# | ||
# | ||
# openssl | ||
# | ||
############################################################# | ||
|
||
# TARGETS | ||
OPENSSL_SITE:=http://www.openssl.org/source | ||
OPENSSL_SOURCE:=openssl-0.9.6g.tar.gz | ||
OPENSSL_DIR:=$(BUILD_DIR)/openssl-0.9.6g | ||
|
||
|
||
$(DL_DIR)/$(OPENSSL_SOURCE): | ||
wget -P $(DL_DIR) --passive-ftp $(OPENSSL_SITE)/$(OPENSSL_SOURCE) | ||
|
||
$(OPENSSL_DIR)/.unpacked: $(DL_DIR)/$(OPENSSL_SOURCE) | ||
gunzip -c $(DL_DIR)/$(OPENSSL_SOURCE) | tar -C $(BUILD_DIR) -xvf - | ||
touch $(OPENSSL_DIR)/.unpacked | ||
|
||
$(OPENSSL_DIR)/Makefile: $(OPENSSL_DIR)/.unpacked | ||
(cd $(OPENSSL_DIR); \ | ||
PATH=$(TARGET_PATH) ./Configure linux-elf --prefix=$(STAGING_DIR) \ | ||
--openssldir=$(STAGING_DIR) -L$(STAGING_DIR)/lib -ldl \ | ||
-I$(STAGING_DIR)/include no-threads shared no-asm) | ||
|
||
$(OPENSSL_DIR)/apps/openssl: $(OPENSSL_DIR)/Makefile | ||
make CC=$(TARGET_CC1) -C $(OPENSSL_DIR) | ||
|
||
$(STAGING_DIR)/bin/openssl: $(OPENSSL_DIR)/apps/openssl | ||
make CC=$(TARGET_CC1) -C $(OPENSSL_DIR) install | ||
|
||
$(TARGET_DIR)/bin/openssl: $(STAGING_DIR)/bin/openssl | ||
cp -fa $(STAGING_DIR)/bin/openssl $(TARGET_DIR)/bin/ | ||
cp -fa $(STAGING_DIR)/lib/libcrypto.so* $(TARGET_DIR)/lib/ | ||
cp -fa $(STAGING_DIR)/lib/libssl.so* $(TARGET_DIR)/lib/ | ||
|
||
openssl-clean: | ||
rm -f $(STAGING_DIR)/bin/openssl $(TARGET_DIR)/bin/openssl | ||
rm -f $(STAGING_DIR)/lib/libcrypto.so* $(TARGET_DIR)/lib/libcrypto.so* | ||
rm -f $(STAGING_DIR)/lib/libssl.so* $(TARGET_DIR)/lib/libssl.so* | ||
$(MAKE) -C $(OPENSSL_DIR) clean | ||
|
||
openssl-dirclean: | ||
rm -rf $(OPENSSL_DIR) | ||
|
||
openssl: uclibc $(TARGET_DIR)/bin/openssl | ||
|
||
#EOF | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Oops, something went wrong.