Skip to content

Commit

Permalink
dev-db/plr: Bump, add more postgres targets
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.8, Repoman-3.0.1
Signed-off-by: Patrick Lauer <[email protected]>
  • Loading branch information
patricklauer committed Sep 27, 2020
1 parent 6af9ae2 commit 6e5293f
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-db/plr/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST plr-8.3.0.17.tar.gz 74017 BLAKE2B 314b4cfa2c3ca8ed31e80a72233a6dc8cdb9f3811dad6e9f3eb5147c17cdf5a039436598b0fc2b30c6702b02dd3cb2da33543764aee3199c6864aae22be875ce SHA512 d7080c62349d1dcdd17008a7be3643b54678e0f66bf721068df73057394496d025c4fe01e52945c3acf9cc21eb90241512667772ef3fe519a3c9081efe92dd40
DIST plr-8.4.1.tar.gz 265142 BLAKE2B 859913ba14d3e6876eb5a3d7593346b98ab2e1b6c70d9fd9cc7e1810fe11ecb3c552305485735cf975cc41ce2de6cbd7bcf407c9e373fc4024230be797c9899a SHA512 0db407355271009bad95c21f81e544839322f0fa0a63d2abd8edbf9eab8f61e208a3e4f7083729cc8247411885197ff3569c88264db0a29b34523dc83bbed7ec
69 changes: 69 additions & 0 deletions dev-db/plr/plr-8.4.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=6

POSTGRES_COMPAT=( 9.{5..6} {10..13} )
POSTGRES_USEDEP="server"

inherit postgres-multi

DESCRIPTION="R language extension for postgresql database"
HOMEPAGE="http://www.joeconway.com/plr/"
SRC_URI="https://github.com/postgres-plr/plr/archive/REL${PV//./_}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64"

RDEPEND="dev-lang/R
${POSTGRES_DEP}"
DEPEND="${RDEPEND}
virtual/pkgconfig"

REQUIRED_USE="${POSTGRES_REQ_USE}"

S=${WORKDIR}/contrib/${PN}

src_unpack() {
unpack ${A}
# the build system wants 'contrib' to be part of the path
mkdir -p "${WORKDIR}/contrib"
mv "${WORKDIR}/${PN}-REL${PV//./_}" "${S}"
}

src_prepare() {
local BUILD_DIR="${S}"
postgres-multi_src_prepare
}

src_compile() {
pg_src_compile() {
cd "${BUILD_DIR}"
PG_CONFIG="${SYSROOT}${EPREFIX}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
USE_PGXS=1 \
emake -j1
}
postgres-multi_foreach pg_src_compile
}

src_install() {
pg_src_install() {
cd "${BUILD_DIR}"
PG_CONFIG="${SYSROOT}${EPREFIX}/usr/$(get_libdir)/postgresql-${MULTIBUILD_ID}/bin/pg_config" \
USE_PGXS=1 \
emake -j1 DESTDIR="${D}" install
}
postgres-multi_foreach pg_src_install
}

pkg_postinst() {
elog "The plr extension needs to be explicitly added (or 'created') on each database"
elog "you wish to use it with. As of postgresql-9.1 the easiest way to do this is"
elog "with the proprietary SQL statement:"
elog
elog "\tCREATE EXTENSION plr;"
elog
elog "For more info on how to add PL/R to your postgresql database(s), please visit"
elog "http://www.joeconway.com/doc/plr-install.html"
}

0 comments on commit 6e5293f

Please sign in to comment.