Skip to content

Commit

Permalink
proj/gentoo: Initial commit
Browse files Browse the repository at this point in the history
This commit represents a new era for Gentoo:
Storing the gentoo-x86 tree in Git, as converted from CVS.

This commit is the start of the NEW history.
Any historical data is intended to be grafted onto this point.

Creation process:
1. Take final CVS checkout snapshot
2. Remove ALL ChangeLog* files
3. Transform all Manifests to thin
4. Remove empty Manifests
5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$
5.1. Do not touch files with -kb/-ko keyword flags.

Signed-off-by: Robin H. Johnson <[email protected]>
X-Thanks: Alec Warner <[email protected]> - did the GSoC 2006 migration tests
X-Thanks: Robin H. Johnson <[email protected]> - infra guy, herding this project
X-Thanks: Nguyen Thai Ngoc Duy <[email protected]> - Former Gentoo developer, wrote Git features for the migration
X-Thanks: Brian Harring <[email protected]> - wrote much python to improve cvs2svn
X-Thanks: Rich Freeman <[email protected]> - validation scripts
X-Thanks: Patrick Lauer <[email protected]> - Gentoo dev, running new 2014 work in migration
X-Thanks: Michał Górny <[email protected]> - scripts, QA, nagging
X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
  • Loading branch information
robbat2 committed Aug 9, 2015
0 parents commit 56bd759
Show file tree
Hide file tree
Showing 97,532 changed files with 3,535,965 additions and 0 deletions.
The diff you're trying to view is too large. We only load the first 3000 changed files.
2 changes: 2 additions & 0 deletions app-accessibility/SphinxTrain/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
DIST SphinxTrain-0.9.1-beta.tar.gz 469617 SHA256 c1a4b74a3e26777b80ddd7a026547aad194040cca8595e6fe1be320a19f99d18 SHA512 1b33a58a6e05069369fe1ba668609e5a25d6a49fbf2fed1f5d86bdc1fc43d4544627c438e61d46003c2dbd8d7fa6f41c686b57cbca215f73b6c4ba0d7682076d WHIRLPOOL 6399233f803f37d8d267a5005a5cb158513cb64b2b7b3727cb9ee93c46781f29e5ed0729c1d7d1e586de49ede098a7d9658c285399bae0d633f34657000074c8
DIST sphinxtrain-1.0.8.tar.gz 8925803 SHA256 548e3e513ceaa1b2fd6fd7ed1724349e0a4bf7bdeb11be9c91787e6f2b865203 SHA512 465d2c4ade9acc7b49c1d975449c38ac01d5a3ff332f9841be66cd8ca9d2f0b68fd36cc8a46384c8b510042efa91c3887a080481e84f2d0deb9775a598835f2b WHIRLPOOL d9ccbe09d125579e15167fa625bb72c86e114f9c394e909488216ae2f4e6af4c7b968d469455b65c4aff2a41a7d97701ac290df2cbc6b0450c64c94b042ae94d
41 changes: 41 additions & 0 deletions app-accessibility/SphinxTrain/SphinxTrain-0.9.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,41 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=4

inherit eutils toolchain-funcs

DESCRIPTION="Speech Recognition (Training Module)"
HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
SRC_URI="http://www.speech.cs.cmu.edu/${PN}/${P}-beta.tar.gz"

LICENSE="BSD-with-attribution"
SLOT="0"
KEYWORDS="~amd64 ppc x86"
IUSE=""

DEPEND="app-accessibility/sphinx2
app-accessibility/festival"
RDEPEND="${DEPEND}"

S=${WORKDIR}/${PN}

src_prepare() {
epatch "${FILESDIR}"/gcc.patch
epatch "${FILESDIR}"/gcc34.patch
tc-export CC AR RANLIB
}

src_install() {
# dobin bin.*/* fails ... see bug #73586
find bin.* -mindepth 1 -maxdepth 1 -type f -exec dobin '{}' \; || die

dodoc README etc/*cfg
dohtml doc/*{txt,html,sgml}
}

pkg_postinst() {
elog "Detailed usage and training instructions can be found at"
elog "http://www.speech.cs.cmu.edu/SphinxTrain/"
}
39 changes: 39 additions & 0 deletions app-accessibility/SphinxTrain/SphinxTrain-1.0.8.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python2_7 )

inherit multilib python-single-r1

DESCRIPTION="Speech Recognition (Training Module)"
HOMEPAGE="http://cmusphinx.sourceforge.net/html/cmusphinx.php"
SRC_URI="mirror://sourceforge/cmusphinx/sphinxtrain-${PV}.tar.gz"

LICENSE="BSD-with-attribution"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""

RDEPEND="app-accessibility/sphinxbase
dev-lang/perl
${PYTHON_DEPS}"
DEPEND="${RDEPEND}
virtual/pkgconfig"

S=${WORKDIR}/sphinxtrain-${PV}

src_install() {
default
dodoc README etc/*cfg

python_fix_shebang "${D}"/usr/bin/sphinxtrain
python_optimize "${D}"/usr/$(get_libdir)/sphinxtrain/python/cmusphinx
}

pkg_postinst() {
elog "Detailed usage and training instructions can be found at"
elog "http://cmusphinx.sourceforge.net/wiki/"
}
34 changes: 34 additions & 0 deletions app-accessibility/SphinxTrain/files/gcc.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
--- src/programs/count_3phone/wrec.h.orig 2003-09-28 18:51:49.000000000 +0900
+++ src/programs/count_3phone/wrec.h 2003-09-28 18:52:23.000000000 +0900
@@ -44,7 +44,7 @@
#define WREC_H

#include "phrec.h"
-#include <varargs.h>
+#include <stdarg.h>

int quit (int status, char *fmt, ...);

--- src/programs/count_3phone/quit.c.orig 2003-09-28 19:12:56.000000000 +0900
+++ src/programs/count_3phone/quit.c 2003-09-28 19:13:12.000000000 +0900
@@ -74,17 +74,14 @@

#include <stdio.h>
#include <stdlib.h>
-#include <varargs.h>
+#include <stdarg.h>

-int quit (status,fmt,va_alist)
- int status;
- char *fmt;
- va_dcl
+int quit (int status,char *fmt,...)
{
va_list args;

fflush(stdout);
- va_start(args);
+ va_start(args, fmt);
(void) vfprintf(stderr, fmt, args);
va_end(args);
exit(status);
11 changes: 11 additions & 0 deletions app-accessibility/SphinxTrain/files/gcc34.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
--- SphinxTrain/src/programs/count_3phone/phone_word_io.c~ 2001-04-05 16:00:33.000000000 -0400
+++ SphinxTrain/src/programs/count_3phone/phone_word_io.c 2005-05-01 12:48:42.000000000 -0400
@@ -71,7 +71,7 @@
#ifdef __alpha
void *malloc();
#else
-char *malloc();
+//char *malloc();
#endif

extern int Num_Phones, Num_Words;
15 changes: 15 additions & 0 deletions app-accessibility/SphinxTrain/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,15 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>accessibility</herd>
<herd>sound</herd>
<longdescription lang="en">
SphinxTrain is CMU Sphinx's training package.
</longdescription>
<longdescription lang="ja">
SphinxTrainはCMU Sphinxの調教パッケージです。
</longdescription>
<upstream>
<remote-id type="sourceforge">cmusphinx</remote-id>
</upstream>
</pkgmetadata>
2 changes: 2 additions & 0 deletions app-accessibility/accerciser/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,2 @@
DIST accerciser-3.12.0.tar.xz 3212432 SHA256 0d421a59cd294966441fb6591d34f28e4b60340815bdf91c9e8f39c2d826e96b SHA512 d15d301f7579a92e3b3aa65d22fd726d71bee8330b450c7ed232d4a8d7fc312402573073f67a490ab659122ad98651f8a073235770caa9eba8a4b6dc9d68e6d3 WHIRLPOOL 4b753de73afc1c8fda7d71a8b6f8007ebb4627985a6049be887d8e916f4e37c3a5484a481d8e516a1d4cc245e987ed29a2a87c2780b882bced032f5d2d14d5d6
DIST accerciser-3.14.0.tar.xz 3213916 SHA256 f5a5915d475e9241396414ccd167724c88807e77e69151cf0b40b32bd57d0574 SHA512 bafc30e15fe0121f8abc64239e48834ab06a03fe64fc368a221d167a13079721962441e0343f17934dde57cd012c9132374739297c23c79c567fc36cc60fb07d WHIRLPOOL 4b9679145ad1ad7f8d059dfdfb12d372c1b27780532a7c19cc25b66bbe0a13db5b864548e332b74e0327eebb488622ae471514046737b738c15624969d8df7a8
67 changes: 67 additions & 0 deletions app-accessibility/accerciser/accerciser-3.12.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python{3_3,3_4} )
PYTHON_REQ_USE="xml"

inherit gnome2 python-r1

DESCRIPTION="Interactive Python accessibility explorer"
HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"

LICENSE="BSD CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

RDEPEND="
>=app-accessibility/at-spi2-core-2.5.2:2
>=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
>=x11-libs/gtk+-3.1.13:3[introspection]
dev-libs/atk[introspection]
>=dev-libs/glib-2.28:2
dev-libs/gobject-introspection
>=dev-python/ipython-0.11[${PYTHON_USEDEP}]
>=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
x11-libs/gdk-pixbuf[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/pango[introspection]
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
app-text/yelp-tools
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
"

src_prepare() {
gnome2_src_prepare

# Leave shebang alone
sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die

python_copy_sources
}

src_configure() {
python_foreach_impl run_in_build_dir gnome2_src_configure \
ITSTOOL=$(type -P true)
}

src_compile() {
python_foreach_impl run_in_build_dir gnome2_src_compile
}

src_install() {
installing() {
gnome2_src_install
python_doscript src/accerciser
}
python_foreach_impl run_in_build_dir installing
}
67 changes: 67 additions & 0 deletions app-accessibility/accerciser/accerciser-3.12.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python3_3 )
PYTHON_REQ_USE="xml"

inherit gnome2 python-r1

DESCRIPTION="Interactive Python accessibility explorer"
HOMEPAGE="http://live.gnome.org/Accerciser"

LICENSE="BSD CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""

RDEPEND="
>=app-accessibility/at-spi2-core-2.5.2:2
>=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
>=x11-libs/gtk+-3.1.13:3[introspection]
dev-libs/atk[introspection]
>=dev-libs/glib-2.28:2
dev-libs/gobject-introspection
>=dev-python/ipython-0.11[${PYTHON_USEDEP}]
>=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
x11-libs/gdk-pixbuf[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/pango[introspection]
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
app-text/yelp-tools
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
"

src_prepare() {
gnome2_src_prepare

# Leave shebang alone
sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die

python_copy_sources
}

src_configure() {
python_foreach_impl run_in_build_dir gnome2_src_configure \
ITSTOOL=$(type -P true)
}

src_compile() {
python_foreach_impl run_in_build_dir gnome2_src_compile
}

src_install() {
installing() {
gnome2_src_install
python_doscript src/accerciser
}
python_foreach_impl run_in_build_dir installing
}
67 changes: 67 additions & 0 deletions app-accessibility/accerciser/accerciser-3.14.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,67 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI="5"
GCONF_DEBUG="no"
PYTHON_COMPAT=( python{3_3,3_4} )
PYTHON_REQ_USE="xml"

inherit gnome2 python-r1

DESCRIPTION="Interactive Python accessibility explorer"
HOMEPAGE="https://wiki.gnome.org/Apps/Accerciser"

LICENSE="BSD CC-BY-SA-3.0"
SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""

RDEPEND="
>=app-accessibility/at-spi2-core-2.5.2:2
>=dev-python/pygobject-2.90.3:3[${PYTHON_USEDEP}]
>=x11-libs/gtk+-3.1.13:3[introspection]
dev-libs/atk[introspection]
>=dev-libs/glib-2.28:2
dev-libs/gobject-introspection
>=dev-python/ipython-0.11[${PYTHON_USEDEP}]
>=dev-python/pyatspi-2.1.5[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
x11-libs/gdk-pixbuf[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/pango[introspection]
${PYTHON_DEPS}
"
DEPEND="${RDEPEND}
app-text/yelp-tools
>=dev-util/intltool-0.35
sys-devel/gettext
virtual/pkgconfig
"

src_prepare() {
gnome2_src_prepare

# Leave shebang alone
sed 's:@PYTHON@:/usr/bin/python:' -i src/accerciser.in || die

python_copy_sources
}

src_configure() {
python_foreach_impl run_in_build_dir gnome2_src_configure \
ITSTOOL=$(type -P true)
}

src_compile() {
python_foreach_impl run_in_build_dir gnome2_src_compile
}

src_install() {
installing() {
gnome2_src_install
python_doscript src/accerciser
}
python_foreach_impl run_in_build_dir installing
}
10 changes: 10 additions & 0 deletions app-accessibility/accerciser/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>gnome-accessibility</herd>
<longdescription lang="en">
Accerciser is an interactive Python accessibility explorer for the GNOME desktop. It uses AT-SPI to inspect and control widgets, allowing you to check if an application is providing correct information to assistive technologies and automated test frameworks. Accerciser has a simple plugin framework which you can use to create custom views of accessibility information.

In essence, Accerciser is a next generation at-poke tool.
</longdescription>
</pkgmetadata>
3 changes: 3 additions & 0 deletions app-accessibility/at-spi2-atk/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,3 @@
DIST at-spi2-atk-2.12.1.tar.xz 280568 SHA256 5fa9c527bdec028e06797563cd52d49bcf06f638549df983424d88db89bb1336 SHA512 a7fc3cbc3665741ea6cee716cc68467ed110c0f6425fe418ea0f1b702931e4a07306e48264e9cd160d98c5bf762f076cad66ff2e46690af226ce33146d11aee2 WHIRLPOOL dc84563059d24ae56029989853d9e5a9a8cca5eecbed1227c4e36cd760aed4035beefbb71668221646cbd03057f1e30e44128081e2a6b32cfe48baabf4a631e5
DIST at-spi2-atk-2.14.1.tar.xz 280952 SHA256 058f34ea60edf0a5f831c9f2bdd280fe95c1bcafb76e466e44aa0fb356d17bcb SHA512 1daee942d3c477444aaa42fb6ede6d821ff9b613f0686dd4a545406c97ceb819a3544419e0cb5d2e661f3a1b6fc92af9394801f3c51377db0ab77620e5c3d437 WHIRLPOOL 75d7e4569eed83df842e363c6203571b7bc26dbfdd71555ead0c1656eb61923817673ce18f8042c4a989a45af956ad9fd85aee5386c8aafb121bf71de99c04c6
DIST at-spi2-atk-2.16.0.tar.xz 286668 SHA256 78efc45ec36383bf785f8636e64a8d866defeb020e00a08f92978f1fc3772ff9 SHA512 fcd40693e5ef55c640a52158996dc8bc66f53ef211c343cd5401c4bcd1669110ea836e0550eb41caee9c9f3a4f9670095a7dd8252600af943ddcb374bf50f011 WHIRLPOOL 0865cb8bfd62449bf345938a382c2a7d8efd425154e7e674c8097702e6873d98b8d2be8ac841858ba7dce166c2be4e18be1b1daf4fed43f667430ac3eeccebe2
Loading

0 comments on commit 56bd759

Please sign in to comment.