Skip to content

Commit

Permalink
fs: Create a common fs_devread for ext4/reiserfs/zfs
Browse files Browse the repository at this point in the history
The ext4, reiserfs and zfs filesystems all have their own implementation
of the same function, *_devread. Generalize this function into fs_devread
and put the code into fs/fs_internal.c.

Signed-off-by: Marek Behun <[email protected]>
[trini: Move fs/fs_internal.o hunk to the end of fs/Makefile as all
cases need it]
Signed-off-by: Tom Rini <[email protected]>
  • Loading branch information
elkablo authored and trini committed Oct 3, 2017
1 parent 85d8bf5 commit 5994e8b
Show file tree
Hide file tree
Showing 6 changed files with 122 additions and 236 deletions.
1 change: 1 addition & 0 deletions fs/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -23,3 +23,4 @@ obj-$(CONFIG_CMD_UBIFS) += ubifs/
obj-$(CONFIG_YAFFS2) += yaffs2/
obj-$(CONFIG_CMD_ZFS) += zfs/
endif
obj-y += fs_internal.o
84 changes: 5 additions & 79 deletions fs/ext4/dev.c
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,7 @@
#include <common.h>
#include <blk.h>
#include <config.h>
#include <memalign.h>
#include <fs_internal.h>
#include <ext4fs.h>
#include <ext_common.h>
#include "ext4_common.h"
Expand All @@ -47,85 +47,11 @@ void ext4fs_set_blk_dev(struct blk_desc *rbdd, disk_partition_t *info)
get_fs()->dev_desc->log2blksz;
}

int ext4fs_devread(lbaint_t sector, int byte_offset, int byte_len, char *buf)
int ext4fs_devread(lbaint_t sector, int byte_offset, int byte_len,
char *buffer)
{
unsigned block_len;
int log2blksz = ext4fs_blk_desc->log2blksz;
ALLOC_CACHE_ALIGN_BUFFER(char, sec_buf, (ext4fs_blk_desc ?
ext4fs_blk_desc->blksz :
0));
if (ext4fs_blk_desc == NULL) {
printf("** Invalid Block Device Descriptor (NULL)\n");
return 0;
}

/* Check partition boundaries */
if ((sector + ((byte_offset + byte_len - 1) >> log2blksz))
>= part_info->size) {
printf("%s read outside partition " LBAFU "\n", __func__,
sector);
return 0;
}

/* Get the read to the beginning of a partition */
sector += byte_offset >> log2blksz;
byte_offset &= ext4fs_blk_desc->blksz - 1;

debug(" <" LBAFU ", %d, %d>\n", sector, byte_offset, byte_len);

if (byte_offset != 0) {
int readlen;
/* read first part which isn't aligned with start of sector */
if (blk_dread(ext4fs_blk_desc, part_info->start + sector, 1,
(void *)sec_buf) != 1) {
printf(" ** ext2fs_devread() read error **\n");
return 0;
}
readlen = min((int)ext4fs_blk_desc->blksz - byte_offset,
byte_len);
memcpy(buf, sec_buf + byte_offset, readlen);
buf += readlen;
byte_len -= readlen;
sector++;
}

if (byte_len == 0)
return 1;

/* read sector aligned part */
block_len = byte_len & ~(ext4fs_blk_desc->blksz - 1);

if (block_len == 0) {
ALLOC_CACHE_ALIGN_BUFFER(u8, p, ext4fs_blk_desc->blksz);

block_len = ext4fs_blk_desc->blksz;
blk_dread(ext4fs_blk_desc, part_info->start + sector, 1,
(void *)p);
memcpy(buf, p, byte_len);
return 1;
}

if (blk_dread(ext4fs_blk_desc, part_info->start + sector,
block_len >> log2blksz, (void *)buf) !=
block_len >> log2blksz) {
printf(" ** %s read error - block\n", __func__);
return 0;
}
block_len = byte_len & ~(ext4fs_blk_desc->blksz - 1);
buf += block_len;
byte_len -= block_len;
sector += block_len / ext4fs_blk_desc->blksz;

if (byte_len != 0) {
/* read rest of data which are not in whole sector */
if (blk_dread(ext4fs_blk_desc, part_info->start + sector, 1,
(void *)sec_buf) != 1) {
printf("* %s read error - last part\n", __func__);
return 0;
}
memcpy(buf, sec_buf, byte_len);
}
return 1;
return fs_devread(get_fs()->dev_desc, part_info, sector, byte_offset,
byte_len, buffer);
}

int ext4_read_superblock(char *buffer)
Expand Down
92 changes: 92 additions & 0 deletions fs/fs_internal.c
Original file line number Diff line number Diff line change
@@ -0,0 +1,92 @@
/*
* 2017 by Marek Behun <[email protected]>
*
* Derived from code in ext4/dev.c, which was based on reiserfs/dev.c
*
* SPDX-License-Identifier: GPL-2.0
*/

#include <common.h>
#include <compiler.h>
#include <part.h>
#include <memalign.h>

int fs_devread(struct blk_desc *blk, disk_partition_t *partition,
lbaint_t sector, int byte_offset, int byte_len, char *buf)
{
unsigned block_len;
int log2blksz = blk->log2blksz;
ALLOC_CACHE_ALIGN_BUFFER(char, sec_buf, (blk ? blk->blksz : 0));
if (blk == NULL) {
printf("** Invalid Block Device Descriptor (NULL)\n");
return 0;
}

/* Check partition boundaries */
if ((sector + ((byte_offset + byte_len - 1) >> log2blksz))
>= partition->size) {
printf("%s read outside partition " LBAFU "\n", __func__,
sector);
return 0;
}

/* Get the read to the beginning of a partition */
sector += byte_offset >> log2blksz;
byte_offset &= blk->blksz - 1;

debug(" <" LBAFU ", %d, %d>\n", sector, byte_offset, byte_len);

if (byte_offset != 0) {
int readlen;
/* read first part which isn't aligned with start of sector */
if (blk_dread(blk, partition->start + sector, 1,
(void *)sec_buf) != 1) {
printf(" ** %s read error **\n", __func__);
return 0;
}
readlen = min((int)blk->blksz - byte_offset,
byte_len);
memcpy(buf, sec_buf + byte_offset, readlen);
buf += readlen;
byte_len -= readlen;
sector++;
}

if (byte_len == 0)
return 1;

/* read sector aligned part */
block_len = byte_len & ~(blk->blksz - 1);

if (block_len == 0) {
ALLOC_CACHE_ALIGN_BUFFER(u8, p, blk->blksz);

block_len = blk->blksz;
blk_dread(blk, partition->start + sector, 1,
(void *)p);
memcpy(buf, p, byte_len);
return 1;
}

if (blk_dread(blk, partition->start + sector,
block_len >> log2blksz, (void *)buf) !=
block_len >> log2blksz) {
printf(" ** %s read error - block\n", __func__);
return 0;
}
block_len = byte_len & ~(blk->blksz - 1);
buf += block_len;
byte_len -= block_len;
sector += block_len / blk->blksz;

if (byte_len != 0) {
/* read rest of data which are not in whole sector */
if (blk_dread(blk, partition->start + sector, 1,
(void *)sec_buf) != 1) {
printf("* %s read error - last part\n", __func__);
return 0;
}
memcpy(buf, sec_buf, byte_len);
}
return 1;
}
78 changes: 4 additions & 74 deletions fs/reiserfs/dev.c
Original file line number Diff line number Diff line change
Expand Up @@ -9,7 +9,7 @@
#include <common.h>
#include <config.h>
#include <reiserfs.h>

#include <fs_internal.h>
#include "reiserfs_private.h"

static struct blk_desc *reiserfs_blk_desc;
Expand All @@ -22,78 +22,8 @@ void reiserfs_set_blk_dev(struct blk_desc *rbdd, disk_partition_t *info)
part_info = info;
}


int reiserfs_devread (int sector, int byte_offset, int byte_len, char *buf)
int reiserfs_devread(int sector, int byte_offset, int byte_len, char *buf)
{
char sec_buf[SECTOR_SIZE];
unsigned block_len;
/*
unsigned len = byte_len;
u8 *start = buf;
*/
/*
* Check partition boundaries
*/
if (sector < 0
|| ((sector + ((byte_offset + byte_len - 1) >> SECTOR_BITS))
>= part_info->size)) {
/* errnum = ERR_OUTSIDE_PART; */
printf (" ** reiserfs_devread() read outside partition\n");
return 0;
}

/*
* Get the read to the beginning of a partition.
*/
sector += byte_offset >> SECTOR_BITS;
byte_offset &= SECTOR_SIZE - 1;

#if defined(DEBUG)
printf (" <%d, %d, %d> ", sector, byte_offset, byte_len);
#endif


if (reiserfs_blk_desc == NULL)
return 0;


if (byte_offset != 0) {
/* read first part which isn't aligned with start of sector */
if (reiserfs_blk_desc->block_read(reiserfs_blk_desc,
part_info->start + sector,
1, (void *)sec_buf) != 1) {
printf (" ** reiserfs_devread() read error\n");
return 0;
}
memcpy(buf, sec_buf+byte_offset, min(SECTOR_SIZE-byte_offset, byte_len));
buf+=min(SECTOR_SIZE-byte_offset, byte_len);
byte_len-=min(SECTOR_SIZE-byte_offset, byte_len);
sector++;
}

/* read sector aligned part */
block_len = byte_len & ~(SECTOR_SIZE-1);
if (reiserfs_blk_desc->block_read(reiserfs_blk_desc,
part_info->start + sector,
block_len / SECTOR_SIZE, (void *)buf)
!= block_len/SECTOR_SIZE) {
printf (" ** reiserfs_devread() read error - block\n");
return 0;
}
buf+=block_len;
byte_len-=block_len;
sector+= block_len/SECTOR_SIZE;

if ( byte_len != 0 ) {
/* read rest of data which are not in whole sector */
if (reiserfs_blk_desc->block_read(reiserfs_blk_desc,
part_info->start + sector,
1, (void *)sec_buf) != 1) {
printf (" ** reiserfs_devread() read error - last part\n");
return 0;
}
memcpy(buf, sec_buf, byte_len);
}

return 1;
return fs_devread(reiserfs_blk_desc, part_info, sector, byte_offset,
byte_len, buf);
}
86 changes: 3 additions & 83 deletions fs/zfs/dev.c
Original file line number Diff line number Diff line change
Expand Up @@ -11,6 +11,7 @@

#include <common.h>
#include <config.h>
#include <fs_internal.h>
#include <zfs_common.h>

static struct blk_desc *zfs_blk_desc;
Expand All @@ -25,87 +26,6 @@ void zfs_set_blk_dev(struct blk_desc *rbdd, disk_partition_t *info)
/* err */
int zfs_devread(int sector, int byte_offset, int byte_len, char *buf)
{
short sec_buffer[SECTOR_SIZE/sizeof(short)];
char *sec_buf = (char *)sec_buffer;
unsigned block_len;

/*
* Check partition boundaries
*/
if ((sector < 0) ||
((sector + ((byte_offset + byte_len - 1) >> SECTOR_BITS)) >=
part_info->size)) {
/* errnum = ERR_OUTSIDE_PART; */
printf(" ** zfs_devread() read outside partition sector %d\n", sector);
return 1;
}

/*
* Get the read to the beginning of a partition.
*/
sector += byte_offset >> SECTOR_BITS;
byte_offset &= SECTOR_SIZE - 1;

debug(" <%d, %d, %d>\n", sector, byte_offset, byte_len);

if (zfs_blk_desc == NULL) {
printf("** Invalid Block Device Descriptor (NULL)\n");
return 1;
}

if (byte_offset != 0) {
/* read first part which isn't aligned with start of sector */
if (zfs_blk_desc->block_read(zfs_blk_desc,
part_info->start + sector, 1,
(void *)sec_buf) != 1) {
printf(" ** zfs_devread() read error **\n");
return 1;
}
memcpy(buf, sec_buf + byte_offset,
min(SECTOR_SIZE - byte_offset, byte_len));
buf += min(SECTOR_SIZE - byte_offset, byte_len);
byte_len -= min(SECTOR_SIZE - byte_offset, byte_len);
sector++;
}

if (byte_len == 0)
return 0;

/* read sector aligned part */
block_len = byte_len & ~(SECTOR_SIZE - 1);

if (block_len == 0) {
u8 p[SECTOR_SIZE];

block_len = SECTOR_SIZE;
zfs_blk_desc->block_read(zfs_blk_desc,
part_info->start + sector,
1, (void *)p);
memcpy(buf, p, byte_len);
return 0;
}

if (zfs_blk_desc->block_read(zfs_blk_desc, part_info->start + sector,
block_len / SECTOR_SIZE,
(void *)buf) != block_len / SECTOR_SIZE) {
printf(" ** zfs_devread() read error - block\n");
return 1;
}

block_len = byte_len & ~(SECTOR_SIZE - 1);
buf += block_len;
byte_len -= block_len;
sector += block_len / SECTOR_SIZE;

if (byte_len != 0) {
/* read rest of data which are not in whole sector */
if (zfs_blk_desc->block_read(zfs_blk_desc,
part_info->start + sector,
1, (void *)sec_buf) != 1) {
printf(" ** zfs_devread() read error - last part\n");
return 1;
}
memcpy(buf, sec_buf, byte_len);
}
return 0;
return fs_devread(zfs_blk_desc, part_info, sector, byte_offset,
byte_len, buf);
}
Loading

0 comments on commit 5994e8b

Please sign in to comment.