Skip to content

Commit

Permalink
Add YAML Azure Pipelines
Browse files Browse the repository at this point in the history
  • Loading branch information
walbourn committed Dec 5, 2022
1 parent 8a4c893 commit be8faf6
Show file tree
Hide file tree
Showing 9 changed files with 1,350 additions and 1 deletion.
2 changes: 1 addition & 1 deletion CMakeLists.txt
Original file line number Diff line number Diff line change
Expand Up @@ -51,7 +51,7 @@ install(TARGETS ${PROJECT_NAME}
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR})

configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/.nuget/${PROJECT_NAME}-config.cmake.in
configure_package_config_file(${CMAKE_CURRENT_SOURCE_DIR}/build/${PROJECT_NAME}-config.cmake.in
${CMAKE_CURRENT_BINARY_DIR}/${PACKAGE_NAME}-config.cmake
INSTALL_DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/${PACKAGE_NAME})

Expand Down
121 changes: 121 additions & 0 deletions build/DirectXMath-GitHub-CMake-Dev17.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,121 @@
# Copyright (c) Microsoft Corporation.
# Licensed under the MIT License.
#
# http://go.microsoft.com/fwlink/?LinkID=615560

# Builds the library and test suite using CMake.

schedules:
- cron: "0 0 * * *"
displayName: 'Nightly build'
branches:
include:
- main

resources:
repositories:
- repository: self
type: git
ref: refs/heads/main
trigger: none

name: $(Year:yyyy).$(Month).$(DayOfMonth)$(Rev:.r)

variables:
VS_GENERATOR: 'Visual Studio 17 2022'
WIN10_SDK: '10.0.19041.0'
WIN11_SDK: '10.0.22000.0'

pool:
vmImage: windows-2022

variables:
GITHUB_PAT: $(GITHUBPUBLICTOKEN)

jobs:
- job: CMAKE_BUILD
displayName: CMake using VS Generator BUILD_TESTING=ON
cancelTimeoutInMinutes: 1
steps:
- checkout: self
clean: true
fetchTags: false
- task: CmdLine@2
displayName: Fetch Tests
inputs:
script: git clone --quiet https://%GITHUB_PAT%@github.com/walbourn/directxmathtest.git Tests
- task: CMake@1
displayName: 'CMake (MSVC): Config x64'
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A x64 -B out -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: 'CMake (MSVC): Build x64 Debug'
inputs:
cwd: ''
cmakeArgs: --build out -v --config Debug
- task: CMake@1
displayName: 'CMake (MSVC): Build x64 Release'
inputs:
cwd: ''
cmakeArgs: --build out -v --config RelWithDebInfo
- task: CMake@1
displayName: 'CMake (MSVC): Config x86'
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A Win32 -B out2 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: 'CMake (MSVC): Build x86 Debug'
inputs:
cwd: ''
cmakeArgs: --build out2 -v --config Debug
- task: CMake@1
displayName: 'CMake (MSVC): Build x86 Release'
inputs:
cwd: ''
cmakeArgs: --build out2 -v --config RelWithDebInfo
- task: CMake@1
displayName: 'CMake (MSVC): Config ARM64'
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A ARM64 -B out3 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: 'CMake (MSVC): Build ARM64 Debug'
inputs:
cwd: ''
cmakeArgs: --build out3 -v --config Debug
- task: CMake@1
displayName: 'CMake (MSVC): Build ARM64 Release'
inputs:
cwd: ''
cmakeArgs: --build out3 -v --config RelWithDebInfo
- task: CMake@1
displayName: 'CMake (ClangCl): Config x64'
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A x64 -T clangcl -B out4 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: 'CMake (ClangCl): Build x64 Debug'
inputs:
cwd: ''
cmakeArgs: --build out4 -v --config Debug
- task: CMake@1
displayName: 'CMake (ClangCl): Build x64 Release'
inputs:
cwd: ''
cmakeArgs: --build out4 -v --config RelWithDebInfo
- task: CMake@1
displayName: 'CMake (ClangCl): Config ARM64'
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A ARM64 -T clangcl -B out5 -DCMAKE_SYSTEM_VERSION=$(WIN11_SDK)'
- task: CMake@1
displayName: 'CMake (ClangCl): Build ARM64 Debug'
inputs:
cwd: ''
cmakeArgs: --build out5 -v --config ARM64 Debug
- task: CMake@1
displayName: 'CMake (ClangCl): Build ARM64 Release'
inputs:
cwd: ''
cmakeArgs: --build out5 -v --config RelWithDebInfo
105 changes: 105 additions & 0 deletions build/DirectXMath-GitHub-CMake.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,105 @@
# Copyright (c) Microsoft Corporation.
# Licensed under the MIT License.
#
# http://go.microsoft.com/fwlink/?LinkID=615560

# Builds the library and test suite using CMake.

schedules:
- cron: "0 0 * * *"
displayName: 'Nightly build'
branches:
include:
- main

resources:
repositories:
- repository: self
type: git
ref: refs/heads/main
trigger: none

name: $(Year:yyyy).$(Month).$(DayOfMonth)$(Rev:.r)

variables:
VS_GENERATOR: 'Visual Studio 16 2019'
WIN10_SDK: '10.0.19041.0'

pool:
vmImage: windows-2019

variables:
GITHUB_PAT: $(GITHUBPUBLICTOKEN)

jobs:
- job: CMAKE_BUILD
displayName: CMake using VS Generator
cancelTimeoutInMinutes: 1
steps:
- checkout: self
clean: true
fetchTags: false
- task: CmdLine@2
displayName: Fetch Tests
inputs:
script: git clone --quiet https://%GITHUB_PAT%@github.com/walbourn/directxmathtest.git Tests
- task: CMake@1
displayName: CMake (MSVC x64)
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A x64 -B out -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: CMake (Build x64)
inputs:
cwd: ''
cmakeArgs: --build out -v
- task: CMake@1
displayName: CMake Test (MSVC x64)
inputs:
cwd: Tests
cmakeArgs: '-G "$(VS_GENERATOR)" -A x64 -B out -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: CMake Test (Build x64)
inputs:
cwd: Tests
cmakeArgs: --build out -v
- task: CMake@1
displayName: CMake (MSVC ARM64)
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A ARM64 -B out2 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: CMake (Build ARM64)
inputs:
cwd: ''
cmakeArgs: --build out2 -v
- task: CMake@1
displayName: CMake Test (MSVC ARM64)
inputs:
cwd: Tests
cmakeArgs: '-G "$(VS_GENERATOR)" -A ARM64 -B out2 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: CMake Test (Build ARM64)
inputs:
cwd: Tests
cmakeArgs: --build out2 -v
- task: CMake@1
displayName: CMake (ClangCl)
inputs:
cwd: ''
cmakeArgs: '-G "$(VS_GENERATOR)" -A x64 -T clangcl -B out3 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: CMake (Build)
inputs:
cwd: ''
cmakeArgs: --build out3 -v
- task: CMake@1
displayName: CMake Test (ClangCL)
inputs:
cwd: Tests
cmakeArgs: '-G "$(VS_GENERATOR)" -A x64 -T clangcl -B out3 -DCMAKE_SYSTEM_VERSION=$(WIN10_SDK)'
- task: CMake@1
displayName: CMake Test (Build)
inputs:
cwd: Tests
cmakeArgs: --build out3 -v
Loading

0 comments on commit be8faf6

Please sign in to comment.