Skip to content

Commit

Permalink
net-nds/phpldapadmin: bump to 1.2.6.3
Browse files Browse the repository at this point in the history
Bug: https://bugs.gentoo.org/760537
Closes: https://bugs.gentoo.org/755701
Signed-off-by: Tomáš Mózes <[email protected]>
Closes: gentoo#25172
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
hydrapolic authored and thesamesam committed May 31, 2022
1 parent a0d4f1f commit 10d9ee0
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions net-nds/phpldapadmin/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST phpldapadmin-1.2.5.tar.gz 1117335 BLAKE2B 00d82434dbdadf1f90f5f356ad644d7cfa078cc0696d7cf64e36bc49baf2a5f29bd62fbcd265d9771e713bdd19d4e5708e77e1229199b6712874f982f9b067b0 SHA512 53cf5a8fb3ae3e5fc3c2ab6d23fb9cf731f1d39e122db6531e87461610f13e4bc1c9e8d4fcf7abd2ee5697022a068a9e23d8e039ba79a12929faeb6265920701
DIST phpldapadmin-1.2.6.3.tar.gz 1130061 BLAKE2B d1183a89db659eeadbf33632edabb1f24d855eea3f37d36128b5a4262a4979f1fa1f963b2d1e43c4d07c988899a7c4cfb72a6f88e13ee5a830654686eaecf183 SHA512 66aeb81c812830968df5d3a2f0ccdd479fe5d7ed3bb729c0fb9991d3efa20263a493b38bfe48c99ad2c93c2ee549f51f53e064fb1381bc7e126ca2ad2bfc3167
51 changes: 51 additions & 0 deletions net-nds/phpldapadmin/phpldapadmin-1.2.6.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit webapp

MY_PN="phpLDAPadmin"
DESCRIPTION="phpLDAPadmin is a web-based tool for managing all aspects of your LDAP server"
HOMEPAGE="http://phpldapadmin.sourceforge.net"
SRC_URI="https://github.com/leenooks/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-2"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
IUSE=""

RDEPEND="
>=dev-lang/php-7.2[hash(+),ldap,session,xml,nls]
virtual/httpd-php
"
S="${WORKDIR}/${MY_PN}-${PV}"

# http://phpldapadmin.git.sourceforge.net/git/gitweb.cgi?p=phpldapadmin/phpldapadmin;a=commit;h=7dc8d57d6952fe681cb9e8818df7f103220457bd
PATCHES=(
"${FILESDIR}/${PN}-1.2.1.1-fix-magic-quotes.patch"
)

need_httpd_cgi

src_prepare() {
mv config/config.php.example config/config.php
default
}

src_install() {
webapp_src_preinst

dodoc INSTALL.md

# Restrict config file access - bug 280836
chown root:apache "config/config.php"
chmod 640 "config/config.php"

insinto "${MY_HTDOCSDIR}"
doins -r *

webapp_configfile "${MY_HTDOCSDIR}/config/config.php"
webapp_postinst_txt en "${FILESDIR}"/postinstall2-en.txt

webapp_src_install
}

0 comments on commit 10d9ee0

Please sign in to comment.