Skip to content

Commit

Permalink
dev-qt/qtchooser: bump to v66
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.52, Repoman-2.3.12
Signed-off-by: Davide Pesavento <[email protected]>
  • Loading branch information
Pesa committed Dec 22, 2018
1 parent 00928a2 commit 1a664a5
Show file tree
Hide file tree
Showing 2 changed files with 51 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-qt/qtchooser/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST qtchooser-0_p20170803.tar.xz 32012 BLAKE2B a0363ccebfd17c2ad514afbaf7ea80456826a42b88badff3a2ff4259745721f336a1b034f4a51831832f5b2dcd042c7c010c47e0f17b77ecacc5520f0c6f8d53 SHA512 320d898617ad52392fe24834e99ace685dac84e3a7edb1f6e6358baadb6658a51b02ae1af465ef5e081485a002c787c6884b6e1637ffd0406767fe7555fc32a7
DIST qtchooser-66.tar.xz 32008 BLAKE2B 1faf4a44406655621e65132289af6a8b0d23f0c1027a3b99017c3951705378bebcfbc3cb32aa59975a101f21294ff701ca6eb6ec18ce977b714a426be0fbcd6d SHA512 0c7d3588ddd7b21e6e9d799204924e06e0b0950c898dfd23088f1e7657b7f821a35579aa062658499809f9d9757e82c3c592591aa2e5ec453463929bf2b33bac
50 changes: 50 additions & 0 deletions dev-qt/qtchooser/qtchooser-66.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,50 @@
# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit qmake-utils toolchain-funcs

DESCRIPTION="Tool to quickly switch between multiple Qt installations"
HOMEPAGE="https://code.qt.io/cgit/qtsdk/qtchooser.git/"
SRC_URI="http://download.qt.io/official_releases/${PN}/${P}.tar.xz"

LICENSE="|| ( LGPL-2.1 GPL-3 )"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd"
IUSE="test"

DEPEND="test? (
dev-qt/qtcore:5
dev-qt/qttest:5
)"
RDEPEND=""

qtchooser_make() {
emake \
CXX="$(tc-getCXX)" \
LFLAGS="${LDFLAGS}" \
prefix="${EPREFIX}/usr" \
"$@"
}

src_compile() {
qtchooser_make
}

src_test() {
pushd tests/auto >/dev/null || die
eqmake5
popd >/dev/null || die

qtchooser_make check
}

src_install() {
qtchooser_make INSTALL_ROOT="${D}" install

keepdir /etc/xdg/qtchooser

# TODO: bash and zsh completion
# newbashcomp scripts/${PN}.bash ${PN}
}

0 comments on commit 1a664a5

Please sign in to comment.