Skip to content

Commit

Permalink
dev-qt/qt3d: 5.15.4 version bump
Browse files Browse the repository at this point in the history
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed May 20, 2022
1 parent 5332843 commit 5247e76
Show file tree
Hide file tree
Showing 2 changed files with 48 additions and 0 deletions.
2 changes: 2 additions & 0 deletions dev-qt/qt3d/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,4 @@
DIST qt3d-5.15.3-gentoo-kde-1.tar.xz 19244 BLAKE2B 3274f171719204af30272e4c20fd509f180a48bd7f179d1656dfc2d638154ed51efc0952c371e6ca707e035142ab0d1e074f4587ca47673673150265f88305fd SHA512 d453cc8eb91214165c3257fa9379efcd1f2c3e4c605895df82366006a9405b37a1222f93334e7925aebf27c5118d576e0ab1b3e24d27aef68cc51f114bc9fbfc
DIST qt3d-5.15.4-gentoo-kde-1.tar.xz 18844 BLAKE2B 2ed592d7bbf5bb4c0adee70ac74fd46207e78e769b19d083d6317d1d561618135769914ac8b4e9d266c28b09764e89fe5dbbe2237c81ff48b27efff99a0ee5a1 SHA512 bca5329a68a1ffc5b679db847a1b327e746170fb194a091feb1a61dbf6fe30b3af1cf9c9c57a3a1b16c6af4a0529bbb309eb2bd269613d65f666203164562cd4
DIST qt3d-everywhere-opensource-src-5.15.3.tar.xz 81930768 BLAKE2B 4ead826b786074993b8c536b4b7c8d781126d402ea55da116201b3d1ea859c83b9d46618b7705b14371064fc41d8aa249efbc5db62f0e9e88fb1424c03bc7a45 SHA512 1fa644ef53923b194efd2296c1505e2193897057774411b1bc50651c2fc4e781e427de13cdc4c1c770294a39d06f8e7360353361c75222c0eb457b560943d97c
DIST qt3d-everywhere-opensource-src-5.15.4.tar.xz 81923836 BLAKE2B 60ca6a00bec8c20e1b2c209e4d15dd5b2e836eb578c98a90dbf02db89d5fc07642106cc0248a1fb356694793f5fdb5e3b6ab9898bc4e87730c379cbd3d1d8a48 SHA512 cb2ea961109a153e78147450310408f4f573186d12412ebdd71511eb273ca78113d3aede583ec8aa44fe19f5268bb6fab3386c5501142ad6a22e10890ce52f62
46 changes: 46 additions & 0 deletions dev-qt/qt3d/qt3d-5.15.4.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,46 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

QT5_KDEPATCHSET_REV=1
inherit qt5-build

DESCRIPTION="3D rendering module for the Qt5 framework"

if [[ ${QT5_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
fi

# TODO: tools
IUSE="gamepad gles2-only qml vulkan"

RDEPEND="
=dev-qt/qtconcurrent-${QT5_PV}*
=dev-qt/qtcore-${QT5_PV}*
=dev-qt/qtgui-${QT5_PV}*:5=[vulkan=]
=dev-qt/qtnetwork-${QT5_PV}*
>=media-libs/assimp-4.0.0
gamepad? ( =dev-qt/qtgamepad-${QT5_PV}* )
qml? ( =dev-qt/qtdeclarative-${QT5_PV}*[gles2-only=] )
"
DEPEND="${RDEPEND}
vulkan? ( dev-util/vulkan-headers )
"

src_prepare() {
rm -r src/3rdparty/assimp/{code,contrib,include} || die

qt_use_disable_mod gamepad gamepad src/input/frontend/frontend.pri
qt_use_disable_mod qml quick src/src.pro

qt5-build_src_prepare
}

src_configure() {
local myqmakeargs=(
--
-system-assimp
)
qt5-build_src_configure
}

0 comments on commit 5247e76

Please sign in to comment.