Skip to content

Commit

Permalink
app-misc/datovka: version bump 4.17.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: Amy Liffey <[email protected]>
  • Loading branch information
Amynka committed Aug 8, 2021
1 parent 8e13909 commit 7697b67
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-misc/datovka/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST datovka-4.15.3.tar.xz 2827960 BLAKE2B 765b48f0608f3cbd947e5191778a0ae88e1fcb6679bc252160c8f5ed2b186f672fcfe2b55db67182d9a07676ebab01a272b70fced151e7f8ae027a632c6d9879 SHA512 e3791dae451ce7b42bd50cfdf0191430e3d1b5d8101a70e5c1466296b03d94e798dc080b663ff98bdf9dd80138f5d067ae5d493aeaf89285d66095b24ce15f1a
DIST datovka-4.17.0.tar.xz 2942828 BLAKE2B 3ee1c9a02d8d5fe470cd59925f01ec8f420cceef36ddae951136c3b4191582da20c4ce35c64df2428034815ab2f6d498b2cf839e10ad33dcebaf86c919f2ecd1 SHA512 d5ab51c8eba611094bba113e51447d1964fe3833a9b842353168725afedb96aadef39d2f103ff344f0c28d989ec89f429415cb9f89bd5b6c2fbf5338374bbcb5
54 changes: 54 additions & 0 deletions app-misc/datovka/datovka-4.17.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit qmake-utils xdg-utils

DESCRIPTION="GUI to access the Czech data box e-government system"
HOMEPAGE="https://www.datovka.cz/"
SRC_URI="https://secure.nic.cz/files/datove_schranky/${PV}/${P}.tar.xz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""

# minimum Qt version required
QT_PV="5.14.0:5"

RDEPEND="
>=dev-libs/openssl-1.0.2:0=
>=dev-qt/qtcore-${QT_PV}
>=dev-qt/qtgui-${QT_PV}
>=dev-qt/qtnetwork-${QT_PV}
>=dev-qt/qtprintsupport-${QT_PV}
>=dev-qt/qtsql-${QT_PV}[sqlite]
>=dev-qt/qtsvg-${QT_PV}
>=dev-qt/qtwidgets-${QT_PV}
>=net-libs/libisds-0.11
"
DEPEND="
${RDEPEND}
>=dev-qt/linguist-tools-${QT_PV}
virtual/pkgconfig
"
DOCS=( ChangeLog README )

src_configure() {
lrelease datovka.pro || die
eqmake5 PREFIX="/usr" DISABLE_VERSION_NOTIFICATION=1 TEXT_FILES_INST_DIR="/usr/share/${PN}/"
}

src_install() {
emake install INSTALL_ROOT="${D}"
einstalldocs
}

pkg_postinst() {
xdg_icon_cache_update
}

pkg_postrm() {
xdg_icon_cache_update
}

0 comments on commit 7697b67

Please sign in to comment.