Skip to content

Commit

Permalink
media-libs/libfpx: EAPI8 bump, fix bug #847412
Browse files Browse the repository at this point in the history
Signed-off-by: Michael Mair-Keimberger <[email protected]>

Closes: https://bugs.gentoo.org/847412
Closes: gentoo#35019
Signed-off-by: Conrad Kostecki <[email protected]>
  • Loading branch information
mm1ke authored and ConiKost committed Mar 16, 2024
1 parent c1cc72e commit a357ebd
Showing 1 changed file with 52 additions and 0 deletions.
52 changes: 52 additions & 0 deletions media-libs/libfpx/libfpx-1.3.1_p10-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,52 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

inherit flag-o-matic libtool

DESCRIPTION="Library for manipulating FlashPIX images"
HOMEPAGE="https://github.com/ImageMagick/libfpx"
SRC_URI="mirror://imagemagick/delegates/${P/_p/-}.tar.bz2"
S="${WORKDIR}/${P/_p/-}"

LICENSE="Flashpix"
SLOT="0/1"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="static-libs"

PATCHES=(
"${FILESDIR}"/${PN}-1.2.0.13-export-symbols.patch
"${FILESDIR}"/${PN}-1.3.1_p10-musl-1.2.3-null.patch
)

src_prepare() {
default

# we're not windows, even though we don't define __unix by default
[[ ${CHOST} == *-darwin* ]] && append-flags -D__unix

elibtoolize
}

src_configure() {
append-ldflags -Wl,--no-undefined
econf \
$(use_enable static-libs static) \
LIBS="-lstdc++ -lm"
}

src_install() {
default

# bug 847412
if ! use static-libs; then
find "${ED}" -type f -name '*.la' -delete || die
fi

dodoc AUTHORS ChangeLog doc/*.txt

docinto pdf
dodoc doc/*.pdf
docompress -x /usr/share/doc/${PF}/pdf
}

0 comments on commit a357ebd

Please sign in to comment.