Skip to content

Commit

Permalink
dev-ada/gtkada: add 24.0.0
Browse files Browse the repository at this point in the history
Signed-off-by: Alfredo Tupone <[email protected]>
  • Loading branch information
atupone committed Mar 16, 2024
1 parent 06de4d0 commit d394294
Show file tree
Hide file tree
Showing 2 changed files with 55 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ada/gtkada/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gtkada-23.0.0.tar.gz 6045493 BLAKE2B 05efb40453aa6f3ebd3beaf3dd7915bc2cca8cfec211bc6ae2f0a7a15f16029b1142028422367dbd4f68e72e02b71c030eec39802b0f9202e411d611a1fe521b SHA512 ea5dffe4fe1b99cfbd952bace510aff9e0f79fe2fa075c299d12e68dfb43b6334df0d707631de30e6e2c3a80759d342b178e8ed29a82e90445e450cfd332767f
DIST gtkada-24.0.0.tar.gz 6046333 BLAKE2B 38db0d87c978bd608344a3e7eda5642bb9d2e73e0a201f65910c96baa4ede410071713190597ce5190ddc49b9ee7b44cc83e64e73cd34ceec00dc2613e24bc33 SHA512 b1c2cd9fe2d7fa6e39b007d64edebdc725132af892442454a0950e5533bf19a0d53e195d56282086f0d6cec1047d54109b933daf6a16f795aca613a01ee9ee61
54 changes: 54 additions & 0 deletions dev-ada/gtkada/gtkada-24.0.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,54 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=8

ADA_COMPAT=( gnat_2021 gcc_12 gcc_13 )
inherit ada autotools multiprocessing

DESCRIPTION="A complete Ada graphical toolkit"
HOMEPAGE="http://libre.adacore.com//tools/gtkada/"
SRC_URI="https://github.com/AdaCore/${PN}/archive/refs/tags/v${PV}.tar.gz
-> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~x86"
IUSE="+shared static-libs static-pic"

RDEPEND="${ADA_DEPS}
app-accessibility/at-spi2-core
dev-libs/glib:2
media-libs/fontconfig
media-libs/freetype
x11-libs/cairo
x11-libs/gdk-pixbuf:2
x11-libs/gtk+:3
x11-libs/pango"
DEPEND="${RDEPEND}
dev-ada/gprbuild[${ADA_USEDEP}]"

REQUIRED_USE="${ADA_REQUIRED_USE}"

PATCHES=( "${FILESDIR}"/${PN}-23.0.0-gentoo.patch )

src_prepare() {
default
eautoreconf
}

src_configure() {
econf \
$(use_enable static-libs static) \
$(use_enable shared) \
$(use_enable static-pic)
}

src_compile() {
emake -j1 PROCESSORS=$(makeopts_jobs)
}

src_install() {
emake -j1 DESTDIR="${D}" install
einstalldocs
}

0 comments on commit d394294

Please sign in to comment.