Skip to content

Commit

Permalink
docs/manual: rename *.txt as *.adoc
Browse files Browse the repository at this point in the history
by using this standard extension `adoc`,
these files are rendered on gitlab & github

Signed-off-by: Francois Perrad <[email protected]>
Signed-off-by: Thomas Petazzoni <[email protected]>
  • Loading branch information
fperrad authored and tpetazzoni committed Sep 30, 2023
1 parent b1f9c51 commit 32cec3b
Show file tree
Hide file tree
Showing 78 changed files with 172 additions and 172 deletions.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
58 changes: 58 additions & 0 deletions docs/manual/adding-packages.adoc
Original file line number Diff line number Diff line change
@@ -0,0 +1,58 @@
// -*- mode:doc; -*-
// vim: set syntax=asciidoc:

[[adding-packages]]
== Adding new packages to Buildroot

This section covers how new packages (userspace libraries or
applications) can be integrated into Buildroot. It also shows how
existing packages are integrated, which is needed for fixing issues or
tuning their configuration.

When you add a new package, be sure to test it in various conditions
(see xref:testing-package[]) and also check it for coding style (see
xref:check-package[]).

include::adding-packages-directory.adoc[]

include::adding-packages-generic.adoc[]

include::adding-packages-autotools.adoc[]

include::adding-packages-cmake.adoc[]

include::adding-packages-python.adoc[]

include::adding-packages-luarocks.adoc[]

include::adding-packages-perl.adoc[]

include::adding-packages-virtual.adoc[]

include::adding-packages-kconfig.adoc[]

include::adding-packages-rebar.adoc[]

include::adding-packages-waf.adoc[]

include::adding-packages-meson.adoc[]

include::adding-packages-cargo.adoc[]

include::adding-packages-golang.adoc[]

include::adding-packages-qmake.adoc[]

include::adding-packages-kernel-module.adoc[]

include::adding-packages-asciidoc.adoc[]

include::adding-packages-linux-kernel-spec-infra.adoc[]

include::adding-packages-hooks.adoc[]

include::adding-packages-gettext.adoc[]

include::adding-packages-tips.adoc[]

include::adding-packages-conclusion.adoc[]
58 changes: 0 additions & 58 deletions docs/manual/adding-packages.txt

This file was deleted.

16 changes: 16 additions & 0 deletions docs/manual/advanced.adoc
Original file line number Diff line number Diff line change
@@ -0,0 +1,16 @@
// -*- mode:doc; -*-
// vim: set syntax=asciidoc:

=== Advanced usage

include::using-buildroot-toolchain.adoc[]

include::using-buildroot-debugger.adoc[]

include::ccache-support.adoc[]

include::download-location.adoc[]

include::package-make-target.adoc[]

include::using-buildroot-development.adoc[]
16 changes: 0 additions & 16 deletions docs/manual/advanced.txt

This file was deleted.

6 changes: 6 additions & 0 deletions docs/manual/appendix.adoc
Original file line number Diff line number Diff line change
@@ -0,0 +1,6 @@
// -*- mode:doc; -*-
// vim: set syntax=asciidoc:

include::makedev-syntax.adoc[]
include::makeusers-syntax.adoc[]
include::migrating.adoc[]
6 changes: 0 additions & 6 deletions docs/manual/appendix.txt

This file was deleted.

File renamed without changes.
File renamed without changes.
Original file line number Diff line number Diff line change
Expand Up @@ -3,9 +3,9 @@

== General Buildroot usage

include::make-tips.txt[]
include::make-tips.adoc[]

include::rebuilding-packages.txt[]
include::rebuilding-packages.adoc[]

=== Offline builds

Expand Down Expand Up @@ -417,4 +417,4 @@ effects:
be empty and it's only at the very end of the build that they will
be populated.

include::advanced.txt[]
include::advanced.adoc[]
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
Original file line number Diff line number Diff line change
Expand Up @@ -153,4 +153,4 @@ Using `fakeroot` is not an absolute substitute for actually being root.
`fakeroot` only ever fakes the file access rights and types (regular,
block-or-char device...) and uid/gid; these are emulated in-memory.

include::customize-device-permission-tables.txt[]
include::customize-device-permission-tables.adoc[]
File renamed without changes.
18 changes: 9 additions & 9 deletions docs/manual/customize.txt → docs/manual/customize.adoc
Original file line number Diff line number Diff line change
Expand Up @@ -41,20 +41,20 @@ image in a reproducible way, even after running 'make clean'. By
following the recommended strategy, you can even use the same Buildroot
tree to build multiple distinct projects!

include::customize-directory-structure.txt[]
include::customize-directory-structure.adoc[]

include::customize-outside-br.txt[]
include::customize-outside-br.adoc[]

include::customize-configuration.txt[]
include::customize-configuration.adoc[]

include::customize-rootfs.txt[]
include::customize-rootfs.adoc[]

include::customize-users-tables.txt[]
include::customize-users-tables.adoc[]

include::customize-post-image.txt[]
include::customize-post-image.adoc[]

include::customize-patches.txt[]
include::customize-patches.adoc[]

include::customize-packages.txt[]
include::customize-packages.adoc[]

include::customize-quick-guide.txt[]
include::customize-quick-guide.adoc[]
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
4 changes: 2 additions & 2 deletions docs/manual/integration.txt → docs/manual/integration.adoc
Original file line number Diff line number Diff line change
Expand Up @@ -9,6 +9,6 @@ level. Buildroot is highly configurable, almost everything discussed
here can be changed or overridden by xref:rootfs-custom[rootfs overlay
or custom skeleton] configuration.

include::integration-systemd.txt[]
include::integration-systemd.adoc[]

include::integration-selinux-support.txt[]
include::integration-selinux-support.adoc[]
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
75 changes: 75 additions & 0 deletions docs/manual/manual.adoc
Original file line number Diff line number Diff line change
@@ -0,0 +1,75 @@
// -*- mode:doc; -*-
// vim: set syntax=asciidoc:

= The Buildroot user manual
:toc:

Buildroot {sys:echo $\{BR2_VERSION%%-git*\}} manual generated on {localdate}
{localtime} from git revision {sys:git rev-parse --short HEAD}

The Buildroot manual is written by the Buildroot developers.
It is licensed under the GNU General Public License, version 2. Refer to the
http://git.buildroot.org/buildroot/tree/COPYING?id={sys:git rev-parse HEAD}[COPYING]
file in the Buildroot sources for the full text of this license.

Copyright (C) The Buildroot developers <[email protected]>

image::logo.png[]

= Getting started

include::introduction.adoc[]

include::prerequisite.adoc[]

include::getting.adoc[]

include::quickstart.adoc[]

include::resources.adoc[]

= User guide

include::configure.adoc[]

include::configure-other-components.adoc[]

include::common-usage.adoc[]

include::customize.adoc[]

include::integration.adoc[]

include::faq-troubleshooting.adoc[]

include::known-issues.adoc[]

include::legal-notice.adoc[]

include::beyond-buildroot.adoc[]

= Developer guide

include::how-buildroot-works.adoc[]

include::writing-rules.adoc[]

include::adding-board-support.adoc[]

include::adding-packages.adoc[]

include::patch-policy.adoc[]

include::download-infra.adoc[]

include::debugging-buildroot.adoc[]

include::contribute.adoc[]

include::developers.adoc[]

include::release-engineering.adoc[]

= Appendix

include::appendix.adoc[]
2 changes: 1 addition & 1 deletion docs/manual/manual.mk
Original file line number Diff line number Diff line change
Expand Up @@ -4,7 +4,7 @@
#
################################################################################

MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.txt) $(wildcard docs/images/*))
MANUAL_SOURCES = $(sort $(wildcard docs/manual/*.adoc) $(wildcard docs/images/*))
MANUAL_RESOURCES = $(TOPDIR)/docs/images

$(eval $(call asciidoc-document))
75 changes: 0 additions & 75 deletions docs/manual/manual.txt

This file was deleted.

File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
File renamed without changes.
2 changes: 1 addition & 1 deletion package/doc-asciidoc.mk
Original file line number Diff line number Diff line change
Expand Up @@ -124,7 +124,7 @@ $$(O)/docs/$(1)/$(1).$(5): $$($(2)_SOURCES) \
--resource="$$(abspath $$(r))") \
$$($(2)_$(3)_A2X_OPTS) \
--asciidoc-opts="$$($(2)_$(3)_ASCIIDOC_OPTS)" \
$$(BUILD_DIR)/docs/$(1)/$(1).txt
$$(BUILD_DIR)/docs/$(1)/$(1).adoc
# install the generated document
$$($(2)_$(3)_INSTALL_CMDS)
endif
Expand Down

0 comments on commit 32cec3b

Please sign in to comment.