forked from OpenDingux/buildroot
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
LibreSSL doesn't build properly on MIPS and a fix is coming upstream. Meanwhile, fix it here with a local patch. Signed-off-by: Paul Cercueil <[email protected]>
- Loading branch information
Showing
1 changed file
with
26 additions
and
0 deletions.
There are no files selected for viewing
26 changes: 26 additions & 0 deletions
26
board/opendingux/patches/libressl/0001-crypto-Fix-build-on-MIPS.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,26 @@ | ||
From ec4c7b5459de395880221217471b91a55156de5b Mon Sep 17 00:00:00 2001 | ||
From: Paul Cercueil <[email protected]> | ||
Date: Fri, 8 Dec 2023 12:51:31 +0100 | ||
Subject: [PATCH] crypto: Fix build on MIPS | ||
|
||
Signed-off-by: Paul Cercueil <[email protected]> | ||
--- | ||
crypto/CMakeLists.txt | 2 ++ | ||
1 file changed, 2 insertions(+) | ||
|
||
diff --git a/crypto/CMakeLists.txt b/crypto/CMakeLists.txt | ||
index 7efb143..4b2c21c 100644 | ||
--- a/crypto/CMakeLists.txt | ||
+++ b/crypto/CMakeLists.txt | ||
@@ -970,6 +970,8 @@ elseif(HOST_ARM) | ||
target_include_directories(crypto_obj PRIVATE bn/arch/arm/) | ||
elseif(HOST_I386) | ||
target_include_directories(crypto_obj PRIVATE bn/arch/i386/) | ||
+elseif(HOST_MIPS) | ||
+ target_include_directories(crypto_obj PRIVATE bn/arch/mips) | ||
elseif(HOST_MIPS64) | ||
target_include_directories(crypto_obj PRIVATE bn/arch/mips64) | ||
elseif(HOST_POWERPC) | ||
-- | ||
2.42.0 | ||
|