forked from OpenDingux/buildroot
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
package/solarus: fix OpenGLES2 build
1. Adds a patch that fixes OpenGLES2 build https://gitlab.com/solarus-games/solarus/-/merge_requests/1364 2. Updates Config.in and solarus.mk to support OpenGLES2 Signed-off-by: Gleb Mazovetskiy <[email protected]> [[email protected]: renumber patch] Signed-off-by: Yann E. MORIN <[email protected]>
- Loading branch information
1 parent
1cf3c39
commit dc19702
Showing
3 changed files
with
57 additions
and
2 deletions.
There are no files selected for viewing
48 changes: 48 additions & 0 deletions
48
package/solarus/0002-Add-a-basic-FindOpenGLES2.cmake.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,48 @@ | ||
From 2bf0e98f17d92fd86ee61be179e3cebe93f75ea7 Mon Sep 17 00:00:00 2001 | ||
From: Gleb Mazovetskiy <[email protected]> | ||
Date: Sun, 3 Jan 2021 12:38:13 +0000 | ||
Subject: [PATCH] Add a basic FindOpenGLES2.cmake | ||
|
||
Fixes #1324 | ||
--- | ||
cmake/modules/FindOpenGLES2.cmake | 28 ++++++++++++++++++++++++++++ | ||
1 file changed, 28 insertions(+) | ||
create mode 100644 cmake/modules/FindOpenGLES2.cmake | ||
|
||
diff --git a/cmake/modules/FindOpenGLES2.cmake b/cmake/modules/FindOpenGLES2.cmake | ||
new file mode 100644 | ||
index 000000000..70fd5e6f0 | ||
--- /dev/null | ||
+++ b/cmake/modules/FindOpenGLES2.cmake | ||
@@ -0,0 +1,28 @@ | ||
+# Try to find OpenGLES2. Once done this will define: | ||
+# OPENGLES2_FOUND | ||
+# OPENGLES2_INCLUDE_DIRS | ||
+# OPENGLES2_LIBRARIES | ||
+# OPENGLES2_DEFINITIONS | ||
+ | ||
+find_package(PkgConfig QUIET) | ||
+ | ||
+pkg_check_modules(PC_OPENGLES2 glesv2) | ||
+ | ||
+if (PC_OPENGLES2_FOUND) | ||
+ set(OPENGLES2_DEFINITIONS ${PC_OPENGLES2_CFLAGS_OTHER}) | ||
+endif () | ||
+ | ||
+find_path(OPENGLES2_INCLUDE_DIRS NAMES GLES2/gl2.h | ||
+ HINTS ${PC_OPENGLES2_INCLUDEDIR} ${PC_OPENGLES2_INCLUDE_DIRS} | ||
+) | ||
+ | ||
+set(OPENGLES2_NAMES ${OPENGLES2_NAMES} glesv2 GLESv2) | ||
+find_library(OPENGLES2_LIBRARIES NAMES ${OPENGLES2_NAMES} | ||
+ HINTS ${PC_OPENGLES2_LIBDIR} ${PC_OPENGLES2_LIBRARY_DIRS} | ||
+) | ||
+ | ||
+include(FindPackageHandleStandardArgs) | ||
+find_package_handle_standard_args(OpenGLES2 REQUIRED_VARS OPENGLES2_INCLUDE_DIRS OPENGLES2_LIBRARIES | ||
+ FOUND_VAR OPENGLES2_FOUND) | ||
+ | ||
+mark_as_advanced(OPENGLES2_INCLUDE_DIRS OPENGLES2_LIBRARIES) | ||
-- | ||
2.27.0 | ||
|
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters