Skip to content

Commit

Permalink
opendingux: Fix libboost static linking with 2022.08 Buildroot
Browse files Browse the repository at this point in the history
The libboost package was updated between 2021.08 and 2022.08 and the old
way to force static linking didn't work anymore.

Signed-off-by: Paul Cercueil <[email protected]>
  • Loading branch information
pcercuei committed Dec 18, 2022
1 parent f77ce86 commit e02f5dd
Showing 1 changed file with 19 additions and 1 deletion.
20 changes: 19 additions & 1 deletion board/opendingux/package/boost/boost.mk
Original file line number Diff line number Diff line change
@@ -1 +1,19 @@
BOOST_OPTS = link=static runtime-link=static
NEW_BOOST_OPTS = $(filter-out link=shared runtime-link=shared,$(BOOST_OPTS)) link=static runtime-link=static

undefine BOOST_BUILD_CMDS
undefine BOOST_INSTALL_TARGET_CMDS
undefine BOOST_INSTALL_STAGING_CMDS

define BOOST_BUILD_CMDS
cd $(@D) && $(TARGET_MAKE_ENV) ./b2 $(NEW_BOOST_OPTS)
endef

define BOOST_INSTALL_TARGET_CMDS
cd $(@D) && $(TARGET_MAKE_ENV) ./b2 $(NEW_BOOST_OPTS) \
--prefix=$(TARGET_DIR)/usr install
endef

define BOOST_INSTALL_STAGING_CMDS
cd $(@D) && $(TARGET_MAKE_ENV) ./b2 $(NEW_BOOST_OPTS) \
--prefix=$(STAGING_DIR)/usr install
endef

0 comments on commit e02f5dd

Please sign in to comment.