Skip to content

Commit

Permalink
www-plugins/mozrepl: New ebuild for bug#463548, thanks to hasufell, Z…
Browse files Browse the repository at this point in the history
…ero_Chaos and Tommy[D]
  • Loading branch information
jauhien committed Mar 27, 2013
1 parent 5927ecb commit f47eda9
Show file tree
Hide file tree
Showing 4 changed files with 84 additions and 0 deletions.
10 changes: 10 additions & 0 deletions www-plugins/mozrepl/ChangeLog
Original file line number Diff line number Diff line change
@@ -0,0 +1,10 @@
# ChangeLog for www-plugins/mozrepl
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
# $Header: $

*mozrepl-1.1.0 (27 Mar 2013)

27 Mar 2013; Jauhien Piatlicki (jauhien) <[email protected]>
+mozrepl-1.1.0.ebuild, +metadata.xml:
New ebuild for bug#463548, thanks to hasufell, Zero_Chaos and Tommy[D]

4 changes: 4 additions & 0 deletions www-plugins/mozrepl/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
DIST mozrepl-1.1.0.tar.gz 20709 SHA256 4b3dbaa1aa347749f7529eec0162474795dc8c6aef5a9816f6c42101dfffedff SHA512 b20e15ca96e1c4f3ea6d9c0ae79e1a908dd8e74ad420cbf6be6f395dc1c5f3e0ca7a9f48ca66b41334bd32dae6a1bf023842d6f463f3eab251ec016f828c4e90 WHIRLPOOL 9dbac105a9a41261f7358ad91fd96961f5ce1cef0d8b4ba6b989b2da8d854780e50e64f817a59dd0216e342c1c0fa2e577c018a632cc0895c1599fb4246af503
EBUILD mozrepl-1.1.0.ebuild 1319 SHA256 fb17f00cecffe54509807d0a0f2d40d6b5a780ada2f3bc5f8f7cdb4f5ec8193f SHA512 e68df0aa412888a6c243bc68355553fdcf093088c9086b99569adc8905d041381f295da73d05eaacdcc5c127e8f20d1d403e53cfdbf139f20117f4c53c22f6f8 WHIRLPOOL 94c37f3b7c6380b3fea5d5c28d8cff5d72b856b3892622c8d9c3fc3eb600c06824caaae9dd7709fed21dcdfb778e11468373e849894219f33582550e84c2bb2b
MISC ChangeLog 329 SHA256 74a0211025e9ea8c2e9e247c2373754b04265bc17c795508b1bd7a315335cf0e SHA512 4d70275cd3a2f31556f519309c3e47a562769b93b277833b207cd9332fec9c2e5271c4e413e3c53fb13e4cc625fe3cbb455fef5244fb41f74b217bfcd349e968 WHIRLPOOL 02ddf83fbb81c4c9b5e8d07ae61d1d4fd77b6d9f6fc5e9e341705ebe0537beb30d218a33d15b5e0bc6e9a1e34cfdf47357ea7e6f60659dc2c8b50cc2dc19195b
MISC metadata.xml 363 SHA256 5543d6474159108e84071743db72aa30d129d2c4a5d7de27abaf4f45e5696ea4 SHA512 2c88a43600cadd685dbe5775841f4c9e596a4782098a4327338fc913c9a5275fa5cc824464ec0e1b35e23a104ffe4057f73d4b53ab732e959acbabb3acee464f WHIRLPOOL 09804e03faa98fc27e35c03eefb97e819f063f0aacf1b266e7361e654c54a1b1d640c4b9aa56ac8f866b224781129a3ecddd54667ee719a5f7483700facac05f
11 changes: 11 additions & 0 deletions www-plugins/mozrepl/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<maintainer>
<email>[email protected]</email>
</maintainer>
<longdescription>
REPL for javascript that lets you program Firefox
and other Mozilla-based applications from the inside.
</longdescription>
</pkgmetadata>
59 changes: 59 additions & 0 deletions www-plugins/mozrepl/mozrepl-1.1.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,59 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Header: $

EAPI=5
inherit elisp-common multilib

DESCRIPTION="Interactive Javascript Console for Mozilla Applications Developers"
HOMEPAGE="https://github.com/bard/mozrepl/wiki http://addons.mozilla.org/firefox/addon/mozrepl"
SRC_URI="https://github.com/bard/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="MPL-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="emacs"

DEPEND="emacs? ( virtual/emacs )"
RDEPEND="${DEPEND}
|| ( www-client/firefox www-client/firefox-bin www-client/conkeror www-client/seamonkey )"

SITEFILE="50${PN}-gentoo.el"

src_prepare() {
rm components/Makefile || die
}

src_compile() {
if use emacs; then
cd chrome/content || die
elisp-make-autoload-file
elisp-compile *.el
fi
}

src_install() {
local emid="[email protected]" #test install.rdf during version bumps

insinto "/usr/share/${P}"
doins -r ./*

local MOZ_DIRS=(
"/usr/$(get_libdir)/firefox"
"/opt/firefox"
"/usr/share/conkeror"
"/usr/$(get_libdir)/seamonkey"
)

local i
for i in ${MOZ_DIRS[@]}
do
dosym "/usr/share/${P}" "${i}/extensions/${emid}"
done

if use emacs; then
cd chrome/content || die
elisp-install ${PN} *.el *.elc
elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
}

0 comments on commit f47eda9

Please sign in to comment.