Skip to content

Commit

Permalink
polarssl: enable AES-GCM and CAMELLIA-GCM ciphersuites
Browse files Browse the repository at this point in the history
Recent versions of Chrome require this ciphers to successfully handshake with
a TLS enabled uhttpd server using the ustream-polarssl backend.

If `CONFIG_GCM` is disabled, `ssl_ciphersuite_from_id()` will return `NULL`
when cipher `0x9d` is looked up, causing the calling `ssl_ciphersuite_match()`
to fail with `POLARSSL_ERR_SSL_INTERNAL_ERROR`.

Signed-off-by: Jo-Philipp Wich <[email protected]>
  • Loading branch information
jow- authored and wigyori committed Jul 4, 2016
1 parent f0b59b4 commit c7789ef
Show file tree
Hide file tree
Showing 2 changed files with 1 addition and 11 deletions.
2 changes: 1 addition & 1 deletion package/libs/polarssl/Makefile
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
PKG_NAME:=polarssl
SRC_PKG_NAME:=mbedtls
PKG_VERSION:=1.3.16
PKG_RELEASE:=1
PKG_RELEASE:=2
PKG_USE_MIPS16:=0

PKG_SOURCE:=$(SRC_PKG_NAME)-$(PKG_VERSION)-gpl.tgz
Expand Down
10 changes: 0 additions & 10 deletions package/libs/polarssl/patches/200-reduce_config.patch
Original file line number Diff line number Diff line change
Expand Up @@ -170,16 +170,6 @@

/**
* \def POLARSSL_ENTROPY_C
@@ -1662,8 +1662,8 @@
*
* This module enables the AES-GCM and CAMELLIA-GCM ciphersuites, if other
* requisites are enabled as well.
- */
#define POLARSSL_GCM_C
+ */

/**
* \def POLARSSL_HAVEGE_C
@@ -1699,8 +1699,8 @@
* Requires: POLARSSL_MD_C
*
Expand Down

0 comments on commit c7789ef

Please sign in to comment.