Skip to content

Commit

Permalink
mail-client/roundcube: 1.5.1 version bump
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.28, Repoman-3.0.3
Signed-off-by: Craig Andrews <[email protected]>
  • Loading branch information
candrews committed Nov 29, 2021
1 parent eb6089d commit 001295b
Show file tree
Hide file tree
Showing 2 changed files with 98 additions and 0 deletions.
1 change: 1 addition & 0 deletions mail-client/roundcube/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST roundcubemail-1.4.11-complete.tar.gz 7048262 BLAKE2B aaf5e6ce5b07577f687788730bc9181334402bb2ff5e78fb306425913b62b4a8f72505547bdcc8673806b48b9ba8252b8059b59399efc95a51877d5c672a4760 SHA512 2bfe0ff3716f76bf9eb5bf5f7b62c738b233c57e67d6ac767c044d1a3a694ae003642d9cc68a18d6f6ba94135aa7ee1692db920e9127128669faee9ddf78fe80
DIST roundcubemail-1.5.0-complete.tar.gz 7802014 BLAKE2B d81a521c264b47b55b7f868caf4fd8f0d7fdb2f0d04bf560bf1774c39aa4d0b4143ba1edb977941a4596848921671ec47a0dfd21f20f7e28778a021d58bec402 SHA512 cba32ee2b86864af9d9163d83fa49763267e3420bee59b86d47b889e1bc53871ed2ff5b2c1444778324f4b259e99752faa3b72f909a8f9c26c7af9c96ba08a54
DIST roundcubemail-1.5.1-complete.tar.gz 7827081 BLAKE2B 1547ba369ef8e5f2b99ed72d562de3f76ff973d9617f4394bb89e281917264c9304aeb2b44cffd16952c2295111707215fe0426ce0f3f1d4a5c94df5f0811235 SHA512 bcea37859fbbee2f474cda024e5648b823a2da44ae69e5036a5b7e6add1d73dbfc1cd1cc32a3e01e59b0a3ba2ea03d1b028eec8e8f139fc4fb3eea8b52e28203
97 changes: 97 additions & 0 deletions mail-client/roundcube/roundcube-1.5.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,97 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit webapp

MY_PN=${PN}mail
MY_PV=${PV/_/-}
MY_P=${MY_PN}-${MY_PV}

DESCRIPTION="A browser-based multilingual IMAP client with an application-like user interface"
HOMEPAGE="https://roundcube.net"

# roundcube is GPL-licensed, the rest of the licenses here are
# for bundled PEAR components, googiespell and utf8.class.php
LICENSE="GPL-3 BSD PHP-2.02 PHP-3 MIT public-domain"

IUSE="change-password enigma exif fileinfo ldap mysql postgres sqlite ssl spell zip"
REQUIRED_USE="|| ( mysql postgres sqlite )"

# this function only sets DEPEND so we need to include that in RDEPEND
need_httpd_cgi

RDEPEND="
${DEPEND}
>=dev-lang/php-5.5.0[exif?,fileinfo?,filter,gd,iconv,intl,json(+),ldap?,pdo,postgres?,session,sqlite?,ssl?,unicode,xml,zip?]
virtual/httpd-php
change-password? (
dev-lang/php[sockets]
)
enigma? (
app-crypt/gnupg
)
mysql? (
|| (
dev-lang/php[mysql]
dev-lang/php[mysqli]
)
)
spell? ( dev-lang/php[curl,spell] )
"

if [[ ${PV} == *9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/roundcube/roundcubemail"
EGIT_BRANCH="master"
BDEPEND="${BDEPEND}
app-arch/unzip
dev-php/composer
net-misc/curl"
else
SRC_URI="https://github.com/${PN}/${MY_PN}/releases/download/${MY_PV}/${MY_P}-complete.tar.gz"
S="${WORKDIR}/${MY_P}"
KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~sparc ~x86"
fi

src_unpack() {
if [[ "${PV}" == *9999* ]]; then
git-r3_src_unpack
pushd "${S}" > /dev/null || die
rm Makefile || die
mv composer.json-dist composer.json || die
composer install --no-dev || die
./bin/install-jsdeps.sh || die
popd > /dev/null || die
else
default
fi
}

src_install() {
webapp_src_preinst

dodoc CHANGELOG.md INSTALL README.md UPGRADING SECURITY.md

insinto "${MY_HTDOCSDIR}"
doins -r [[:lower:]]* SQL
doins .htaccess

webapp_serverowned "${MY_HTDOCSDIR}"/logs
webapp_serverowned "${MY_HTDOCSDIR}"/temp

webapp_configfile "${MY_HTDOCSDIR}"/config/defaults.inc.php
webapp_postupgrade_txt en "${FILESDIR}/POST-UPGRADE_complete.txt"

webapp_src_install
}

pkg_postinst() {
webapp_pkg_postinst

if [[ -n ${REPLACING_VERSIONS} ]]; then
elog "You can review the post-upgrade instructions at:"
elog "${EROOT}/usr/share/webapps/${PN}/${PV}/postupgrade-en.txt"
fi
}

0 comments on commit 001295b

Please sign in to comment.