Skip to content

Commit

Permalink
dev-python/CacheControl: New package, initial ebuild written by ercpe
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <[email protected]>
  • Loading branch information
jlec committed Aug 24, 2015
1 parent 3523fbd commit 0079935
Show file tree
Hide file tree
Showing 3 changed files with 43 additions and 0 deletions.
31 changes: 31 additions & 0 deletions dev-python/CacheControl/CacheControl-0.11.5.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,31 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy pypy3 )

inherit distutils-r1

DESCRIPTION="The httplib2 caching algorithms packaged up for use with requests"
HOMEPAGE="https://github.com/ionrock/cachecontrol https://pypi.python.org/pypi/cachecontrol/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="redis test"

RDEPEND="
dev-python/requests[${PYTHON_USEDEP}]
>=dev-python/lockfile-0.9[${PYTHON_USEDEP}]
redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )"
DEPENDS="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/pytest[${PYTHON_USEDEP}] )
"

python_test() {
py.test -v || die
}
1 change: 1 addition & 0 deletions dev-python/CacheControl/Manifest
Original file line number Diff line number Diff line change
@@ -0,0 +1 @@
DIST CacheControl-0.11.5.tar.gz 13104 SHA256 b78484d6feb17b501267f4048c364a8fc26fcef35ca3ff62bdba63d41fa4cf42 SHA512 2acce5a8be2e409a1a18254cfe71314074037bce3341f8b8fdec52c43500c90bfdb6063b2121c5cf6c8a2fc7c0903e4fd0c15813ffdfa547810b33571d211deb WHIRLPOOL 5e12640ba5c952ee8a83f5271bbbd105f148cd080bf6ae5c2cbc9c6cc20361005aa5cf1a95feaa1a808c56c26b7abdfbde3b7bffc873f26072d23262c12b49ca
11 changes: 11 additions & 0 deletions dev-python/CacheControl/metadata.xml
Original file line number Diff line number Diff line change
@@ -0,0 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>python</herd>
<use>
<flag name="redis">Allows using redis as a cache store</flag>
</use>
<upstream>
<remote-id type="github">ionrock/cachecontrol</remote-id>
</upstream>
</pkgmetadata>

0 comments on commit 0079935

Please sign in to comment.