Skip to content

Commit

Permalink
dev-lang/crystal: bump up to 0.19.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.3.0
  • Loading branch information
Sergei Trofimovich committed Sep 10, 2016
1 parent 1107b2f commit 018526a
Show file tree
Hide file tree
Showing 2 changed files with 72 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-lang/crystal/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -5,3 +5,4 @@ DIST crystal-0.18.7-1-linux-i686.tar.gz 14273325 SHA256 b84e9d4050b4667012bd7f59
DIST crystal-0.18.7-1-linux-x86_64.tar.gz 13977303 SHA256 8be06d53e91d14ad05417c5504931b0ac8485a101a98711181b6a40f008f3fa8 SHA512 69366aa66f921534cb8c3f2e03555736d6e451658e0eec1038f26e74bd8ba31c61513d61d52259291431834e8bbd941d6364f329846e81bcdfb05c5d8382343c WHIRLPOOL 7cb68ab111dc5050bb92fffe7a9b243d1bd39d097c4af39d3bb43dd5ec72e1b8e393988550255605a04084afc6e0b19270003b49ff27dd948264cd8afce49291
DIST crystal-0.18.7.tar.gz 1359375 SHA256 72b33fd4bd903a9f0957c74c2f95429e8c0f94c04df86396711b5560f540805d SHA512 4d176036d0f003cc17be73e6a0a9c5c2c9df2764123051007156d86a7dc967c93821c3e087d8c1e27fe7f7b79efa43ea0503bc902813c5b322ca12cd2212da90 WHIRLPOOL 3f7b266be386459918c2e546faf1c3989e7c285400e1f68d0af15b3a639cf72c6a08e0f821703e0413661d8080da499da22035806e0c0a6169f0dbd43792f93f
DIST crystal-0.19.0.tar.gz 1389070 SHA256 4d7d9770891bd8bd835251e2654316412a3f44074db0adeca28357c0993eb2d8 SHA512 23c2f10f32ce1340639639f784703274a9f96799b7762289144ea0551aadd4685814ffcc781750e526ee06b5418c66ec48faeaf6d95a6e63a5e26a839918958b WHIRLPOOL d310a3a738273789856c57351e74ce99bc4eddc3e7398b3e791fdd967d46ca2edc3114f2bf34916708129184e4c1d8bc53434decdb40fb82b3d415b59a3b6fc9
DIST crystal-0.19.1.tar.gz 1393220 SHA256 7528fc1ec63a3e9db9aabbccccfc8985511d6a54e44c5a1b26ccd0ee37275937 SHA512 6a2ab736ad65cbc435fae87d46cb235e2f3d88c7eb5b64bc1753f298deec0de4f72813d0413807002cde8acd21f183e6babe70e9f7a6f10e0cbdaaf205d964b6 WHIRLPOOL 695fb60acb728240525ec2dc1c2fd5779d398021b4a1ab0c7bcc58b360d11b6c927a0accceb84eae4c0f3f3c7251f356418fdd850721d14a290fdfbcfdad5fad
71 changes: 71 additions & 0 deletions dev-lang/crystal/crystal-0.19.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,71 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=6

inherit multilib

BV=0.18.7-1
BV_AMD64=${BV}-linux-x86_64
BV_X86=${BV}-linux-i686

DESCRIPTION="The Crystal Programming Language"
HOMEPAGE="http://crystal-lang.org"
SRC_URI="https://github.com/crystal-lang/crystal/archive/${PV}.tar.gz -> ${P}.tar.gz
amd64? ( https://github.com/crystal-lang/crystal/releases/download/${PV}/crystal-${BV_AMD64}.tar.gz )
x86? ( https://github.com/crystal-lang/crystal/releases/download/${PV}/crystal-${BV_X86}.tar.gz )"

LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64"
IUSE="doc examples +xml +yaml"

# dev-libs/boehm-gc[static-libs] dependency problem, check the issue: https://github.com/manastech/crystal/issues/1382
DEPEND="
>=sys-devel/llvm-3.8.0
dev-libs/boehm-gc[static-libs,threads]
dev-libs/libatomic_ops
dev-libs/libevent
dev-libs/libpcre
sys-libs/libunwind
dev-libs/pcl
dev-libs/gmp:0
"
RDEPEND="${DEPEND}
xml? ( dev-libs/libxml2 )
yaml? ( dev-libs/libyaml )
"

src_compile() {
emake \
release=1 \
threads=4 \
PATH="${WORKDIR}"/${PN}-${BV}/bin:"${PATH}" \
CRYSTAL_PATH=src \
CRYSTAL_CONFIG_VERSION=${PV} \
CRYSTAL_CONFIG_PATH="libs:${EPREFIX}/usr/$(get_libdir)/crystal"
use doc && emake doc
}

src_test() {
emake spec \
CRYSTAL_PATH=src \
CRYSTAL_CONFIG_VERSION=${PV}
}

src_install() {
insinto /usr/$(get_libdir)/crystal
doins -r src/.
dobin .build/crystal

insinto /usr/share/zsh/site-functions
newins etc/completion.zsh _crystal

use examples && dodoc -r samples

if use doc ; then
docinto api
dodoc -r doc/.
fi
}

0 comments on commit 018526a

Please sign in to comment.