Skip to content

Commit

Permalink
media-libs/gst-plugins-bad: bump to 1.12.3 for upstream bug fixes
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.6, Repoman-2.3.2
  • Loading branch information
leio committed Sep 18, 2017
1 parent 06d2c55 commit 02d4070
Show file tree
Hide file tree
Showing 2 changed files with 107 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-libs/gst-plugins-bad/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -3,3 +3,4 @@ DIST gst-plugins-bad-0.10.23.tar.xz 3155044 SHA256 03cf0786391c64625569072e90408
DIST gst-plugins-bad-1.10.3.tar.xz 4734656 SHA256 24099351fb6984c9e7560de06e072ff2e33d0b2db38b8fcc7afefb536e5094e7 SHA512 028e2c579d6e41fed2a3b7de91f3e0eac08fecd52bd67f198437909025aa41dbf4fd7ddd76decd989f8c4ca7664fad3517b403b326d8ef297bfdd006b5d79944 WHIRLPOOL 744f76c10fc534156abb49d71b4f01c663d8c14b3eb4ced988a41b0b3e1e455b988a2b2064af96f5e75f65622f6e5077c08016e29d68b12864f33fea664a613c
DIST gst-plugins-bad-1.10.5.tar.xz 4737820 SHA256 c5806040bb83b43be86ce592e6a19c5d83d7776f7d9f434eb4b911c4efff3573 SHA512 03a1b712084ace16b933b708e19922aef4f9b5f7ba0408c35865e699d70bd19e73121594449355b6252a31d9085602d8bef581fe14cfdf6c9fdcf2ddcea21e1a WHIRLPOOL 4828818d6f2a18d38b35e6b6ab3dcc5ad2465b22e2e505d84d2665cd4fc6838391d47d79256e57cc52522fa459cd0949060182aa02baa6e9ec22160335380d3b
DIST gst-plugins-bad-1.12.2.tar.xz 4702120 SHA256 9c2c7edde4f59d74eb414e0701c55131f562e5c605a3ce9b091754f106c09e37 SHA512 48c6acb7e1f58404c92371309ba7628c0f3e8ab4507ce0b3ceb56fea297a206ce8a0036cbbefdd54139996178eaa282ce463cb0fe05a5e1a457cce362b40b828 WHIRLPOOL f1d5afd0e047a4b797b76d8bb246c96ce6663f7e48def688d201e4d1560e1fd51c4d840a8b8b38476fbb9f08a1b140bf3feb0bf17d473fc764e91beb33191180
DIST gst-plugins-bad-1.12.3.tar.xz 4707000 SHA256 36d059761852bed0f1a7fcd3ef64a8aeecab95d2bca53cd6aa0f08054b1cbfec SHA512 6df47381de3a2f4286d047c1e7de2c76dd4312c9806636e2012717282cde0f3e5b2d0ffa910c564c8e122b19363e842b663cce1eda7ae95a05d63d1dbbd52661 WHIRLPOOL b4c1262a0ca63331f5cb38fecc6a26830234712d6d4409aed495b05e7cfe13760bf056767e54e17cb9899c3671f0a05b90199d80d0b47bacb2ee6d27b89a5457
106 changes: 106 additions & 0 deletions media-libs/gst-plugins-bad/gst-plugins-bad-1.12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,106 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2

EAPI=6
GST_ORG_MODULE="gst-plugins-bad"

inherit eutils flag-o-matic gstreamer virtualx

DESCRIPTION="Less plugins for GStreamer"
HOMEPAGE="https://gstreamer.freedesktop.org/"

LICENSE="LGPL-2"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux"

IUSE="X bzip2 egl gles2 gtk +introspection opengl +orc vcd vnc wayland"
REQUIRED_USE="
gles2? ( !opengl )
opengl? ( X )
wayland? ( egl )
"

# X11 is automagic for now, upstream #709530
RDEPEND="
>=dev-libs/glib-2.40.0:2[${MULTILIB_USEDEP}]
>=media-libs/gstreamer-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
>=media-libs/gst-plugins-base-${PV}:${SLOT}[${MULTILIB_USEDEP},introspection?]
introspection? ( >=dev-libs/gobject-introspection-1.31.1:= )
bzip2? ( >=app-arch/bzip2-1.0.6-r4[${MULTILIB_USEDEP}] )
egl? ( >=media-libs/mesa-9.1.6[egl,${MULTILIB_USEDEP}] )
gles2? ( >=media-libs/mesa-9.1.6[gles2,${MULTILIB_USEDEP}] )
opengl? (
>=media-libs/mesa-9.1.6[${MULTILIB_USEDEP}]
virtual/glu[${MULTILIB_USEDEP}] )
X? ( x11-libs/libX11[${MULTILIB_USEDEP}] )
wayland? (
>=dev-libs/wayland-1.4.0[${MULTILIB_USEDEP}]
>=x11-libs/libdrm-2.4.55[${MULTILIB_USEDEP}]
>=dev-libs/wayland-protocols-1.4
)
gtk? ( >=x11-libs/gtk+-3.15:3[X?,wayland?,${MULTILIB_USEDEP}] )
orc? ( >=dev-lang/orc-0.4.17[${MULTILIB_USEDEP}] )
"
DEPEND="${RDEPEND}
>=dev-util/gtk-doc-am-1.12
"

RESTRICT="test"

src_prepare() {
default
addpredict /dev # Prevent sandbox violations bug #570624
}

multilib_src_configure() {
local myconf=()
if use opengl || use gles2 ; then
# Actually enable the gl element, not just libs
myconf+=( --enable-gl )
fi

# Always enable gsettings (no extra dependency)
# and shm (need a switch for winnt ?)
gstreamer_multilib_src_configure \
$(multilib_native_use_enable introspection) \
$(use_enable bzip2 bz2) \
$(use_enable egl) \
$(use_enable gles2) \
$(use_enable gtk gtk3) \
$(use_enable opengl) \
$(use_enable opengl glx) \
$(use_enable orc) \
$(use_enable vcd) \
$(use_enable vnc librfb) \
$(use_enable wayland) \
$(use_enable X x11) \
--disable-examples \
--disable-debug \
--disable-cocoa \
--without-player-tests \
--disable-wgl \
--enable-shm \
${myconf[$@]}
# not ported
# --enable-gsettings

if multilib_is_native_abi; then
local x
for x in libs plugins; do
ln -s "${S}"/docs/${x}/html docs/${x}/html || die
done
fi
}

multilib_src_test() {
unset DISPLAY
# Tests are slower than upstream expects
virtx emake check CK_DEFAULT_TIMEOUT=300
}

multilib_src_install_all() {
DOCS="AUTHORS ChangeLog NEWS README RELEASE"
einstalldocs
prune_libtool_files --modules
}

0 comments on commit 02d4070

Please sign in to comment.