Skip to content

Commit

Permalink
games-strategy/widelands: Fix for boost 1.73
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/724316
Package-Manager: Portage-2.3.100, Repoman-2.3.22
Signed-off-by: David Seifert <[email protected]>
  • Loading branch information
SoapGentoo committed Jun 14, 2020
1 parent f268b99 commit 030ea7d
Show file tree
Hide file tree
Showing 2 changed files with 25 additions and 2 deletions.
22 changes: 22 additions & 0 deletions games-strategy/widelands/files/widelands-0.20-boost-1.73.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,22 @@
--- a/src/editor/ui_menus/categorized_item_selection_menu.h
+++ b/src/editor/ui_menus/categorized_item_selection_menu.h
@@ -124,7 +124,7 @@

UI::Checkbox* cb = create_checkbox(horizontal, descriptions_.get(i));
cb->set_state(tool_->is_enabled(i));
- cb->changedto.connect(boost::bind(&CategorizedItemSelectionMenu::selected, this, i, _1));
+ cb->changedto.connect(boost::bind(&CategorizedItemSelectionMenu::selected, this, i, boost::placeholders::_1));
checkboxes_[i] = cb;
horizontal->add(cb);
horizontal->add_space(kSpacing);
--- a/src/ui_basic/box.cc
+++ b/src/ui_basic/box.cc
@@ -104,7 +104,7 @@
int maxbreadth = mindesiredbreadth_;

for (uint32_t idx = 0; idx < items_.size(); ++idx) {
- int depth, breadth = 0;
+ int depth = 0, breadth = 0;
get_item_desired_size(idx, &depth, &breadth);

totaldepth += depth;
5 changes: 3 additions & 2 deletions games-strategy/widelands/widelands-0.20-r1.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -43,8 +43,9 @@ CMAKE_BUILD_TYPE="Release"
S="${WORKDIR}/${MY_P}"

PATCHES=(
"${FILESDIR}/${PN}-0.20_rc1-cxxflags.patch"
"${FILESDIR}/${PN}-0.20-glvnd.patch"
"${FILESDIR}"/${PN}-0.20_rc1-cxxflags.patch
"${FILESDIR}"/${PN}-0.20-glvnd.patch
"${FILESDIR}"/${PN}-0.20-boost-1.73.patch
)

src_prepare() {
Expand Down

0 comments on commit 030ea7d

Please sign in to comment.