Skip to content

Commit

Permalink
games-misc/lolcat: install lolcat binary
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/721718
Package-Manager: Portage-3.0.1, Repoman-2.3.23
Signed-off-by: Sam James <[email protected]>
  • Loading branch information
thesamesam committed Aug 8, 2020
1 parent c3b6a91 commit 0319ec3
Showing 1 changed file with 34 additions and 0 deletions.
34 changes: 34 additions & 0 deletions games-misc/lolcat/lolcat-100.0.1-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
USE_RUBY="ruby24 ruby25 ruby26 ruby27"

RUBY_FAKEGEM_TASK_TEST=""
RUBY_FAKEGEM_EXTRADOC="README.md"
RUBY_FAKEGEM_GEMSPEC="lolcat.gemspec"

inherit ruby-fakegem

DESCRIPTION="Rainbows and unicorns!"
HOMEPAGE="https://github.com/busyloop/lolcat"

LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"

ruby_add_rdepend "
dev-ruby/optimist:3
>=dev-ruby/paint-2.1:0"

all_ruby_prepare() {
sed -e '/manpages/ s:^:#:' \
-e 's/git ls-files --/echo/' \
-e 's/git ls-files/find/' \
-i ${RUBY_FAKEGEM_GEMSPEC} || die
}

all_ruby_install() {
doman man/lolcat.6
ruby_fakegem_binwrapper lolcat
}

0 comments on commit 0319ec3

Please sign in to comment.