Skip to content

Commit

Permalink
app-pda/libplist: Simplify configure test for fmin
Browse files Browse the repository at this point in the history
libimobiledevice/libplist#168

Package-Manager: Portage-3.0.2, Repoman-2.3.23
Bug: https://bugs.gentoo.org/736866
Signed-off-by: Jeroen Roovers <[email protected]>
  • Loading branch information
Jeroen Roovers committed Aug 13, 2020
1 parent 596902c commit 04014b1
Show file tree
Hide file tree
Showing 3 changed files with 40 additions and 4 deletions.
34 changes: 34 additions & 0 deletions app-pda/libplist/files/libplist-2.2.0-fmin.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
--- a/configure.ac
+++ b/configure.ac
@@ -79,19 +79,7 @@
esac
AM_CONDITIONAL(WIN32, test x$win32 = xtrue)

-# Check if we need libm for fmin
-CACHED_CFLAGS="$CFLAGS"
-CFLAGS="-O0"
-AC_CACHE_CHECK(if fmin is a builtin function, ac_cv_fmin_builtin,
- AC_TRY_LINK([
- #include <math.h>
- #include <float.h>
- ], [
- double val = 3.1415f * 0.55555f;
- double diff = fmin(val, DBL_MAX);
- if (diff > 0) return 1;
- ], ac_cv_fmin_builtin=yes, ac_cv_fmin_builtin=no))
-CFLAGS="$CACHED_CFLAGS"
+AC_SEARCH_LIBS([fmin],[m])

# Check if struct tm has a tm_gmtoff member
AC_CACHE_CHECK(for tm_gmtoff in struct tm, ac_cv_struct_tm_gmtoff,
@@ -153,10 +141,6 @@
AS_COMPILER_FLAGS(GLOBAL_CFLAGS, "-Wall -Wextra -Wredundant-decls -Wshadow -Wpointer-arith -Wwrite-strings -Wswitch-default -Wno-unused-parameter -Wno-strict-aliasing -fvisibility=hidden $PTHREAD_CFLAGS")
GLOBAL_LDFLAGS="$PTHREAD_LIBS"

-if test "x$ac_cv_fmin_builtin" != "xyes"; then
- GLOBAL_LDFLAGS+=" -lm"
-fi
-
AC_ARG_ENABLE(debug,
AS_HELP_STRING([--enable-debug],
[build debug message output code (default is no)]),
5 changes: 2 additions & 3 deletions app-pda/libplist/files/libplist-2.2.0-pkgconfig-lib.patch
Original file line number Diff line number Diff line change
@@ -1,6 +1,5 @@
diff -Naur libplist/src/libplist-2.0.pc.in libplist-pcfile/src/libplist-2.0.pc.in
--- libplist/src/libplist-2.0.pc.in 2020-07-18 17:25:52.156222244 +0300
+++ libplist-pcfile/src/libplist-2.0.pc.in 2020-07-18 17:26:32.752017958 +0300
--- a/src/libplist-2.0.pc.in
+++ b/src/libplist-2.0.pc.in
@@ -6,5 +6,5 @@
Name: @PACKAGE_NAME@
Description: A library to handle Apple Property Lists whereas they are binary or XML
Expand Down
5 changes: 4 additions & 1 deletion app-pda/libplist/libplist-2.2.0-r2.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -26,7 +26,10 @@ REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"

DOCS=( AUTHORS NEWS README.md )

PATCHES=( "${FILESDIR}"/libplist-2.2.0-pkgconfig-lib.patch )
PATCHES=(
"${FILESDIR}"/libplist-2.2.0-fmin.patch
"${FILESDIR}"/libplist-2.2.0-pkgconfig-lib.patch
)

BUILD_DIR="${S}_build"

Expand Down

0 comments on commit 04014b1

Please sign in to comment.