forked from gentoo/gentoo
-
Notifications
You must be signed in to change notification settings - Fork 0
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
gui-wm/hikari: version bump to 2.2.1
and pkg-config calling as well Closes: https://bugs.gentoo.org/741164 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Aisha Tammy <[email protected]> Signed-off-by: Joonas Niilola <[email protected]>
- Loading branch information
Showing
3 changed files
with
143 additions
and
0 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -1,2 +1,3 @@ | ||
DIST hikari-2.1.1.tar.gz 1012598 BLAKE2B 189e7bd9271ed5af89f5039288334c16a33c049c504f57e05cfa11b20098650165bb655023d016a14f2b13ed94e819bece088ef8517b9114b80d6a5921000780 SHA512 6da547d957cc65ab040647209a865550b0cc2b3d79040fae507591c41e938826861e27034379c21a1b7ce18afa35dbb813e96e661f4bd1232eb932f032271dff | ||
DIST hikari-2.1.2.tar.gz 1012670 BLAKE2B 9ce3dc08b3b9377458eba7299d5921466983c64ef7a9eb16194c4cf4dcb482af1313b9378bf733e38fd5bb0b8154553d7ab57a7e45db69932a2bb201ff29b041 SHA512 e4c1328414a2b99657fbce58139d5f6432580182ee277bc1fb8d3de1fa875675d78606dc8defd7997025caeac36f533ea9f34fca56c15a9a64dfa05c9c3e51b7 | ||
DIST hikari-2.2.1.tar.gz 1019168 BLAKE2B aa2ea50b665b3e5d62deba9565cab0d24694046d37dcd9aaa85d3581efbce339ea3f02630155fc731a7eb20dc7b4e4a301e5c6abfd1499ef962e6ef012184ca6 SHA512 640d4ef19cb445613e43fb3363ff00f13937ab256155129bbeba7adcd5f8aed1e4ddbcc6af13809c54ce14dc0d51933cc2763c8a990f44e49d6bfbf9daf62d80 |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,78 @@ | ||
diff --git a/Makefile b/Makefile | ||
index 555b770..01025b9 100644 | ||
--- a/Makefile | ||
+++ b/Makefile | ||
@@ -13,6 +13,7 @@ WITH_VIRTUAL_INPUT = YES | ||
OS != uname | ||
VERSION ?= "CURRENT" | ||
PREFIX ?= /usr/local | ||
+PKG_CONFIG ?= pkg-config | ||
ETC_PREFIX ?= ${PREFIX} | ||
|
||
OBJS = \ | ||
@@ -78,7 +79,7 @@ OBJS += \ | ||
xwayland_view.o | ||
.endif | ||
|
||
-WAYLAND_PROTOCOLS != pkg-config --variable pkgdatadir wayland-protocols | ||
+WAYLAND_PROTOCOLS != ${PKG_CONFIG} --variable pkgdatadir wayland-protocols | ||
|
||
.PHONY: distclean clean clean-doc doc dist install uninstall | ||
.PATH: src | ||
@@ -125,31 +126,31 @@ CFLAGS += -DHAVE_VIRTUAL_INPUT=1 | ||
|
||
CFLAGS += -Wall -I. -Iinclude -DHIKARI_ETC_PREFIX=${ETC_PREFIX} | ||
|
||
-WLROOTS_CFLAGS != pkg-config --cflags wlroots | ||
-WLROOTS_LIBS != pkg-config --libs wlroots | ||
+WLROOTS_CFLAGS != ${PKG_CONFIG} --cflags wlroots | ||
+WLROOTS_LIBS != ${PKG_CONFIG} --libs wlroots | ||
|
||
WLROOTS_CFLAGS += -DWLR_USE_UNSTABLE=1 | ||
|
||
-PANGO_CFLAGS != pkg-config --cflags pangocairo | ||
-PANGO_LIBS != pkg-config --libs pangocairo | ||
+PANGO_CFLAGS != ${PKG_CONFIG} --cflags pangocairo | ||
+PANGO_LIBS != ${PKG_CONFIG} --libs pangocairo | ||
|
||
-CAIRO_CFLAGS != pkg-config --cflags cairo | ||
-CAIRO_LIBS != pkg-config --libs cairo | ||
+CAIRO_CFLAGS != ${PKG_CONFIG} --cflags cairo | ||
+CAIRO_LIBS != ${PKG_CONFIG} --libs cairo | ||
|
||
-PIXMAN_CFLAGS != pkg-config --cflags pixman-1 | ||
-PIXMAN_LIBS != pkg-config --libs pixman-1 | ||
+PIXMAN_CFLAGS != ${PKG_CONFIG} --cflags pixman-1 | ||
+PIXMAN_LIBS != ${PKG_CONFIG} --libs pixman-1 | ||
|
||
-XKBCOMMON_CFLAGS != pkg-config --cflags xkbcommon | ||
-XKBCOMMON_LIBS != pkg-config --libs xkbcommon | ||
+XKBCOMMON_CFLAGS != ${PKG_CONFIG} --cflags xkbcommon | ||
+XKBCOMMON_LIBS != ${PKG_CONFIG} --libs xkbcommon | ||
|
||
-WAYLAND_CFLAGS != pkg-config --cflags wayland-server | ||
-WAYLAND_LIBS != pkg-config --libs wayland-server | ||
+WAYLAND_CFLAGS != ${PKG_CONFIG} --cflags wayland-server | ||
+WAYLAND_LIBS != ${PKG_CONFIG} --libs wayland-server | ||
|
||
-LIBINPUT_CFLAGS != pkg-config --cflags libinput | ||
-LIBINPUT_LIBS != pkg-config --libs libinput | ||
+LIBINPUT_CFLAGS != ${PKG_CONFIG} --cflags libinput | ||
+LIBINPUT_LIBS != ${PKG_CONFIG} --libs libinput | ||
|
||
-UCL_CFLAGS != pkg-config --cflags libucl | ||
-UCL_LIBS != pkg-config --libs libucl | ||
+UCL_CFLAGS != ${PKG_CONFIG} --cflags libucl | ||
+UCL_LIBS != ${PKG_CONFIG} --libs libucl | ||
|
||
CFLAGS += \ | ||
${WLROOTS_CFLAGS} \ | ||
@@ -192,7 +193,7 @@ wlr-layer-shell-unstable-v1-protocol.h: | ||
wayland-scanner server-header protocol/wlr-layer-shell-unstable-v1.xml ${.TARGET} | ||
|
||
hikari-unlocker: hikari_unlocker.c | ||
- ${CC} ${CFLAGS_EXTRA} ${LDFLAGS_EXTRA} -o hikari-unlocker hikari_unlocker.c -lpam | ||
+ ${CC} ${LDFLAGS} ${CFLAGS} ${INCLUDES} -o hikari-unlocker hikari_unlocker.c -lpam | ||
|
||
clean-doc: | ||
@test -e _darcs && echo "cleaning manpage" ||: |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,64 @@ | ||
# Copyright 2019-2020 Gentoo Authors | ||
# Distributed under the terms of the GNU General Public License v2 | ||
|
||
EAPI=7 | ||
|
||
inherit multiprocessing toolchain-funcs | ||
|
||
DESCRIPTION="Wayland compositor inspired by CWM" | ||
HOMEPAGE="https://hikari.acmelabs.space/" | ||
SRC_URI="https://hikari.acmelabs.space/releases/${P}.tar.gz" | ||
KEYWORDS="~amd64 ~x86" | ||
|
||
LICENSE="MIT" | ||
SLOT="0" | ||
IUSE="gamma layershell screencopy suid virtual-io +X" | ||
|
||
DEPEND=" | ||
dev-libs/libinput:= | ||
dev-libs/libucl | ||
>=gui-libs/wlroots-0.11.0[X?] | ||
media-libs/libglvnd | ||
x11-libs/cairo[X?,svg] | ||
x11-libs/libxkbcommon[X?] | ||
x11-libs/pango[X?] | ||
x11-libs/pixman | ||
sys-libs/pam | ||
" | ||
|
||
RDEPEND=" | ||
${DEPEND} | ||
x11-misc/xkeyboard-config | ||
" | ||
|
||
BDEPEND=" | ||
dev-libs/wayland-protocols | ||
sys-devel/bmake | ||
virtual/pkgconfig | ||
" | ||
|
||
PATCHES=( "${FILESDIR}"/${P}-pkgconfig.patch ) | ||
|
||
pkg_setup() { | ||
export MAKE=bmake | ||
tc-export CC PKG_CONFIG | ||
} | ||
|
||
src_compile() { | ||
|
||
${MAKE} -j$(makeopts_jobs) VERSION="{PV}" \ | ||
LDFLAGS="${LDFLAGS}" \ | ||
-DWITH_POSIX_C_SOURCE \ | ||
$(usex gamma -DWITH_GAMMACONTROL "") \ | ||
$(usex layershell -DWITH_LAYERSHELL "") \ | ||
$(usex screencopy -DWITH_SCREENCOPY "") \ | ||
$(usex suid -DWITH_SUID "") \ | ||
$(usex virtual-io -DWITH_VIRTUAL_INPUT "") \ | ||
$(usex X -DWITH_XWAYLAND "") \ | ||
all || die | ||
} | ||
|
||
src_install() { | ||
${MAKE} DESTDIR="${D}" PREFIX=/usr ETC_PREFIX=/ install || die | ||
doman share/man/man1/hikari.1 | ||
} |