Skip to content

Commit

Permalink
dev-util/radare2: bump up to 3.8.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-2.3.75, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <[email protected]>
  • Loading branch information
Sergei Trofimovich committed Sep 3, 2019
1 parent f52af5e commit 0437b96
Show file tree
Hide file tree
Showing 2 changed files with 57 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-util/radare2/Manifest
Original file line number Diff line number Diff line change
Expand Up @@ -2,3 +2,4 @@ DIST radare2-3.5.1.tar.gz 7083677 BLAKE2B 3d84e79d4e20e031b6cfdbabcf80922f977328
DIST radare2-3.6.0.tar.gz 7339427 BLAKE2B 60ecd110ac4cafa38dd10f49321e984e98f189398f15196614fb096970cc2f24981ffbbd161fdd55621b65c45a8fb9f843f273bf245ac0ea2b4493981ab0477d SHA512 15c02b744892934bd0b4beeb146d8a0289244405214b62892d7e307cd42f6706aca16c1e02b6b2beb5b6869c5c5920cc291ffec8a690b5338c6973a5e1d7900e
DIST radare2-3.7.0.tar.gz 7478494 BLAKE2B 547efda30a65783758b132f4b241039b83bb274904a1f69616e60ec83547b22da486e97df06a74cd82f855650dbc3802d31bf3cb00ebd12d956848efd4b6ff5e SHA512 8e4d1b89d0d1e717403ba0bc2ce47e2644d12303ed5391fe4b9efc11b86a0b9c9356fdea1caecabe16d88ded9577fe77c182225adf2fdbd63b2e48f9c9c9f52d
DIST radare2-3.7.1.tar.gz 7481103 BLAKE2B 4bae07dad298a45704ee45740bc3376902dfa35631efc94874666ead0b9c3dbb407558f4c02283d0909970247bc7730754cad9c6b6859a23ab40f408eff9102e SHA512 972c137e20d73a4cc8001c6d3e3b0c68874ed4a837d2ec20f26bc164a5451dbd46264471adc93332eecadd86d8023579fa69b42fce0291f49979b451118c7673
DIST radare2-3.8.0.tar.gz 7510078 BLAKE2B c3dcc28c0cda8c7c5f8dbc6d35c3d15fa73fec8402acfd5de0b3ea85ef0295608d2332efbb29a41e75239acafb66b1c3b946f58523d9e5bb605b70ddce3ce38d SHA512 c9a1a4e7743b54026990d7473f05fb8eb25d7a7f0fd985172587ce82b8f6fefb53dd181b0bdb8463d2460c71e4a9eb377ead4ef7379615c90aa858d8fcadeadb
56 changes: 56 additions & 0 deletions dev-util/radare2/radare2-3.8.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,56 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

inherit bash-completion-r1 eutils

DESCRIPTION="unix-like reverse engineering framework and commandline tools"
HOMEPAGE="http://www.radare.org"

if [[ ${PV} == *9999 ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/radare/radare2"
else
SRC_URI="https://github.com/radare/radare2/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi

LICENSE="GPL-2"
SLOT="0"
IUSE="ssl libressl"

RDEPEND="
dev-libs/capstone:0=
ssl? (
!libressl? ( dev-libs/openssl:0= )
libressl? ( dev-libs/libressl:0= )
)
"
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"

src_configure() {
econf \
--without-libuv \
--with-syscapstone \
$(use_with ssl openssl)
}

src_install() {
default

insinto /usr/share/zsh/site-functions
doins doc/zsh/_*

newbashcomp doc/bash_autocompletion.sh "${PN}"
bashcomp_alias "${PN}" rafind2 r2 rabin2 rasm2 radiff2

# a workaround for unstable $(INSTALL) call, bug #574866
local d
for d in doc/*; do
if [[ -d $d ]]; then
rm -rfv "$d" || die "failed to delete '$d'"
fi
done
}

0 comments on commit 0437b96

Please sign in to comment.