Skip to content

Commit

Permalink
games-roguelike/dwarf-fortress: Version bump
Browse files Browse the repository at this point in the history
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=567280

Package-Manager: portage-2.2.22
  • Loading branch information
Chris Reffett committed Dec 13, 2015
1 parent 920a520 commit 045794f
Show file tree
Hide file tree
Showing 2 changed files with 94 additions and 0 deletions.
1 change: 1 addition & 0 deletions games-roguelike/dwarf-fortress/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST df_40_24_linux.tar.bz2 12921246 SHA256 da37c6263a679123e6ac57fe0dd6def11f1d61efee3c5913de09495c88ce9234 SHA512 2242e471b7dbc996e819e2f74b2bbfda30a9a301755bc025ddcccdffdd3afe2e48bbedca31a332283ef829d023069398e57d6a87e26c582ddbce4a67ff7fd755 WHIRLPOOL 03cb652a2564d2b0c809be8252f7754d893f69ac1b95124ea108ed0fde9ac742c498d9e369339775695861e430a2ded0741b018f85551d48731730f98303dc69
DIST df_42_02_linux.tar.bz2 13754571 SHA256 660f3b5a8a5ca7073cb1fe8ba76fe7868f947d8542b2baa8634842acfd29ac09 SHA512 7e728018331daba53bed76a54bdc76b2f1070eaddd2e36dc7f9ccf54fbed1465d636e68e695bbfa788bd77897e17dc3c38ad562a327f51b437927d237841ae8d WHIRLPOOL e2ba9a941f0ac406e60a9ed28c3101301b8a7e19bb875cc9eac23668ac0ae14bfb00cd188ee43772e1f0312f7f8eff18248694dce3bae05110346964298962d8
93 changes: 93 additions & 0 deletions games-roguelike/dwarf-fortress/dwarf-fortress-0.42.02.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,93 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5

inherit eutils games multilib versionator

MY_PV=$(replace_all_version_separators _ "$(get_version_component_range 2-)")
MY_PN=df
MY_P=${MY_PN}_${MY_PV}

DESCRIPTION="A single-player fantasy game"
HOMEPAGE="http://www.bay12games.com/dwarves"
SRC_URI="http://www.bay12games.com/dwarves/${MY_P}_linux.tar.bz2"

LICENSE="free-noncomm BSD BitstreamVera"
SLOT="0"
KEYWORDS="~amd64 ~x86 -*"
IUSE="debug"

RDEPEND="media-libs/glew[abi_x86_32(-)]
media-libs/libsdl[abi_x86_32(-),opengl,video,X]
media-libs/libsndfile[abi_x86_32(-),alsa]
media-libs/sdl-image[abi_x86_32(-),jpeg,png,tiff]
media-libs/sdl-ttf[abi_x86_32(-)]
sys-libs/zlib[abi_x86_32(-)]
virtual/glu[abi_x86_32(-)]
x11-libs/gtk+:2[abi_x86_32(-)]"
# Yup, openal and ncurses are only needed at compile-time; the code dlopens it at runtime
# if requested.
DEPEND="${RDEPEND}
media-libs/openal[abi_x86_32(-)]
sys-libs/ncurses[abi_x86_32(-),unicode]
virtual/pkgconfig
x11-proto/kbproto[abi_x86_32(-)]
x11-proto/xproto[abi_x86_32(-)]"

S=${WORKDIR}/${MY_PN}_linux

gamesdir="${GAMES_PREFIX_OPT}/${PN}"
QA_PRESTRIPPED="${gamesdir}/libs/Dwarf_Fortress"

pkg_setup() {
games_pkg_setup

multilib_toolchain_setup x86
}

src_prepare() {
rm libs/*.so*
cp "${FILESDIR}"/{dwarf-fortress,Makefile} .
epatch_user
}

src_configure() {
tc-export CXX PKG_CONFIG
CXXFLAGS+=" -D$(use debug || echo N)DEBUG"
}

src_compile() {
default
sed -i -e "s:^gamesdir=.*:gamesdir=${gamesdir}:" ${PN} || die
}

src_install() {
# install data-files and libs
insinto "${gamesdir}"
doins -r raw data libs

# install our wrapper
dogamesbin ${PN}

# install docs
dodoc README.linux *.txt

prepgamesdirs

fperms 750 "${gamesdir}"/libs/Dwarf_Fortress
}

pkg_postinst() {
elog "System-wide Dwarf Fortress has been installed to ${gamesdir}. This is"
elog "symlinked to ~/.dwarf-fortress when dwarf-fortress is run."
elog "For more information on what exactly is replaced, see ${GAMES_BINDIR}/${PN}."
elog "Note: This means that the primary entry point is ${GAMES_BINDIR}/${PN}."
elog "Do not run ${gamesdir}/libs/Dwarf_Fortress."
elog
elog "Optional runtime dependencies: install sys-libs/ncurses[$(use amd64 && echo "abi_x86_32,")unicode]"
elog "for [PRINT_MODE:TEXT]. Install media-libs/openal$(use amd64 && echo "[abi_x86_32]") for audio output."
elog
games_pkg_postinst
}

0 comments on commit 045794f

Please sign in to comment.