Skip to content

Commit

Permalink
dev-ruby/async_sinatra: add 1.2.1
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.26
  • Loading branch information
graaff committed Jan 18, 2016
1 parent 364609f commit 048e70f
Show file tree
Hide file tree
Showing 2 changed files with 45 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/async_sinatra/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST async_sinatra-1.2.0-git.tgz 8194 SHA256 b62f1f7944fe2816fe418c9acf64ca73c2708b6ebd3bfa6e06dc693703faaa0a SHA512 abddfd78e6e6d1dbee8e463a10f3e233045f3321a828267e666399853fc6e1ab7661b8338193f1437cd9ef891a15323667b8f1e3dc89f2acc6ccc34b2aa16a6e WHIRLPOOL 109ececfd95de28e27a5c8be0b010690d1054db993cb764a2d5ac43edae9a5ccd031b75638523f568496bcdf7b0c67d23cfa1e209820bad1831686a5391ebaec
DIST async_sinatra-1.2.1-git.tgz 8314 SHA256 431d5b229d2e795707184caaf9e9bf0d4e1cb3402b9bfa9d7a6ee624f6ca8712 SHA512 f1c7dc5aeeae366836bc2db6ae1c34967fa4a8d89d2f0fdcbcfeb7737e7b39615990c67ba9d55428cc0873329b5b54e9a1df727b09c5d79b03210b4e209b56ba WHIRLPOOL d13fa0d3e19a3b4a22d8b8321248a635e8ca17ed78f1ec39f38bf2a3130e4d37fe2a929a28df9032ea5b9b8c8329b80fa43d1baf6284ff3a1285b08dc810e243
44 changes: 44 additions & 0 deletions dev-ruby/async_sinatra/async_sinatra-1.2.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,44 @@
# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
USE_RUBY="ruby20 ruby21 ruby22"

RUBY_FAKEGEM_DOCDIR="doc"
RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
RUBY_FAKEGEM_TASK_DOC="docs"

inherit ruby-fakegem

DESCRIPTION="Asynchronous response API for Sinatra and Thin"
HOMEPAGE="https://github.com/raggi/async_sinatra"
SRC_URI="https://github.com/raggi/async_sinatra/archive/v${PV}.tar.gz -> ${P}-git.tgz"

LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
IUSE="test"

ruby_add_bdepend "test? (
>=dev-ruby/hoe-3.13
>=dev-ruby/minitest-5.6:5
>=dev-ruby/eventmachine-0.12.11
dev-ruby/rack-test
)"
ruby_add_bdepend "doc? ( >=dev-ruby/hoe-2.9.1 )"

ruby_add_rdepend ">=dev-ruby/sinatra-1.3.2
>=dev-ruby/rack-1.4.1:*"

all_ruby_prepare() {
# Remove development dependencies that we don't have from the gemspec
sed -i -e '/\(hoe\|rdoc\)/d' async_sinatra.gemspec || die
}

all_ruby_install() {
all_fakegem_install

insinto /usr/share/doc/${PF}/
doins -r examples || die "Failed to install examples"
}

0 comments on commit 048e70f

Please sign in to comment.