Skip to content

Commit

Permalink
dev-ruby/webmock: add 3.13.0
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.20, Repoman-3.0.2
Signed-off-by: Hans de Graaff <[email protected]>
  • Loading branch information
graaff committed Jun 22, 2021
1 parent 3c15b7e commit 05baa99
Show file tree
Hide file tree
Showing 2 changed files with 70 additions and 0 deletions.
1 change: 1 addition & 0 deletions dev-ruby/webmock/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST webmock-3.11.3.gem 125952 BLAKE2B 664253079457cdf400be869b9e61092b12872282057540e42e6fb73a5fbaa38666757f7f8bd336e4f5c45ea1ec52f9af4b444ba67ae24db62a75b5c18636ae08 SHA512 80fd2139126e1e9d6907dfe93021d77179ae6c31cc2a63eb3ee47c011c2a48f18bb84ac08322da8def014f2293564f5669eb41037edbe72ffccfefb7ea281739
DIST webmock-3.13.0.gem 127488 BLAKE2B d92deda505469fc7fc5adbf0f7a90a462b03999c0affb79bf67523667af30f582b44b10f554c93a1c98e224edf1f8a5a700fc17c3624a962a68d8e61df84127f SHA512 de7c3d8e079f409db53b316238ce37a80db8eeb257e00c8b3f162e5b4f98c4a383108e6cb21be8b71db34295fdb2354502e9b7457741a935572d9afcb75b30c3
DIST webmock-3.7.6.gem 122368 BLAKE2B 9bc40971f1eec96d88217544acc67b7abfe6c0815a0696119e12fc5629b4f51e1164ecc982525d2c02fa50c7b1b09548c4831c1d597f06acde04a83227ba0dc9 SHA512 85455495476b22d94b23e34a92db3f0f8cf1aa5bb52ea6a8eb71f5f0bcbdad1edc13dff778c62806ec27850320e9f4e17f12525bbac552e5e105ee1ecd771efd
DIST webmock-3.8.3.gem 122880 BLAKE2B 66371028294f3b15172d718e0fa9402ad6ed1bf7beedb0c62621ad31758d25e401af9cd982a6f29cd1161a7e4d7954f6f9df22ab2e0c44c970a0edca3c0f1304 SHA512 6c845c4ed0c82ba4bb1f32d0d87a87eb945c54e159317aa14e2238b497d38282b7e81542e78c0d68d4b8d4a08e46137de84503829b7381e6d945e45474ebb507
69 changes: 69 additions & 0 deletions dev-ruby/webmock/webmock-3.13.0.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,69 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

USE_RUBY="ruby25 ruby26 ruby27"

RUBY_FAKEGEM_TASK_TEST="test spec NO_CONNECTION=true"

RUBY_FAKEGEM_EXTRADOC="CHANGELOG.md README.md"

inherit ruby-fakegem

DESCRIPTION="Allows stubbing HTTP requests and setting expectations on HTTP requests"
HOMEPAGE="https://github.com/bblimke/webmock"

LICENSE="GPL-2"
SLOT="3"
KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris ~x86-solaris"
IUSE=""

ruby_add_rdepend "
>=dev-ruby/addressable-2.3.6
>=dev-ruby/crack-0.3.2
>=dev-ruby/hashdiff-0.4.0:0
"

ruby_add_bdepend "test? (
dev-ruby/minitest:5
dev-ruby/rspec:3
>=dev-ruby/test-unit-3.0.0
dev-ruby/rack
>=dev-ruby/httpclient-2.8.0
)"

all_ruby_prepare() {
# Remove bundler support
rm Gemfile || die
sed -i -e '/[Bb]undler/d' Rakefile || die
sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
sed -i -e '1igem "test-unit"' test/test_helper.rb || die

# There is now optional support for curb and typhoeus which we don't
# have in Gentoo yet. em_http_request is available in Gentoo but its
# version is too old. patron's latest version is not compatible.
sed -i -e '/\(curb\|typhoeus\|em-http\|patron\)/ s:^:#:' spec/spec_helper.rb || die
rm -f spec/acceptance/{typhoeus,curb,excon,em_http_request,patron,async_http_client}/* || die

# Drop tests for dev-ruby/http for now since this package only works with ruby26
sed -i -e '/http_rb/ s:^:#:' spec/spec_helper.rb || die
rm -f spec/acceptance/http_rb/* || die

# Avoid httpclient specs that require network access, most likely
# because mocking does not fully work.
sed -i -e '/httpclient streams response/,/^ end/ s:^:#:' \
-e '/are detected when manually specifying Authorization header/,/^ end/ s:^:#:' \
spec/acceptance/httpclient/httpclient_spec.rb

# Avoid specs that require network access
sed -i -e '/when request is not stubbed/,/^ end/ s:^:#:' spec/acceptance/shared/callbacks.rb
}

each_ruby_test() {
${RUBY} -S rake test NO_CONNECTION=true || die
${RUBY} -S rspec-3 spec || die

einfo "Delay to allow the test server to stop"
sleep 10
}

0 comments on commit 05baa99

Please sign in to comment.