Skip to content

Commit

Permalink
media-video/gxine: Bump to version 0.5.908
Browse files Browse the repository at this point in the history
Package-Manager: portage-2.2.20.1
Signed-off-by: Lars Wendler <[email protected]>
  • Loading branch information
Lars Wendler committed Sep 8, 2015
1 parent b066835 commit 0638440
Show file tree
Hide file tree
Showing 2 changed files with 102 additions and 0 deletions.
1 change: 1 addition & 0 deletions media-video/gxine/Manifest
Original file line number Diff line number Diff line change
@@ -1 +1,2 @@
DIST gxine-0.5.907.tar.xz 910528 SHA256 b5c925806a35cb23a24a80a39d494cefb529e22c957987741f269a994ab258d5 SHA512 dd35c8a8810c233e81a28e9f10504645662d60dc9609451e7c49c5d516bb041b61a3b9c8f330021af1e527064cf3f62f37bde98402df7426f501d0c78c571045 WHIRLPOOL 01037e358c515f01bd42ec48e54d92e7672162098a4d0a279f979dd01d9a6354dd37f7194f36f9dfc804a8730bd792676cef39e48b608104724a787bf9c51e57
DIST gxine-0.5.908.tar.xz 917780 SHA256 832e47136ec68a573b22b6cc1c1d57607e78b05712ba9fb8e64464b5201ed9e7 SHA512 6172f442948655178fde837a5fa9194fdb06b5cc50f8cbbfcd153b72f9a360a5497bd7ebd09c8f2340547fd7a0c834d5c673712a13202768bf0c762ee41c5454 WHIRLPOOL 8e97e1f1d72a7b669c3346030522e4d2d755220fa337ad1a6486415f28d7ec375e4a5ae86fe2c7d3a4fb2ad84a76f5beb8d8c8ca7a4e06d9f1b0d1e01aebd00c
101 changes: 101 additions & 0 deletions media-video/gxine/gxine-0.5.908.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,101 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$

EAPI=5
inherit autotools eutils fdo-mime gnome2-utils multilib nsplugins

DESCRIPTION="GTK+ Front-End for libxine"
HOMEPAGE="http://xine.sourceforge.net/"
SRC_URI="mirror://sourceforge/xine/${P}.tar.xz"

LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
IUSE="linguas_cs linguas_de lirc nls nsplugin udev +xcb xinerama"

COMMON_DEPEND=">=media-libs/xine-lib-1.1.20
x11-libs/gtk+:2
>=dev-libs/glib-2
>=dev-lang/spidermonkey-1.8.2.15:0
x11-libs/libX11
x11-libs/libXext
x11-libs/libXrender
lirc? ( app-misc/lirc )
nls? ( virtual/libintl )
nsplugin? ( dev-libs/nspr
x11-libs/libXaw
x11-libs/libXt )
udev? ( virtual/libgudev:= )
xcb? ( x11-libs/libxcb )
xinerama? ( x11-libs/libXinerama )"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig
nls? ( sys-devel/gettext )"

src_prepare() {
# ld: cannot find -ljs
sed -i -e '/JS_LIBS="`spidermonkey_locate_lib/s:js:mozjs:' m4/_js.m4 || die

if has_version '>=dev-lang/spidermonkey-1.8.7:0'; then
sed -i -e 's:mozjs185:mozjs187:' m4/_js.m4 || die #422983
fi

epatch \
"${FILESDIR}"/${PN}-0.5.905-desktop.patch \
"${FILESDIR}"/${PN}-0.5.905-fix-nspr-useage.patch \
"${FILESDIR}"/${PN}-0.5.906-endif.patch \
"${FILESDIR}"/${PN}-0.5.907-underlinking.patch

# need to disable calling of xine-list when running without
# userpriv, otherwise we get sandbox violations (bug #233847)
if [[ ${EUID} == "0" ]]; then
sed -i -e 's:^XINE_LIST=.*$:XINE_LIST=:' configure.ac || die
fi

eautoreconf
}

src_configure() {
econf \
$(use_enable nls) \
$(use_enable lirc) \
--enable-watchdog \
$(use_with xcb) \
$(has_version '<dev-lang/spidermonkey-1.8.5' && echo --with-spidermonkey=/usr/include/js) \
$(use_with nsplugin browser-plugin) \
$(use_with udev gudev) \
--without-hal \
--without-dbus \
$(use_with xinerama)
}

src_install() {
emake DESTDIR="${D}" \
docdir=/usr/share/doc/${PF} \
docsdir=/usr/share/doc/${PF} \
install

dodoc AUTHORS BUGS ChangeLog README{,_l10n} TODO

use linguas_cs && dodoc README.cs
use linguas_de && dodoc README.de

use nsplugin && inst_plugin /usr/$(get_libdir)/gxine/gxineplugin.so
}

pkg_preinst() {
gnome2_icon_savelist
}

pkg_postinst() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
gnome2_icon_cache_update
}

pkg_postrm() {
fdo-mime_desktop_database_update
fdo-mime_mime_database_update
gnome2_icon_cache_update
}

0 comments on commit 0638440

Please sign in to comment.