Skip to content

Commit

Permalink
app-crypt/tpm2-tss-engine: fix libressl issue
Browse files Browse the repository at this point in the history
Closes: https://bugs.gentoo.org/show_bug.cgi?id=687084
Thanks: Toralf Förster
Signed-off-by: Alon Bar-Lev <[email protected]>
Package-Manager: Portage-2.3.66, Repoman-2.3.11
  • Loading branch information
alonbl committed May 31, 2019
1 parent c247b6e commit 068c8bd
Show file tree
Hide file tree
Showing 2 changed files with 36 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
From deb2b6697babf99aaf3f64b342ce414b48638ea3 Mon Sep 17 00:00:00 2001
From: Alon Bar-Lev <[email protected]>
Date: Fri, 31 May 2019 20:36:47 +0300
Subject: [PATCH] build: libressl fix incomplete type
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit

src/tpm2-tss-engine-rand.c:90:1: error: variable ‘rand_methods’ has initializer but incomplete type
90 | static RAND_METHOD rand_methods = {
| ^~~~~~
src/tpm2-tss-engine-rand.c:91:5: warning: excess elements in struct initializer

Signed-off-by: Alon Bar-Lev <[email protected]>
---
src/tpm2-tss-engine-rand.c | 1 +
1 file changed, 1 insertion(+)

https://github.com/tpm2-software/tpm2-tss-engine/pull/120

diff --git a/src/tpm2-tss-engine-rand.c b/src/tpm2-tss-engine-rand.c
index 50d5661..86980a5 100644
--- a/src/tpm2-tss-engine-rand.c
+++ b/src/tpm2-tss-engine-rand.c
@@ -32,6 +32,7 @@
#include <string.h>

#include <openssl/engine.h>
+#include <openssl/rand.h>

#include <tss2/tss2_mu.h>
#include <tss2/tss2_esys.h>
--
2.21.0

1 change: 1 addition & 0 deletions app-crypt/tpm2-tss-engine/tpm2-tss-engine-1.0.0.ebuild
Original file line number Diff line number Diff line change
Expand Up @@ -23,6 +23,7 @@ BDEPEND="virtual/pkgconfig"

PATCHES=(
"${FILESDIR}/${P}-build.patch"
"${FILESDIR}/${P}-libressl.patch"
)

src_prepare() {
Expand Down

0 comments on commit 068c8bd

Please sign in to comment.