Skip to content

Commit

Permalink
app-text/pdfarranger: bump to 1.7.1
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.18, Repoman-3.0.3
Signed-off-by: Andrey Grozin <[email protected]>
  • Loading branch information
Andrey Grozin committed Apr 27, 2021
1 parent 481b4d8 commit 06b886d
Show file tree
Hide file tree
Showing 2 changed files with 52 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-text/pdfarranger/Manifest
Original file line number Diff line number Diff line change
@@ -1,2 +1,3 @@
DIST pdfarranger-1.6.2.tar.gz 197726 BLAKE2B aee8ee7d32603f20bc01d9f5f77290390e8a038bf79e3c4f689a71ec1c3e454784b2225b43d33bdfd7897785827141cfe1770dcf41d233c4ec1f3865d6f1e3c0 SHA512 610c4dfaa141cfb8caebfc72b524cda05455ed4a5c1e336772655bd02ceac25fafedb439dbe83e87c88da189147eaf91149e9af92ec745a52f8a24fcee5fd390
DIST pdfarranger-1.7.0.tar.gz 236125 BLAKE2B f16eb23fb597a22a48f075ee6435c74d51a4c45d35e03ec02b2b2353c29ad327f36f6af9ef028ddc53777ecae069e62437728308cda2a6296bd520c2a54e1220 SHA512 8f3c804119d5e4aa78cdae1964757be3404977a68dacccddea0e3e598c531a0ae163567709358ccd60764bebf3a55b5ed1bfbd2e0392c97569ffd9a18f549552
DIST pdfarranger-1.7.1.tar.gz 236699 BLAKE2B b82a1f2309cc326bfba33458aaccee5396597a5c937c67baba767632cadddfae4f7ad21e0c86300c889f8e6d5f7dba9c6483b11bc97c83077e5ab01596b76617 SHA512 1adb5700b6497db95c3f727d1c18fc7b98ecc382cf15bc58bb7ce784d094e0d8cd45a26241e06a593eeb7601aa9f32ebba7d7f0f3a816e9384be09102eb0b4db
51 changes: 51 additions & 0 deletions app-text/pdfarranger/pdfarranger-1.7.1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,51 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 optfeature xdg-utils desktop

DESCRIPTION="Merge or split pdfs; rearrange, rotate, crop pages."
HOMEPAGE="https://github.com/jeromerobert/pdfarranger"
SRC_URI="https://github.com/jeromerobert/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"

LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64"
IUSE=""

RDEPEND="
app-text/poppler[introspection,cairo]
dev-python/pikepdf[${PYTHON_USEDEP}]
dev-python/pycairo[${PYTHON_USEDEP}]
dev-python/pygobject:3[${PYTHON_USEDEP},cairo]
dev-python/python-dateutil[${PYTHON_USEDEP}]
x11-libs/gtk+:3[introspection]
x11-libs/pango[introspection]
"
DEPEND="${RDEPEND}
dev-python/python-distutils-extra[${PYTHON_USEDEP}]
"

src_install() {
distutils-r1_src_install
for x in 16 32 48 256 scalable
do doicon -s ${x} data/icons/hicolor/${x}*/*
done
}

pkg_postinst() {
optfeature "image file import" media-gfx/img2pdf

xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

pkg_postrm() {
xdg_desktop_database_update
xdg_icon_cache_update
xdg_mimeinfo_database_update
}

0 comments on commit 06b886d

Please sign in to comment.