Skip to content

Commit

Permalink
app-emacs/auctex: Version bump to 12.3
Browse files Browse the repository at this point in the history
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Ulrich Müller <[email protected]>
  • Loading branch information
ulm committed Feb 6, 2021
1 parent 0de32ae commit 075af47
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
1 change: 1 addition & 0 deletions app-emacs/auctex/Manifest
Original file line number Diff line number Diff line change
@@ -1,3 +1,4 @@
DIST auctex-11.92.tar.gz 1486606 BLAKE2B 6e34d1da3bacad8f2baee2f13eb44a5b617a342c294ef4d7ba28059b678510e1d161f3f02fbcf38128c09ab4996a035e5ec28898134b967d88ad621b8b477845 SHA512 758bf82903ba0499decf0ade77c7ac70865132a24195d7e8794538b7857c448811b7ef26149a915b60ed3ee34c2ebaddb3282a320bd459c9ee3f461d6ee9b84e
DIST auctex-12.1.tar.gz 1476296 BLAKE2B 1dd5db94b5b7bb572919fdcb6c7dd2ea4d17f816204bedc69756610b80370ca748a06ab100ef8221107605a5e464b6a8c2587b728ba6a964776ea6dfeb7f7165 SHA512 4c27a3b16eaf98db164832497c497576fcabb274b24c6eb3060625b7711b1de91fce9a52f7c7caaec77a93768a6ce2ec173ab1ccb72f4c56c51cc4740d380d97
DIST auctex-12.2.tar.gz 1511396 BLAKE2B 02cad76c8846fc10dc1bd94d15fb1d6f56a9beead96deaa32a5e9a43241b232f021d9abe1965e10e53b941a223c500b301b1c467228bf8d9ed2646fa70bae647 SHA512 412e247ad9ba7feb768cade0a7098cc79991ccdf350248836813d572bfe2339f52c4e0e9ce631354e2c2d434217274aa9116e61d122a625a45a7f67aabd2316b
DIST auctex-12.3.tar.gz 1534283 BLAKE2B b70db839cd82805ed0410f8b92c5f19a78e92ee8f23d18962f0da77bdfdbac4264272805135c7f16ba35c461017aac74030071c85d2ff413f8eff542cad670d2 SHA512 29c411a7f18e0dd2d84edaf935e278cdf694644e01f40c26c26da403efa0a823fc3110c291d218bf930cad208dc249ca665dc20ccad5e2b44bd3caae828079ca
61 changes: 61 additions & 0 deletions app-emacs/auctex/auctex-12.3.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,61 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7
NEED_EMACS=24

inherit elisp

DESCRIPTION="Extensible package for writing and formatting TeX files in Emacs"
HOMEPAGE="https://www.gnu.org/software/auctex/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"

LICENSE="GPL-3+ FDL-1.3+"
SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~sparc-solaris"
IUSE="preview-latex"

RDEPEND="virtual/latex-base
preview-latex? (
app-text/dvipng
app-text/ghostscript-gpl
)"
BDEPEND="${RDEPEND}"

TEXMF="/usr/share/texmf-site"

src_configure() {
econf \
--with-emacs \
--with-auto-dir="${EPREFIX}/var/lib/auctex" \
--with-lispdir="${EPREFIX}${SITELISP}/${PN}" \
--with-packagelispdir="${EPREFIX}${SITELISP}/${PN}" \
--with-packagedatadir="${EPREFIX}${SITEETC}/${PN}" \
--with-texmf-dir="${EPREFIX}${TEXMF}" \
--disable-build-dir-test \
$(use_enable preview-latex preview)
}

src_compile() {
export VARTEXFONTS="${T}"/fonts
emake
}

src_install() {
emake -j1 DESTDIR="${D}" install
elisp-site-file-install "${FILESDIR}/50${PN}-gentoo.el"
if use preview-latex; then
elisp-site-file-install "${FILESDIR}/60${PN}-gentoo.el"
fi
dodoc ChangeLog* CHANGES FAQ INSTALL PROBLEMS.preview README RELEASE TODO
}

pkg_postinst() {
use preview-latex && texmf-update
elisp-site-regen
}

pkg_postrm() {
use preview-latex && texmf-update
elisp-site-regen
}

0 comments on commit 075af47

Please sign in to comment.