Skip to content

Commit

Permalink
kde-frameworks/kcompletion: Fix regression porting from + to | operator
Browse files Browse the repository at this point in the history
Upstream commit 7acda936f06193e9fc85ae5cf9ccc8d65971f657

KDE-Bug: https://bugs.kde.org/show_bug.cgi?id=431493
Package-Manager: Portage-3.0.14, Repoman-3.0.2
Signed-off-by: Andreas Sturmlechner <[email protected]>
  • Loading branch information
a17r committed Jan 25, 2021
1 parent fadf3a0 commit 07a4288
Show file tree
Hide file tree
Showing 2 changed files with 62 additions and 0 deletions.
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 7acda936f06193e9fc85ae5cf9ccc8d65971f657 Mon Sep 17 00:00:00 2001
From: Albert Astals Cid <[email protected]>
Date: Tue, 12 Jan 2021 23:43:19 +0100
Subject: [PATCH] Fix regression caused due to porting from operator+ to
operator|

BUGS: 431493
---
src/klineedit.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/src/klineedit.cpp b/src/klineedit.cpp
index 1cc9316..8201259 100644
--- a/src/klineedit.cpp
+++ b/src/klineedit.cpp
@@ -1222,7 +1222,7 @@ bool KLineEditPrivate::overrideShortcut(const QKeyEvent *e)
// but doesn't dare force as "stronger than kaction shortcuts"...
else if (e->matches(QKeySequence::SelectAll)) {
return true;
- } else if (qApp->platformName() == QLatin1String("xcb") && (key == Qt::CTRL | Qt::Key_E || key == Qt::CTRL | Qt::Key_U)) {
+ } else if (qApp->platformName() == QLatin1String("xcb") && (key == (Qt::CTRL | Qt::Key_E) || key == (Qt::CTRL | Qt::Key_U))) {
return true;
}

--
GitLab

35 changes: 35 additions & 0 deletions kde-frameworks/kcompletion/kcompletion-5.78.0-r1.ebuild
Original file line number Diff line number Diff line change
@@ -0,0 +1,35 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2

EAPI=7

ECM_DESIGNERPLUGIN="true"
PVCUT=$(ver_cut 1-2)
QTMIN=5.15.1
VIRTUALX_REQUIRED="test"
inherit ecm kde.org

DESCRIPTION="Framework for common completion tasks such as filename or URL completion"
LICENSE="LGPL-2+"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
IUSE="nls"

BDEPEND="
nls? ( >=dev-qt/linguist-tools-${QTMIN}:5 )
"
DEPEND="
>=dev-qt/qtgui-${QTMIN}:5
>=dev-qt/qtwidgets-${QTMIN}:5
=kde-frameworks/kconfig-${PVCUT}*:5
=kde-frameworks/kwidgetsaddons-${PVCUT}*:5
"
RDEPEND="${DEPEND}"

PATCHES=( "${FILESDIR}/${P}-fix-klineedit.patch" ) # KDE-Bug 431493

src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PythonModuleGeneration=ON # bug 746866
)
ecm_src_configure
}

0 comments on commit 07a4288

Please sign in to comment.